Bug 58418 - VIEWING: Keyboard accelerators should't be hidden without ALT-button pressed
Summary: VIEWING: Keyboard accelerators should't be hidden without ALT-button pressed
Status: RESOLVED DUPLICATE of bug 54169
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-17 15:21 UTC by Valentin
Modified: 2013-02-14 08:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (4.13 KB, image/png)
2012-12-17 15:21 UTC, Valentin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Valentin 2012-12-17 15:21:44 UTC
Created attachment 71660 [details]
Screenshot

Under Windows (since XP) and GNOME the underlined keyboard accelerators natively are hidden by default. They appear only after the pressure of ALT.

LibreOffice shows they allways. Would it be possible to show they only after the ALT-button is pressed?
Operating System: All
Comment 1 Marco Menardi 2013-01-01 16:13:21 UTC
I can confirm that LiBo always shows them regardless the OS or DE is running into.
I've checked LXDE (gtk based) and XP and apps there don't show the accelerator, only LiBo does.
I've to add that other OS, like Windows 2003, show always the underlined keyboard, and so does for instance KDE Plasma Desktop (even latest 4.10rc).
My personal opinion is that this "hide everything" UI trend is just madness from a user perspective, it's just cosmetics that damages usefulness.
Never less, I agree with the reporter that LiBo should conform with the environment and take as much as possible it's "look and feel".
So, since at least KDE (and some Windows versions) show the accelerator in the menu, LiBo code can't just remove them but needs to "adapt".
Comment 2 Samuel Mehrbrodt (CIB) 2013-02-14 08:25:00 UTC

*** This bug has been marked as a duplicate of bug 54169 ***