Bug Hunting Session
Bug 58425 - LibreOffice Draw program doesn't correctly open Visio Stencils (.vss/.vsx) and Templates (.vst/vtx)
Summary: LibreOffice Draw program doesn't correctly open Visio Stencils (.vss/.vsx) an...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-17 17:11 UTC by Michael
Modified: 2016-12-20 20:23 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments
Document Showing up Blank (1.01 MB, application/vnd.visio)
2012-12-17 17:37 UTC, Joel Madero
Details
Visio Stencil and Template [MicrosoftExchangeServer2007_Icons, .vss and .vst] (2.22 MB, application/x-zip-compressed)
2015-02-19 17:40 UTC, Maarten Hoes
Details
Screenshot of Visio Stencil opened in Visio 2013 [MicrosoftExchangeServer2007_Icons.vss] (103.28 KB, image/png)
2015-02-19 17:41 UTC, Maarten Hoes
Details
Screenshot Visio Stencil opened in LibreOffice [MicrosoftExchangeServer2007_Icons.vss] (61.64 KB, image/png)
2015-02-19 17:42 UTC, Maarten Hoes
Details
Visio 2013 Stencil and Template [MicrosoftExchangeServer2007_Icons, .vssx and .vstx] (1.67 MB, application/x-zip-compressed)
2015-02-19 17:49 UTC, Maarten Hoes
Details
Visio Stencil file, containing network switch stencils from D-Link (588.00 KB, application/x-ole-storage)
2015-09-27 17:52 UTC, Christoph Sold
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2012-12-17 17:11:12 UTC
I've attempted to open VSS files downloaded from the following site: http://www.visiocafe.com/downloads/ibm/IBM-3D.zip

After attempting to do so from several different places I'm concluding there may be an issue with how Draw interprets these file types.  Based on some libvisio doc I found it looks like each picture should open on a separate page that can be used in my own drawing.  

As it appears .vss files are supported in the latest release I've also tried this with 4.0.0beta1 and still encounter the same issue.

Since I don't have a Visio license, I'm unable to post a screen shot of what it looks like.

Other notes...
- I've tried this on win32 and also with Linux mint
- I've successfully opened vsd files with Draw

Through IRC it was suggested this defect can be Normal-Low but since this is my first time wasn't sure how to move to low.  This can be reclassified by the developer.

Thanks!!
Comment 1 Jorendc 2012-12-17 17:14:03 UTC
I can confirm this bug. 

When I try to open the .vss file, 'Draw' opens and shows an single empty page.

Tested with Mac OSX 10.8.2 and LibreOffice 4.0.0.0.beta1 (Bouw-id: 87906242e87d3ddb2ba9827818f2d1416d80cc7)
TinderBox: MacOSX TDF Release, Branch:libreoffice-4-0, Time: 2012-12-05_22:13:37 Dutch UI
Comment 2 Joel Madero 2012-12-17 17:37:15 UTC
Created attachment 71677 [details]
Document Showing up Blank

Just attached document directly to bug, confirmed that the bug does exist
Comment 3 Fridrich Strba 2012-12-17 19:26:46 UTC
(In reply to comment #0)
> Based on some
> libvisio doc I found it looks like each picture should open on a separate
> page that can be used in my own drawing.

Yeah, libvisio has an API to extract the stencils, but I never ever announced that LibreOffice would know what to do with it or that it would use that API.

> As it appears .vss files are supported in the latest release I've also tried
> this with 4.0.0beta1 and still encounter the same issue.

The only way you can get the stencils extracted is to use command-line vss2* tools. Where vss2odg is part of git master of writerperfect. The code is here: http://libwpd.git.sourceforge.net/git/gitweb.cgi?p=libwpd/writerperfect;a=summary
Comment 4 Michael 2012-12-17 19:52:01 UTC
Thanks for clarifying.
Comment 5 Rob Hagopian 2013-12-23 23:28:38 UTC
It sounds like this is now implemented:

http://libregraphicsworld.org/blog/entry/libreoffice-gets-visio-2013-support

But I'm having problems opening any of the VSS files from:

http://www.softwarestencils.com/uml/

They just open as blank documents if opened as 'Visio' file type or "incorrect file version" if opened without a file type specified.
Comment 6 Rob Hagopian 2013-12-23 23:29:42 UTC
(Sorry - I bumped the version but should have clarified in the comments too - this is with 4.1.2.3 from Linux Mint 16)
Comment 7 Michael 2013-12-29 04:01:16 UTC
I see the same problem as reported by Rob in version 4.1.4.2 on Windows platform.

When I attempt to open a .vss I get an error window with the message: "Version Incompatibility.  Incorrect file version."
Comment 8 sgt_b2002 2014-01-21 01:06:34 UTC
I see the same problem as Rob in Comment #5.
Version 4.1.3.2 running Gentoo Linux
Comment 9 Manfred Braun 2014-02-10 23:35:48 UTC
True for me also, using Windows 7 (all patches)
and LibreOffice 4.1.4.2.

Thanks,
++mabra
Comment 10 Kjeld Flarup 2014-03-04 13:57:34 UTC
http://www.cisco.com/web/about/ac50/ac47/2.html Tried to download these vss files but it failed on my Version: 4.1.4.2
Build ID: 4.1.4.2-4.fc20
Comment 11 retired 2014-03-04 17:00:44 UTC
Confirmed:4.2.1.1:OSX

Joel's test file does still showup blank.

@Kjeld: please post a direct link or attach a test file. The page you link to contains a ton of files.
Comment 12 Luc Novales 2014-09-09 09:17:44 UTC
Confirmed on Linux Debian 7.6 amd64 with versions :
version 4.2.6.2 Build ID: 420m0(Build:2) (Debian wheezy backports),
and
version 4.3.1.2 Build ID: 958349dc3b25111dbca392fbc281a05559ef6848 from LibreOffice website.

Michael test file 
http://www.visiocafe.com/downloads/ibm/IBM-3D.zip
and files from 
http://www.juniper.net/shared/visio-icons/juniper-m-series-icons.zip
does still showup blank without any error.

Luc.
Comment 13 Toni Ballesta 2015-02-18 19:21:33 UTC
I can confirm that lamentably also it happens with newer releases, like 4.2.8 and 4.3.5. On BSD or GNU/Linux, the libvisio version is 0.1.1. This happen with BSD, Linux and Windows.

I remember, on older version (months ago), import one vss file but now... I'm not really sure.

This is a really important step for academic and company productions.
Comment 14 David Tardon 2015-02-19 17:15:38 UTC
*** Bug 89469 has been marked as a duplicate of this bug. ***
Comment 15 Maarten Hoes 2015-02-19 17:40:41 UTC
Created attachment 113512 [details]
Visio Stencil and Template [MicrosoftExchangeServer2007_Icons, .vss and .vst]
Comment 16 Maarten Hoes 2015-02-19 17:41:58 UTC
Created attachment 113513 [details]
Screenshot of Visio Stencil opened in Visio 2013 [MicrosoftExchangeServer2007_Icons.vss]
Comment 17 Maarten Hoes 2015-02-19 17:42:36 UTC
Created attachment 113514 [details]
Screenshot Visio Stencil opened in LibreOffice [MicrosoftExchangeServer2007_Icons.vss]
Comment 18 Maarten Hoes 2015-02-19 17:49:54 UTC
Created attachment 113515 [details]
Visio 2013 Stencil and Template [MicrosoftExchangeServer2007_Icons, .vssx and .vstx]
Comment 19 Toni Ballesta 2015-02-19 21:43:41 UTC
More: 4.4.0.3 is the same, doesn't work (checked now only on Windows).
Comment 20 Robinson Tryon (qubit) 2015-03-05 14:27:45 UTC Comment hidden (obsolete)
Comment 21 actionmystique 2015-07-30 15:49:44 UTC
I confirm the issue on Ubuntu 15.04 with LO 4.4.4.3.
I get a blank page with this visio stencil vss for example: http://www.cisco.com/c/en/us/support/switches/catalyst-3850-16xs-s-switch/model.html
Comment 22 Christoph Sold 2015-09-27 17:52:46 UTC
Created attachment 119073 [details]
Visio Stencil file, containing network switch stencils from D-Link
Comment 23 Fridrich Strba 2016-01-15 09:33:10 UTC
Libvisio has API to extract stencils from the vss/vsx and vst/vtx files. However, LibreOffice does not have API to generate galleries on the fly. So this is a known problem, but not the importer's bug. You can however write a generator that parses the stencils/template files and generates the galleries. This cannot be though done in the real time while opening the document.
So, closing as NOTOURBUG
Comment 24 V Stuart Foote 2016-12-20 19:49:23 UTC
*** Bug 104147 has been marked as a duplicate of this bug. ***
Comment 25 V Stuart Foote 2016-12-20 20:01:26 UTC Comment hidden (obsolete)
Comment 26 V Stuart Foote 2016-12-20 20:23:24 UTC
Sorry for the noise--a bit of QA housekeeping, this back to closed NOB

enhancement to support import of Visio stencils (.vss/.vsx) tracked as bug 89469