Bug Hunting Session
Bug 58477 - EDITING, FORMATTING: No automatic line break after hyphen
Summary: EDITING, FORMATTING: No automatic line break after hyphen
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: All other
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 76966 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-18 20:48 UTC by Jonas Meurer
Modified: 2014-12-29 11:34 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the bug. (67.20 KB, image/png)
2012-12-20 00:09 UTC, Jonas Meurer
Details
Sample document for the bug. (10.81 KB, application/vnd.oasis.opendocument.text)
2012-12-20 00:10 UTC, Jonas Meurer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonas Meurer 2012-12-18 20:48:10 UTC
I discovered a regression in LibreOffice Writer 3.6.2.2 (Ubuntu 12.10):

In 3.5, a line break was added after hyphens, if this was reasonable for formatting. This no longer is the case in 3.6.2.2. In other words, hyphens in words now are treated as if they were non-breaking dashs. I confirmed that other Ubuntu 12.10 users have the same issue.

It's easy to reproduce this bug: write something in a new Writer document. At the end of a line, write a long word that doesn't match into the line. Add a simple hyphen (neither a protected/non-breaking dash, nor a definitive seperator) to the word. In earlier versions of LibreOffice, the line break was added behind the hyphen. Now, it's added in front of the full longword.

Kind regards,
 jonas
Comment 1 Jonas Meurer 2012-12-18 20:49:30 UTC
I forgot to mention that my native language is german, and that I have all german language/help/hyphen packages installed.
Comment 2 Urmas 2012-12-19 10:35:01 UTC
Please attach a screenshot and a sample document.
Comment 3 Jonas Meurer 2012-12-20 00:09:25 UTC
Created attachment 71829 [details]
Screenshot of the bug.
Comment 4 Jonas Meurer 2012-12-20 00:10:08 UTC
Created attachment 71830 [details]
Sample document for the bug.
Comment 5 ancow 2013-08-20 09:18:11 UTC
This problem is still present in LO 4.1.0.4 (Debian testing with LO from unstable). System and LO language is German.

(Setting this bug back to unconfirmed as the requested info was provided.)
Comment 6 Eric Botts 2013-12-13 03:15:33 UTC
This bug is still present in 4.1.3.2, and it is incredibly frustrating. I'm a writer, editor, and occasional book designer. This bug is forcing me either to add spaces after the hyphens of hyphenated words (which gets really annoying when I'm doing revisions or changing a book's layout) or to use other word processors (which is also annoying for a variety of reasons).

I hate to come off as surly or rude, but can someone PLEASE get on this?
Comment 7 Joel Madero 2013-12-20 17:32:08 UTC
It looks like it's been fixed in 4.3 at least - you can test this by installing a daily build http://dev-builds.libreoffice.org/daily/master/

I have gotten confirmation that is is also fixed in 4.2 RC1 which came out yesterday. You'll see a fix in 4.2 :)


Our team is incredibly stretched, if you have any free time (as little as 20 minutes a week), we would really appreciate any help ( no development skills needed, email me if you're interested in giving back to the community). Thanks!
Comment 8 Simo Kaupinmäki 2014-06-11 21:06:16 UTC
Just to note that I can still see this bug in LO 4.2.4.2 (Debian stable with LO from backports), but it does seem fixed in LO 4.3.0.0.beta2.
Comment 9 Simo Kaupinmäki 2014-06-12 07:27:39 UTC
*** Bug 76966 has been marked as a duplicate of this bug. ***
Comment 10 Aelfinn 2014-08-09 17:49:07 UTC
This bug is still (or again) present in LibreOffice 4.3.0.4, as installed on my elementary OS 0.2 via the LibreOffice PPA.
Comment 11 Aelfinn 2014-08-09 18:00:52 UTC
I had this problem before, btw, and it was only present in the version installed from the PPA; the version downloaded and installed manually was fine.
Comment 12 QA Administrators 2014-08-09 18:02:57 UTC
If it's back then verified is incorrect status - setting back to UNCONFIRMED so we can confirm it again on 4.3
Comment 13 David 2014-08-26 23:01:31 UTC
I'm now seeing this very bug in Writer Version: 4.3.0.4 Build ID: 430m0(Build:4); Linux Mint 13 LTS (Xfce). I get LibO from PPA.
Comment 14 tommy27 2014-08-31 18:31:19 UTC
Works fine with LibO 4.3.0.4 under Win7x64.

status in NEW because of independent confirmation in previous comment.

did you try retestesting under Linux with 4.3.1.2 as well?
Comment 15 Simo Kaupinmäki 2014-09-14 13:30:07 UTC
I have tested with 4.3.1.2, and this bug is still present on Debian stable if Libo is installed from the backports repository. However, the bug is NOT present if I download the same Libo version directly from the Libo download page and install it manually. This was also the case with Libo 4.2.6, which was the previous version available in Debian backports. Thus, as noted in comment 11, the bug seems to be linked to some special repositories (personal package archives, Debian backports). Furthermore, looking through the other comments, the bug primarily (only?) seems to affect .deb based distros (Debian, Ubuntu, Mint, Elementary). I'm therefore changing the platform metadata from "Linux (All)" into "other".

Besides the hyphen-minus (U+002D) and hyphen (U+2010), this bug seems to affect the en dash (U+2013) and several special space characters (U+2002 through U+2006 and U+2008 through U+200A). On the other hand, line break is correctly allowed after the regular space (U+0020), zero-width space (U+200B), soft hyphen (U+00AD), and em dash (U+2014, both before and after).
Comment 16 Björn Michaelsen 2014-10-11 00:39:40 UTC
Closing this one as NOTOURBUG because of Comment 11, this seems to be a packaging bug (possibly even only affecting backports).

CC'ing Rene as there are multiple references to Debian packages.

Also tested on Ubuntu 14.04 LTS with distro-provided 4.2.6.3 and can NOT reproduce the bug, this seems to work here.
Comment 17 Ulrich Moser 2014-10-14 15:02:51 UTC
Seems to work in actual version from Trusty packages on Ubuntu.
Version: 4.2.6.3
Build-ID: 420m0(Build:3)
Comment 18 Aelfinn 2014-12-28 18:44:00 UTC
@Björn:
How can this be classified as NOTOURBUG if it appears obvious that it is a problem originating from the packages contained *in the official LibreOffice PPA*?

In any case, this bug has been around for quite some time now, and I can’t quite believe that it hasn’t been fixed yet. Is there really nobody who is concerned about that quality of the packages publicly distributed via a very popular PPA?
Comment 19 Björn Michaelsen 2014-12-29 11:34:51 UTC
(In reply to Aelfinn from comment #18)
> @Björn:
> How can this be classified as NOTOURBUG if it appears obvious that it is a
> problem originating from the packages contained *in the official LibreOffice
> PPA*?

Its NOTOURBUG here on the upstream LibreOffice bug tracker, because it does not happen on TDFs release builds[1] here (at least this bug provided no such information). The PPA at https://launchpad.net/~libreoffice/+archive/ubuntu/ppa is a community effort by the Ubuntu community as per https://lists.launchpad.net/libreoffice/msg00072.html you can file bugs on launchpad for the ppa packages. As discribed that PPA is not officially supported by Canonical. If you want L3-support, you are invited to contact any of the companies named at http://www.libreoffice.org/get-help/professional-support/. E.g. Canonical might provide fixes for the packages in the official main repository via that route.


> In any case, ...

Please use bugzilla only for information that helps triaging or fixing bugs -- all other discussion does not belong here. Use e.g. the qa mailing list, if you have questions in how to get involved with QA.

[1] http://www.libreoffice.org/download/libreoffice-fresh/ or http://www.libreoffice.org/download/libreoffice-still/