Download it now!
Bug 58509 - FORMATTING: Changes to existing conditional formatting are not recorded in the undo list
Summary: FORMATTING: Changes to existing conditional formatting are not recorded in th...
Status: RESOLVED DUPLICATE of bug 57176
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-19 10:30 UTC by john.pratt
Modified: 2012-12-19 10:36 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
a document to edit in the steps to reproduce - it contains a simple conditional format in cell A1 (8.25 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-12-19 10:30 UTC, john.pratt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description john.pratt 2012-12-19 10:30:37 UTC
Created attachment 71795 [details]
a document to edit in the steps to reproduce - it contains a simple conditional format in cell A1

Problem description: when changing existing conditional formatting it is not possible to undo changes as they are not captured by the undo list, so cannot be undone.

Steps to reproduce:
1. open the attached document (or create a simple document with a conditional format, save, close and reopen to clear the undo list)
2A. change the conditional format in cell A1 to be active when the cell value is 2 using: Format -> Conditional formatting -> Condition
3. close the dialogue(s)

Steps to reproduce:
1. open the attached document (or create a simple document with a conditional format, save, close and reopen to clear the undo list)
2B. change the conditional format in cell A1 to be active when the cell value is 2 using: Format -> Conditional formatting -> Manage, and then selecting 'Edit...'
3. close the dialogue(s)

Current behavior: the undo button is deactivated as the change is not captured by the undo list, so it cannot be undone

Expected behavior: the undo button should allow this change to be undone      
Operating System: Windows XP
Version: 4.0.0.0.beta1
Comment 1 john.pratt 2012-12-19 10:36:16 UTC
Sorry - just found this which duplicates mine and I can confirm it is still present in 4.0 beta 1.

*** This bug has been marked as a duplicate of bug 57176 ***