Bug 58514 - re-rendering horrors in draw ...
Summary: re-rendering horrors in draw ...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: Other Linux (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2012-12-19 12:08 UTC by Michael Meeks
Modified: 2012-12-20 14:43 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Meeks 2012-12-19 12:08:49 UTC
I'm seeing lots of re-rendering bugs in draw with display dirt everywhere; to reproduce:

I start draw - I draw a black line; I enlarge it's width I now drag it around the sheet: it disappears. Force re-rendering the whole scene renders it again but ... wow that's not optimal :-)

I've seen similar behavior for other bits when loaded.

I draw a rectangular box - it should be blue filled: but I see only the outline, oddly I see the correct box in the preview on the left. When I force re-render it is back, but dragging it around the document the content disappears again.
Comment 1 Michael Meeks 2012-12-19 12:09:36 UTC
I'm seeing this with master to be fair not 4.0.0 but I assume it applies there ;-)
Comment 2 m.a.riosv 2012-12-19 17:03:26 UTC
Hi Michael,
I can not see this issues with:
Win7x64Ultimate.I3.Radeon HD5470.
LibreOffice Version 3.6.4.3 (Build ID: 2ef5aff)
LibreOffice Version Version 4.0.0.0.beta1 (Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)

Even changing the options in Graphics Output, for hardware acceleration and/or anti aliasing.
Comment 3 Michael Meeks 2012-12-20 12:28:20 UTC
Interesting - quite likely this is linux-only then; just adjusting that - thanks for trying ! :-)
Comment 4 Lucas Betschart 2012-12-20 14:09:38 UTC
I'm also unable to reproduce this bug.

Version 4.0.0.0.beta1 (Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)
Ubuntu 12.04, Intel Atom N450, Graphic: Intel® IGD x86/MMX/SSE2

I've also changed the Graphics Output options.

What's your graphic card? What driver do you use? Maybe try to switch between the open / closed source ones.
Do you have any other graphic problems in other applications?
Comment 5 Michael Meeks 2012-12-20 14:43:34 UTC
Can't reproduce now either myself - must have been some horrible transient partial build error.

Thanks guys & sorry for the noise :-) [ I'm using Intel so no driver problems I hope ;-]