Download it now!
Bug 58529 - Restore Windows Problem
Summary: Restore Windows Problem
Status: RESOLVED DUPLICATE of bug 39007
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.0.1 rc
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-19 18:22 UTC by Kathleen Baker
Modified: 2012-12-20 09:01 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Attatched is a screenshot of the window that will not go away. (75.41 KB, image/png)
2012-12-19 18:22 UTC, Kathleen Baker
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kathleen Baker 2012-12-19 18:22:42 UTC
Created attachment 71814 [details]
Attatched is a screenshot of the window that will not go away.

Problem description: When I open my LibreOffice, a pop-up window asks if I would like to restore my previous windows. I try clicking both options, and they blink as if I have successfully clicked them, but the window stays open. I am unable to get rid of this window no matter what I do, and then the program will not let me quit normally, I have to force quit. 

Steps to reproduce:
1. Open LibreOffice
2. Restore Windows window opens automatically
3. ....

Current behavior:

Expected behavior:
I expect the program to respond when I click "Do not Restore" or "Restore", and also to close with the normal Command+Q option instead of making me force quit. 
              
Operating System: Mac OS X
Version: 3.6.0.1 rc
Comment 1 Roman Eisele 2012-12-20 09:01:55 UTC
Thank you very much for your bug report!

This is a known problem; the main bug report for it is bug 39007 - “Persistent ‘Restore Windows’ dialog won’t disappear, disables key functionality”, at
  https://bugs.freedesktop.org/show_bug.cgi?id=39007

Please see that bug report for details, including some suggestions how to solve the problem, at least for some time (see comments no. 2, 6, and 20 there).
Basically, you need to delete the file
    org.libreoffice.script.savedState
from the folder
    ~/Library/Saved Application State/
(~ is your user/home folder) and then to reboot your Mac.

I hope that our developers will fix this issue soon and for good, but it seems
it is not easy to fix, it is some kind of terrible “misunderstanding” between
LibreOffice and MacOS X >= 10.7.

By the way: if you are still using LibreOffice 3.6.0.1, you might consider to update to the current release (3.6.4.3), which includes many useful bug fixes ...

Thank you again!

*** This bug has been marked as a duplicate of bug 39007 ***