Bug Hunting Session
Bug 58603 - EDITING: Content of text boxes in headers no more editable since v3.5
Summary: EDITING: Content of text boxes in headers no more editable since v3.5
Status: RESOLVED DUPLICATE of bug 52182
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-21 06:23 UTC by Michael Zaugg
Modified: 2012-12-21 22:43 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Testcase: Text is not editable with recent 3.5.* LO (30.99 KB, application/vnd.oasis.opendocument.text)
2012-12-21 06:23 UTC, Michael Zaugg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Zaugg 2012-12-21 06:23:18 UTC
Created attachment 71900 [details]
Testcase: Text is not editable with recent 3.5.* LO

Problem description:
Since the 3.5.x releases text boxes in headers are no more editable.
In the 4.0beta 1 the bug seems fixed.

In the document source the affected box is in styles.xml:
<draw:text-box><text:p text:style-name="foo">Maintitle</text:p><text:p text:style-name="bar">Subtitle</text:p></draw:text-box>

and

<draw:text-box><table:table table:name="Tabelle2" table:style-name="Tabelle2"><table:table-column table:style-name="Tabelle2.A"/><table:table-row table:style-name="Tabelle2.1"><table:table-cell table:style-name="Tabelle2.A1" office:value-type="string"><text:p text:style-name="MP2">Some Text</text:p></table:table-cell></table:table-row><table:table-row table:style-name="Tabelle2.2"><table:table-cell table:style-name="Tabelle2.A2" office:value-type="string"><text:p text:style-name="MP3"/></table:table-cell></table:table-row></table:table><text:p text:style-name="Sender"/></draw:text-box>


Steps to reproduce:
1. Open attached testcase in LO>=3.5
2. Try to change the existing text

Current behavior:
Cannot select and edit text.


Expected behavior:
Select text and edit. This worked before the new header/footer handling in 3.5.

Impact:
In our case users cannot adapt their template headers.
Operating System: All
Version: 3.6.4.3 release
Comment 1 manj_k 2012-12-21 22:43:54 UTC
Thanks, I have tested your attached 'testcase.odt'.

This problem has been reported (and fixed) in
→ Bug 52182 - cannot put cursor into frames with Wrap "In Background"
(see also the described workarounds for LO 3.5.x / 3.6.x).

The bug fix will be available in LibreOffice releases 4.0.0 / 3.6.5
(tested with LO-Dev 4.0.0.0.beta2, and LO-Dev 3.6.5.0+).

*** This bug has been marked as a duplicate of bug 52182 ***