Bug Hunting Session
Bug 58619 - gratuitously slow startup ...
Summary: gratuitously slow startup ...
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta2
Hardware: Other Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2012-12-21 12:58 UTC by Michael Meeks
Modified: 2013-01-16 20:28 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Meeks 2012-12-21 12:58:18 UTC
It seems that our pagein / wrapper logic is causing more grief than joy for us (somehow):

I would expect our shell wrapper, and splash bits to take around 100ms tops to get going on a warm machine etc. and yet I see a large discrepancy for us:

LibreOffice - 4.5bn callgrind pseudo-cycles for soffice.bin

time-wise that is:
	real 3.911s
	user 2.160s
	sys  0.348s

Timing ./soffice.bin alone gives us:
        real 1.633s
        ...

That is not ideal. Even more amusingly AOO does 2 bn more cycles in soffice.bin for the same file, but does so in a shorter time:

AOO - 6.5bn cycles ...
	real 2.023
	user 1.260
	sys  0.152

We should fix that :-)
Comment 1 Michael Meeks 2012-12-21 12:59:35 UTC
making a MAB - it's pretty silly; all numbers on Linux / gtk+ - openSUSE 12.2 32bit.
Comment 2 Michael Meeks 2012-12-21 13:32:40 UTC
Interestingly - this seems to be an artifact of a symlinked development build - I imagine sourcing 'ooenv' seems to be most of the grief - ~all of which is javaldx (I imagine) - though why javaldx should be -so- slow when it's run from ooenv - I have no idea.

time (. ./ooenv)

real	0m1.873s
user	0m1.148s
sys	0m0.176s

On a normal install I get:

real	0m1.197s
user	0m0.872s
sys	0m0.168s

for a full load/render of the relevant XLS file.
Comment 3 Michael Stahl (CIB) 2013-01-16 20:28:07 UTC
regression is a keyword - if the bug weren't already resolved INVALID i'd do that now based on abuse of "whiteboard" field :P