Bug 58635 - Calc - CONDITIONAL FORMATTING: dysfunctional during the cell selection of a condition.
Summary: Calc - CONDITIONAL FORMATTING: dysfunctional during the cell selection of a c...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: Other Windows (All)
: medium enhancement
Assignee: Markus Mohrhard
URL:
Whiteboard: target:5.4.0 target:5.3.3
Keywords:
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2012-12-21 21:34 UTC by Michel Rudelle
Modified: 2017-04-12 10:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Rudelle 2012-12-21 21:34:45 UTC
4.0.0.0.beta1 Version + (Build ID: b0eb7231a9643d71be3125be7248c91242339ab
under Vista

Steps to reproduce:

Purpose: Conditional Formatting on cell A1 of Sheet1 with the following condition: $Sheet1$A$1^2>$Sheet2.$D$1

1/ Format > Conditional Formatting > Condition
2/ select the condition "Formula is"
3/ position the cursor in the input box
4/ click cell A1: the input box contains: $Sheet1.$A$1
5/ with the keyboard, add  ^2>  to obtain: $Sheet1.$A$1^2> (leave the cursor remaining after >)
6a/ it is impossible to select Sheet2
6b/ so we try now to work on Sheet1: select cell D1, the input box now contains: $Sheet1.$A$1, the previous content is erased. We expected: $Sheet1$A$1^2>$Sheet1.$D$1

Points 6a and 6b worked correctly with versions 3.5 and earlier.
Confirmed on the French en-qa list
Comment 1 ydutrieux 2012-12-21 22:56:08 UTC
Confirmé sous libo Version 4.0.0.0.beta1+ (Build ID: 6d4a55bf38a1c470c49f904dbbddf94eb2f6154)

Win7 - 64bits
Comment 2 Markus Mohrhard 2012-12-21 23:46:11 UTC
Enhancement request against the new dialog.
Comment 3 Commit Notification 2017-04-09 02:29:14 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=42aece949ec96c775b31216bddd723aa5321e966

don't replace content of formula field when selecting range, tdf#58635

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 m.a.riosv 2017-04-09 11:40:28 UTC
Looks working fine, but change alone to sheet2 or the last selected sheet in the input box after leave CF's edition.
If after exit from CF you go again to edit CF, you find nothing, even although it's right because you are in a different sheet. But it seems if there was an error if you forgot that CFs are defined per sheet.

Version: 5.4.0.0.alpha0+
Build ID: 5a345f714f67594bb9e3f8914e89975a937872cf
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-04-09_02:25:47
Locale: es-ES (es_ES); Calc: CL
Comment 5 Commit Notification 2017-04-12 10:01:59 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dcd9eef1727efb7a909f8009fde4f34f26139522&h=libreoffice-5-3

don't replace content of formula field when selecting range, tdf#58635

It will be available in 5.3.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.