Download it now!
Bug 58674 - VIEWING: Customizable Nonprinting Character appearance
Summary: VIEWING: Customizable Nonprinting Character appearance
Status: RESOLVED DUPLICATE of bug 80054
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-23 08:16 UTC by christoph
Modified: 2015-09-01 07:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description christoph 2012-12-23 08:16:49 UTC
I use the view control characters option very often when correcting long scanned passages of text or even books. But the control characters are really annoying. On the one hand I need them, but on the other hand they are disturbingly big, fat and the same color as the text. So sometimes it is nearly impossible to recognize a comma or semicolon because of the overwhelming appearance of the space control character.

I found several forum entries of people who welcome such an option to customize the appearance, like changing the color to a light blue or just like the user wants it to be.

Would be of great help and I guess it is not even very hard to implement. Thanks for the great product and keep up the good work.

Merry christmas and a happy new year.

Christoph
Comment 1 Jorendc 2013-01-26 22:32:13 UTC
Thanks for reporting this enhancement!

I mark this as NEW because I can't find any duplicate so far.

(In reply to comment #0)
> I use the view control characters option very often when correcting long
> scanned passages of text or even books. But the control characters are
> really annoying. On the one hand I need them, but on the other hand they are
> disturbingly big, fat and the same color as the text. So sometimes it is
> nearly impossible to recognize a comma or semicolon because of the
> overwhelming appearance of the space control character.

Do you mean by 'control character' the Nonprinting Characters (ctrl+F10)?

Kind regards,
Joren
Comment 2 christoph 2013-01-28 10:06:24 UTC
Sorry, I'm using the German version though I was looking for the English translation I obvisiously got the wrong one.

Of course I mean the Nonprinting Characters.
Comment 3 Jorendc 2013-01-28 10:17:11 UTC
(In reply to comment #2)
> Sorry, I'm using the German version though I was looking for the English
> translation I obvisiously got the wrong one.
> 
> Of course I mean the Nonprinting Characters.

No problem :-). It's just to improve the title and for clarification.

Kind regards,
Joren
Comment 4 Al Maloney 2014-05-22 20:23:19 UTC
master~2014-05-20_23.56.34_LibreOfficeDev_4.3.0.0.alpha1_MacOS_x86

now has the nonprinting characters in blue.

However, the characters for the spaces often occur in the body of a word and not between the words.

I would like the option to choose the colour of these, as I find the blue to be too distracting.
Comment 5 Bert 2014-10-05 08:59:40 UTC
I noticed in fresh 4.3 that nonprintable characters had gone blue, and I HATE this ! There are so many important bugs to fix  (like erratic page numbering among other) that I don't see the value of coding such "improvements".
I have been used word processors for nearly 30 years and the paragrap mark in black never disturbed anyone (if you don't want to see it do not activate nonprintable characters display).
It worked perfectly before.
Comment 6 christoph 2014-10-08 07:37:25 UTC
@Bert: First: Maybe you calm down, read the first post and last but not least think before you post. You are invited to scan some old books with German "Fraktur" letters, OCR them and correct them in OO and tell me after it how easy things go with activated and deactivated or blue and black NPC.
This is a comment for feature requests and bug reports and not a place for unloading frustration. I am very happy about this and there are obvisiously more people like me. And if you don't need or like it just customize it black. That's what I asked for. Where is your problem? Software has changed the last 30 years otherwise we would still use typing machines... that's called progress. I hated the black NPC since I started using word processors back in Win 3.11.
I can understand that there are other bugs that need maintenance but that's the way it is. And there are bugs taking months to be corrected and feature requests fixed in seconds.
Comment 7 Cor Nouws 2015-09-01 07:41:41 UTC
(In reply to Al Maloney from comment #4)
> 
> I would like the option to choose the colour of these, as I find the blue to
> be too distracting.

Indeed. There is bug 80054 for this.
Cheers - Cor

*** This bug has been marked as a duplicate of bug 80054 ***