Bug Hunting Session
Bug 58766 - "enable macro recording" status lost at restart
Summary: "enable macro recording" status lost at restart
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: Other All
: medium normal
Assignee: LeMoyne Castle
URL:
Whiteboard: BSA target:4.1.0 target:4.0.0.1
Keywords: regression
: 58765 (view as bug list)
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2012-12-26 02:39 UTC by paolo_debortoli
Modified: 2013-01-05 13:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description paolo_debortoli 2012-12-26 02:39:01 UTC
I enabled tools -> options -> advanced -> allow macro registrations, but when I closed and restarted libreoffice it was automaticly disabled and I had to enable it again each time.
Operating System: Ubuntu
Version: 4.0.0.0.beta2
Comment 1 ugone 2012-12-26 08:24:31 UTC
I enabled tools -> options -> advanced -> allow macro registrations, but when I closed and restarted libreoffice it was automaticly disabled and I had to enable it again each time.

same thing to me
Operating System: Ubuntu
Version: 4.0.0.0.beta2
Comment 2 Jorendc 2012-12-26 12:27:28 UTC
(In reply to comment #1)
> I enabled tools -> options -> advanced -> allow macro registrations, but
> when I closed and restarted libreoffice it was automaticly disabled and I
> had to enable it again each time.
> 
> same thing to me
> Operating System: Ubuntu
> Version: 4.0.0.0.beta2

Ugone: if you can reproduce this bug, please set the status of this bug to 'NEW'.

I can reproduce with Mac OS X 10.8.2, LibreOffice 4.0.0.0.beta2 (Build ID: 4104d660979c57e1160b5135634f732918460a0)
TinderBox: MacOSX TDF Release, Branch:libreoffice-4-0, Time: 2012-12-18_17:13:13

So platform versions is not Linux only -> set platform = all
Comment 3 Jorendc 2012-12-26 12:35:58 UTC
Can reproduce it also with LibreOffice 4.0.0.0.beta1+ (Build ID: f4a1520c58f8bbbaf5027222c071374afb55961)
TinderBox: MacOSX-Intel@27-OSX_10.7.0-gcc_4.2.1_llvm, Branch:libreoffice-4-0, Time: 2012-12-16_21:58:26
Comment 4 tommy27 2012-12-27 18:33:09 UTC
confirming bug on Windows Vista 64bit using:
Version 4.0.0.0.beta1+ (Build ID: 546faa79bf3b1e4b222f182d43a9839106a398d)
Version 4.0.0.0.beta2+ (Build ID: 350ae8294a8df78403fd8cdce56b9aeb8178e13)

changing BUG description

adding REGRESSION keywords (LibO 3.6.4 remembers macro recorder status)
Comment 5 LeMoyne Castle 2012-12-28 00:05:58 UTC
*** Bug 58765 has been marked as a duplicate of this bug. ***
Comment 6 tommy27 2012-12-28 15:40:39 UTC
"macro recording" status correctly remembered on an old master release:
Version 3.7.0.0.alpha0+ (Build ID: 24761a6) tested on WinXP 32bit.
Comment 7 LeMoyne Castle 2012-12-28 23:05:10 UTC
Load (and thereby Commit) of the last misc. config item in the define block was broken by hole in the number sequence that effectively dropped off the last item, which just happened to be the Macro Recorder option.  See first change here: http://cgit.freedesktop.org/libreoffice/core/diff/svtools/source/config/miscopt.cxx?id=d9cf110dae8030c93c4cc7909b30c779b523359f

Simple fix patch today.
Replacement of fragile define implementation in later patch with other cleanup.
Comment 8 tommy27 2012-12-30 08:38:10 UTC
@LeMoyne Castle

I did not understand... is your patch already available or not in latest dailt build?
Comment 9 LeMoyne Castle 2013-01-01 02:36:50 UTC
(In reply to comment #8)
> @LeMoyne Castle
> 
> I did not understand... is your patch already available or not in latest
> dailt build?

Hi tommy, 
I messed up the patch (my 2d since 2011) in a couple different ways, so I abandoned it, studied my error, studied git help and logerrit howtos and resubmitted the patch.  Not yet pushed to master.  You can follow it with: https://gerrit.libreoffice.org/1523 

Gerrit should mark this bug when the patch is merged into master and the fix will be in nightly builds after that.
Comment 10 Not Assigned 2013-01-01 12:57:22 UTC
LeMoyne Castle committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4ae569eb3e6d587aed6885b46c78f0d9bcbbb0b2

Minimal fix fdo#58766 Macro Recorder opt not saved



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 tommy27 2013-01-01 15:02:40 UTC
nice to see that it has been pushed to master (future 4.1)

however I think it deserves to be pushed to 4.0 final as well since it restores a function that worked in 3.6.x and got screwed during early 4.0 beta development.
Comment 12 tommy27 2013-01-02 13:06:23 UTC
as expected the bug is still present on latest 4.0.0.0.beta2+ (Build ID: 5ee54bcb9c7713c7233b0bb9f7671c6e6104758) (2013-01-02_08.49.10) 

please, backport from 4.1 to 4.0.
Comment 13 Jorendc 2013-01-03 12:45:10 UTC
I saw on gerrit it was merged (https://gerrit.libreoffice.org/#/c/1523/)

Tested using Mac OSX and LibreOffice 4.1.0.0.alpha0+ (Build ID: 73731b01cd65defdf9b42a9754bede3ba84221d)
TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master, Time: 2013-01-02_08:47:51

Can't reproduce anymore: RESOLVED -> FIXED

Many thanks LeMoyne Castle for this fast fix!
Comment 14 tommy27 2013-01-03 12:48:31 UTC
nice to know that it's fixed in 4.1.

as I said before, this is a 4.0 MAB, so it should be fixed in the 4.0 branch as well.
Comment 15 Jorendc 2013-01-03 13:29:59 UTC
(In reply to comment #14)
> nice to know that it's fixed in 4.1.
> 
> as I said before, this is a 4.0 MAB, so it should be fixed in the 4.0 branch
> as well.

I asked this question to a core developer (Markus Mohrhard) on IRC-chat. He said that every developer is allowed till the first release candidate (RC1) of LO 4.0 to backport his bugfix by himself (after that, it'll require a review by a peer-developer first).
So, we need to be patient :-).
Comment 16 tommy27 2013-01-03 14:47:56 UTC
(In reply to comment #15)
> (In reply to comment #14)
> > 
> > as I said before, this is a 4.0 MAB, so it should be fixed in the 4.0 branch
> > as well.
> 
> I asked this question to a core developer (Markus Mohrhard) on IRC-chat. He
> said that every developer is allowed till the first release candidate (RC1)
> of LO 4.0 to backport his bugfix by himself (after that, it'll require a
> review by a peer-developer first).
> So, we need to be patient :-).


sure, I did not want to seem pushy... I just wanted to be sure that backporting to 4.0 won't be forgotten!!!

anyway RC1 timeframe is "Jan 7 - Jan 13, 2013" so there's still time to directly backporting without external review.

for what I can see, it was an easy fix.
Comment 17 Not Assigned 2013-01-04 07:18:25 UTC
LeMoyne Castle committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=65deb382fb2bc45192f3b9224bf0fca00955ee71&h=libreoffice-4-0

Minimal fix fdo#58766 Macro Recorder opt not saved


It will be available in LibreOffice 4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 18 tommy27 2013-01-05 13:58:19 UTC
I confirm that it's fixed in Version 4.0.0.0.beta2+ (Build ID: 65deb382fb2bc45192f3b9224bf0fca00955ee7) as well.

thanks to LeMoyne Castle.