Bug 58786 - File -> Wizards -> Document converter does not open at all in Ubuntu/Linux
Summary: File -> Wizards -> Document converter does not open at all in Ubuntu/Linux
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-26 22:00 UTC by Gerry
Modified: 2013-11-26 14:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Converter on LibreOffice 3.5 (50.23 KB, image/png)
2013-02-01 12:36 UTC, vulcain
Details
converter on LibreOffice 3.4 (58.38 KB, image/png)
2013-02-01 12:37 UTC, vulcain
Details
Message at the end: choose ASCII (118.36 KB, image/png)
2013-02-01 12:40 UTC, vulcain
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2012-12-26 22:00:17 UTC
Problem: Since the legacy binary StarOffice files: 1.0 -> 5.0 will not be supported anymore in LibreOffice 4, I wanted to mass-convert my old StarOffice files to ODF. As suggested I wanted to use the Document Converter wizard. However the wizard seems to be fundamentally broken on Ubuntu.

How to reproduce:
* Open Writer
* Choose File -> Wizards -> Document converter
* Result: Nothing happens. The wizard does not open. The click on "Document converter" simply has not effect.

Systems (same problems on both systems): 
Ubuntu 12.10, Version 3.6.2.2 (Build ID: 360m1(Build:2)) (from Ubuntu repository)
Ubuntu 11.10, Version ibreOffice 3.5.4.2  Build ID: 350m1(Build:2) (Libreffice PPA)
Comment 1 Rob Snelders 2013-01-01 12:25:30 UTC
In 4.0-beta2 in Ubuntu 12.04 x86_64 it works. But that would still be useless to you. I can't try with older versions as I don't have those installed. Hopefully somebody else can try.
Comment 2 Michael Stahl (allotropia) 2013-01-14 17:31:17 UTC
maybe the problem only happens on Ubuntu?

the wizard is implemented in StarBASIC so it's
definitely not a JVM problem.

can't reproduce this bug here on Fedora, but
i've just found and fixed a different bug that would prevent
you from actually using Document Converter, bug 59366.
Comment 3 Gerry 2013-01-17 23:48:48 UTC
Can anyone with Ubuntu (12.10) test this issue and confirm this bug? Thanks.

This would be really helpful, because only if this bug is fixed and the document converter works again old .sdw, .sdc,... files can be auto-converted to the ODF files.
Comment 4 vulcain 2013-01-19 15:49:30 UTC
@ Gerry: If you had some files for test. I try to use them and test if it work LibreOffice 3.5.7 or LibreOffice 4.0 on Ubuntu 12.04

I haven't any of this legacy binary StarOffice files and don't find them on the web.
Comment 5 Gerry 2013-01-19 16:29:55 UTC
@Vulcain: Thanks for looking into the bug. On my system, the document converter actually does not open at all. Maybe you can just test whether it works on yours.


My system:
Ubuntu 12.10, 64-bit, LibreOffice (Ubuntu Repositories) Version 3.6.2.2 (Build ID: 360m1(Build:2))

P.S: In case you need some old .sdw or .sdc files, I can send you some.
Comment 6 vulcain 2013-01-19 19:02:17 UTC
I could convert .doc, .xls, .ppt with LibreOffice 3.5.7 or 4.0 on Ubuntu 12.04

Yes, i need some .sdw or .sdc files.
Comment 7 vulcain 2013-02-01 12:36:50 UTC
Created attachment 74043 [details]
Converter on LibreOffice 3.5

I reproduce on Ubuntu 12.04 with LibreOffice 3.5.7.2 (from Ubuntu repository precise-proposed) or LibreOffice from libreoffice.org

I don't reproduce on Ubuntu 11.10 with LibreOffice 3.4.4, i have just a message at the end.
Comment 8 vulcain 2013-02-01 12:37:32 UTC
Created attachment 74044 [details]
converter on LibreOffice 3.4
Comment 9 vulcain 2013-02-01 12:40:32 UTC
Created attachment 74045 [details]
Message at the end: choose ASCII

May be, it's not a bug but a feature: converter sdw, sdc, sdd could not be doing with LibreOffice 3.5 and next.

I don't see that on the release note: https://wiki.documentfoundation.org/ReleaseNotes/3.5
Comment 10 Michael Stahl (allotropia) 2013-02-01 12:41:25 UTC
vulcain, i don't exactly see what you are trying to say.

it seems you have reproduced not this bug, but instead bug 59366.

this means this bug still happens only for Gerry.
Comment 11 vulcain 2013-02-01 12:46:39 UTC
@ Michael Stahl : I try to reproduce and i follow Gerry's step. May be this bug is duplicated of https://bugs.freedesktop.org/show_bug.cgi?id=59366
Comment 12 Gerry 2013-02-01 16:49:51 UTC
Thanks Vulcain, thanks Michael for looking into this bug. 

I think Michael is right, what Vulcain has discovered in his test is exactly what is described in bug 59366.

This bug report here is different, though. On my system, no dialog appears at all. When I click on "File"->"Wizards"->"Document Converter" simply nothing happens. No dialog appears. 

Can anyone please test this on Ubuntu 12.10 with the LibreOffice version that comes with Ubuntu?
Comment 13 Julien Nabet 2013-03-03 19:48:29 UTC
Gerry: did you try to launch LO and Document converter from console to see if there could be some warning or error messages?
Comment 14 Gerry 2013-03-03 19:58:23 UTC
Dear Julien, thanks for looking into this bug:

I started "libreoffice" from the console and then tried to open the Document converter. There were no error messages.

Is there a way to open the document converter directly from the console?
Comment 15 Julien Nabet 2013-03-03 20:19:04 UTC
Gerry:
I don't use LO in console mode so I don't know much about this but when running
"soffice --help", it shows options like:
--headless     like invisible but no userinteraction at all.

--infilter=<filter>
      Force an input filter type if possible
      Eg. --infilter="Calc Office Open XML"
--convert-to output_file_extension[:output_filter_name] [--outdir output_dir] files
      Batch convert files.
      If --outdir is not specified then current working dir is used as output_dir.
      Eg. --convert-to pdf *.doc
          --convert-to pdf:writer_pdf_Export --outdir /home/user *.doc
Comment 16 Gerry 2013-03-07 21:00:08 UTC
Thanks Julien. The following commands on the command line work:

libreoffice --headless --convert-to odt *.sdw
libreoffice --headless --convert-to odp *.sdd
libreoffice --headless --convert-to odg *.sda
libreoffice --headless --convert-to ods *.sdc

It is a work around for the bug, but the bug is still there. So I leave it open for now.
Comment 17 Julien Nabet 2013-05-30 20:26:31 UTC
Gerry: could you give a try to 4.0.3? This version is proposed for Ubuntu 12.10 on LO ppa (see https://launchpad.net/~libreoffice/+archive/ppa).
Comment 18 Björn Michaelsen 2013-05-31 00:15:36 UTC
Document converter works perfectly fine on LibreOffice 4.0.2 on Ubuntu 13.10 (saucy). Please make sure you have a libreoffice packages installed.
Closing bug as WORKSFORME.

As for the unrelated discussion on document conversion, unoconv should be of service:

 https://launchpad.net/ubuntu/+source/unoconv

but please keep that discussion out of this bug as it does not belong here as a support/help request better served on ask.libreoffice.org.
Comment 19 Gerry 2013-06-10 17:39:12 UTC
i reopen the issue, since the problem is still existing on my system.

A few weeks ago I updated to Ubuntu 13.04. Still the document converter does not open at all. I tested this with the old user preferences and after that also with a completely new user configuration in .config/libreoffice. In both cases, the document converter does not open. 

LibreOffice version: Version 4.0.2.2 (Build ID: 400m0(Build:2)). I think I have all relevant LibreOffice packages installed. Also, Java is enabled.
Comment 20 Markus 2013-08-02 21:09:37 UTC
I can confirm this bug.

Ubuntu 12.10; AMD 64 bit; LibreOffice Version 3.6.2.2 (Build ID: 360m1(Build:2))

Since LibreOffice does not seem to have a debug mode, I straced it.

$ strace -f -e open,stat,lstat,fstat,process libreoffice

[ignore all the startup into its start screen]

This is what one gets if one selects File->Wizards->Euro Converter

[pid  5794] lstat("/usr/lib/libreoffice/program/../program/resource/euren-US.res", {st_mode=S_IFREG|0644, st_size=4656, ...}) = 0
[pid  5794] open("/usr/lib/libreoffice/program/../program/resource/euren-US.res", O_RDONLY) = 34
[pid  5794] fstat(34, {st_mode=S_IFREG|0644, st_size=4656, ...}) = 0
[pid  5794] open("/D:/office630np/share/template/german/wizard/bitmap/euro_2.bmp", O_RDONLY|O_EXCL) = -1 ENOENT (No such file or directory)
[pid  5794] lstat("/usr", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid  5794] lstat("/usr", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid  5794] lstat("/usr/lib", {st_mode=S_IFDIR|0755, st_size=102400, ...}) = 0
[pid  5794] lstat("/usr", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid  5794] lstat("/usr/lib", {st_mode=S_IFDIR|0755, st_size=102400, ...}) = 0
[pid  5794] lstat("/usr/lib/libreoffice", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid  5794] lstat("/usr", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid  5794] lstat("/usr/lib", {st_mode=S_IFDIR|0755, st_size=102400, ...}) = 0
[pid  5794] lstat("/usr/lib/libreoffice", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid  5794] lstat("/usr/lib/libreoffice/program", {st_mode=S_IFDIR|0755, st_size=36864, ...}) = 0
[pid  5794] lstat("/usr", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid  5794] lstat("/usr/lib", {st_mode=S_IFDIR|0755, st_size=102400, ...}) = 0
[pid  5794] lstat("/usr/lib/libreoffice", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid  5794] lstat("/usr/lib/libreoffice/program", {st_mode=S_IFDIR|0755, st_size=36864, ...}) = 0
[pid  5794] lstat("/usr/lib/libreoffice/program/libtklo.so", {st_mode=S_IFREG|0644, st_size=3890336, ...}) = 0
[pid  5794] lstat("/usr", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid  5794] lstat("/usr", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid  5794] lstat("/usr/lib", {st_mode=S_IFDIR|0755, st_size=102400, ...}) = 0
[pid  5794] lstat("/usr", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid  5794] lstat("/usr/lib", {st_mode=S_IFDIR|0755, st_size=102400, ...}) = 0
[pid  5794] lstat("/usr/lib/libreoffice", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid  5794] lstat("/usr", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid  5794] lstat("/usr/lib", {st_mode=S_IFDIR|0755, st_size=102400, ...}) = 0
[pid  5794] lstat("/usr/lib/libreoffice", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid  5794] lstat("/usr/lib/libreoffice/program", {st_mode=S_IFDIR|0755, st_size=36864, ...}) = 0
[pid  5794] lstat("/usr", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid  5794] lstat("/usr/lib", {st_mode=S_IFDIR|0755, st_size=102400, ...}) = 0
[pid  5794] lstat("/usr/lib/libreoffice", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid  5794] lstat("/usr/lib/libreoffice/program", {st_mode=S_IFDIR|0755, st_size=36864, ...}) = 0
[pid  5794] lstat("/usr/lib/libreoffice/program/libtklo.so", {st_mode=S_IFREG|0644, st_size=3890336, ...}) = 0
[pid  5794] lstat("/home/baumeist/Dokumente", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid  5794] lstat("/usr/lib/libreoffice/program/../share/template/en-US/../wizard/bitmap", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid  5794] open("/usr/lib/libreoffice/program/../share/template/en-US/../wizard/bitmap/euro_2.bmp", O_RDONLY|O_EXCL) = 44

[BTW, opening a file on "D:" under Linux?]

and this is what one gets when selecting File->Wizards->Document Converter

[pid  5794] lstat("/usr/lib/libreoffice/program/../share/template/en-US/../wizard/bitmap", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0

Looks as if something is amiss. Any suggestions as to what to strace for? Does anyone need the strace dump from startup?
Comment 21 Julien Nabet 2013-08-03 13:57:05 UTC
Markus: you use 3.6.2, could you give a try to LO > 4.0.2?
Gerry/Markus: Bjoern had indicated Ubuntu >= 13.10. Perhaps Ubuntu < 13.10 had packages problems
Comment 22 Gerry 2013-08-03 19:25:23 UTC
The most up-to-date LibreOffice in Ubuntu 13.04 repositories is Version 4.0.2.2 (Build ID: 400m0(Build:2)). The problem is there with this system/version.
Comment 23 Julien Nabet 2013-08-04 06:35:59 UTC
Gerry: in LO ppa, there's 4.1.0, see https://launchpad.net/~libreoffice/+archive/ppa. Would it be possible you give it a try?
Comment 24 Gerry 2013-08-05 09:56:34 UTC
I tried with the PPA version: 4.1.0.4
Build ID: 410m0(Build:4) and the problem is also there. Nothing has improved. Clicking on File -> Wizards -> Document Converter does nothing.