Bug 59366 - Document Conversion wizard does not list "StarOffice" file types
Summary: Document Conversion wizard does not list "StarOffice" file types
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: Other All
: highest normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:3.6.5
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-01-14 16:27 UTC by Michael Stahl (CIB)
Modified: 2013-02-01 12:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Stahl (CIB) 2013-01-14 16:27:18 UTC
File->Wizards->Document Converter... dialog only lists "Microsoft Office"
but not "StarOffice" formats in 3.5.x and 3.6.x releases.

this is a regression from f3e40273b699910108007faf8a7991fe0498ad97
which does not actually return the value from the new function.

i'd like to fix this ASAP because binfilter was removed in 4.0
(which naturally doesn't show "StarOffice" in the dialog either,
but that is intentional because the required filters are gone)
so users want to use their 3.x release to convert their legacy docs.
Comment 1 Not Assigned 2013-01-14 17:27:59 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=959ce73b266d3639ff1ced9cb980adf5fe643ad5&h=libreoffice-3-6

fdo#59366: Document Conversion wizard: enable "StarOffice" again:


It will be available in LibreOffice 3.6.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.