Bug Hunting Session
Bug 58797 - Date field format contain excess quotation mark in Hungarian version
Summary: Date field format contain excess quotation mark in Hungarian version
Status: RESOLVED DUPLICATE of bug 58179
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta2
Hardware: Other All
: medium normal
Assignee: Eike Rathke
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-27 08:26 UTC by Zoltán Reizinger
Modified: 2013-11-14 14:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
example file, with fields (8.99 KB, application/vnd.oasis.opendocument.text)
2012-12-27 08:26 UTC, Zoltán Reizinger
Details
example file, with fields (8.99 KB, application/vnd.oasis.opendocument.text)
2013-01-03 23:10 UTC, Rob Snelders
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zoltán Reizinger 2012-12-27 08:26:17 UTC
Created attachment 72170 [details]
example file, with fields

Date field format contain excess quotation mark in Hungarian version, in some date format. See attached example file.

This happens in writer, and reports in Base, where I tested.
Comment 1 Rob Snelders 2013-01-03 23:10:48 UTC
Created attachment 72488 [details]
example file, with fields
Comment 2 Joel Madero 2013-01-11 20:33:50 UTC
@Rob - since you made attachment can we assume that you verified bug?
Comment 3 Andras Timar 2013-01-11 20:46:27 UTC
Laci, can you take a look at this? Thanks.
Comment 4 László Németh 2013-01-12 04:48:24 UTC
Eike, could you help us? It seems, this is a regression in the date handling:

Quoted dot + space in date format definitions results dot + space + ASCII quotation mark in date formatting of LibO 4, not only dot + space:

YYYY". "M". "D. results 2013. "I. 11., and not the correct 2013. I. 11.

TEST: The date format selection list contains these bad date formats.

The only difference is the DateAcceptancePattern in the newer hu_HU.xml:

<DateAcceptancePattern>M-D</DateAcceptancePattern>
<DateAcceptancePattern>M.D</DateAcceptancePattern>

Thanks in advance, László
Comment 5 Eike Rathke 2013-01-12 18:24:59 UTC
Sounds pretty much like bug 58179, fixed in rc1 announced today. If not, then please reopen.

*** This bug has been marked as a duplicate of bug 58179 ***
Comment 6 László Németh 2013-01-17 23:58:40 UTC
(In reply to comment #5)
> Sounds pretty much like bug 58179, fixed in rc1 announced today. If not,
> then please reopen.
> 
> *** This bug has been marked as a duplicate of bug 58179 ***

Fixed in RC1, thanks! Laci