Bug 58179 - Cell FORMATTING string interpretation differs from version 3.6.4.3
Summary: Cell FORMATTING string interpretation differs from version 3.6.4.3
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: Other All
: medium normal
Assignee: Eike Rathke
URL:
Whiteboard: BSA target:4.0.0.0.beta3 target:4.1.0
Keywords: regression
: 57596 58190 58268 58374 58512 58602 58797 59061 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-12 08:47 UTC by Serge Julien
Modified: 2013-04-11 04:29 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (68.30 KB, image/jpeg)
2013-01-16 05:42 UTC, Jaise James
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Serge Julien 2012-12-12 08:47:39 UTC
Problem description: Cell rendering differs from Version 3.6.4.3 

Steps to reproduce:
1. Create a new spreasheet with Version 3.6.4.3
2. Set value of cell A1 to 1000
3. Set the cell number formatting to

[>0]"+"0,00;[<0]-0,00;#

(French version, decimal separator is a comma)
4. Save document
5. Open it with Version 4.0.0.1beta

Current behavior:
Cell is rendered as +"1000,00

Expected behavior:
Cell should be rendered as +1000,00
[i.e. without the double quote character, as it is with version 3.6.4.3]

Additional comment: maybe the problem is in the format string itself (shouldn't contain the quotes characters), but it worked with version 3.6.4.3

              
Operating System: All
Last worked in: 3.6.4.3 release
Comment 1 Michel Rudelle 2012-12-12 13:12:57 UTC
I confirm this bug.
Platform : 
Vista and Windows 7 64bits
Comment 2 Michel Rudelle 2012-12-12 14:56:34 UTC
*** Bug 58190 has been marked as a duplicate of this bug. ***
Comment 3 Michel Rudelle 2012-12-14 17:28:30 UTC
*** Bug 58268 has been marked as a duplicate of this bug. ***
Comment 4 m.a.riosv 2012-12-16 22:08:14 UTC
*** Bug 58374 has been marked as a duplicate of this bug. ***
Comment 5 Terrence Enger 2012-12-16 23:42:37 UTC
I have added attachments to bug 58374 ...
(*) typescript with messages from recent master
(*) image of dialog box Format Cells from 3.6.4.3
(*) image of dialog box Format Cells from 4.0.0beta1
Comment 6 Eike Rathke 2012-12-18 16:57:42 UTC
Taking this.
Comment 7 Not Assigned 2012-12-18 18:29:44 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9525bf5c0704c7a27b3ee6249d33d875abb51bc1&g=libreoffice-4-0

resolved fdo#58179 ImpSvNumberformatScan::RemoveQuotes: both ...


It will be available in LibreOffice 4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Not Assigned 2012-12-18 18:30:03 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=91d3c0ce2b808e917ee45f18f2c40a58329d2c19

resolved fdo#58179 ImpSvNumberformatScan::RemoveQuotes: both ...



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Eike Rathke 2012-12-18 18:46:04 UTC
*** Bug 57596 has been marked as a duplicate of this bug. ***
Comment 10 GerardF 2012-12-19 13:10:58 UTC
*** Bug 58512 has been marked as a duplicate of this bug. ***
Comment 11 Terrence Enger 2012-12-20 15:56:33 UTC
With master commit id eaf3c60, pulled around 2012-12-19 12:20 UTC, the problem is gone.
Comment 12 Cor Nouws 2013-01-07 08:36:26 UTC
*** Bug 59061 has been marked as a duplicate of this bug. ***
Comment 13 Michel Rudelle 2013-01-07 13:11:54 UTC
*** Bug 58602 has been marked as a duplicate of this bug. ***
Comment 14 Eike Rathke 2013-01-12 18:24:59 UTC
*** Bug 58797 has been marked as a duplicate of this bug. ***
Comment 15 Jaise James 2013-01-16 05:42:45 UTC
Created attachment 73134 [details]
screenshot

Screenshot of problem. if click on value, it will show as in red circle