Bug 58374 - FORMATTING: MS office 2010 excel.xlsx format reading
Summary: FORMATTING: MS office 2010 excel.xlsx format reading
Status: RESOLVED DUPLICATE of bug 58179
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-12-16 20:33 UTC by RobertG
Modified: 2013-11-16 19:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
One of the files this is happening with. (14.93 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2012-12-16 20:33 UTC, RobertG
Details
How it looks in EXCEL 2010 (609.30 KB, image/jpeg)
2012-12-16 20:34 UTC, RobertG
Details
how it looks in LibreOffice 4 (608.50 KB, image/jpeg)
2012-12-16 20:35 UTC, RobertG
Details
typescript with some warnings (4.96 KB, text/plain)
2012-12-16 23:34 UTC, Terrence Enger
Details
Format cells dialog from 3.643 (67.89 KB, image/png)
2012-12-16 23:36 UTC, Terrence Enger
Details
Format cells dialog from 4.0beta1 (67.59 KB, image/png)
2012-12-16 23:38 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description RobertG 2012-12-16 20:33:13 UTC
Created attachment 71599 [details]
One of the files this is happening with.

Problem description:Open MS office 2010 excel.xlsx document in LibreOffice 4Spreadsheet. Answering either YES or NO to This document was last saved by Excel.  Some formula cells may produce different results when recalculated. Do you want to recalculate all formula cells now?

Steps to reproduce:
1. ....Start Spreadsheet, or open direct from document
2. ....
3. ....

Current behavior:=SUM(E3:E34) cell reads £"0.00

Expected behavior:=SUM(E3:E34) cell should read £0.00

              
Operating System: Windows 7
Comment 1 RobertG 2012-12-16 20:34:48 UTC
Created attachment 71600 [details]
How it looks in EXCEL 2010
Comment 2 RobertG 2012-12-16 20:35:36 UTC
Created attachment 71601 [details]
how it looks in LibreOffice 4
Comment 3 m.a.riosv 2012-12-16 22:08:14 UTC

*** This bug has been marked as a duplicate of bug 58179 ***
Comment 4 Terrence Enger 2012-12-16 23:34:28 UTC
Created attachment 71609 [details]
typescript with some warnings

Using a local build of master commit id 7ba2c82, fetched around
2012-12-11 14:00 UTC, configured as

    --enable-dbgutil
    --enable-crashdump
    --disable-build-mozilla
    --without-system-postgresql
    --without-myspell-dicts
    --without-help
    --with-extra-buildid

built and running on ubuntu-natty (11.04) 32-bit ...

    $ uname -a
    Linux cougar-natty 2.6.38-16-generic #67-Ubuntu SMP Thu Sep 6 18:00:43 UTC 2012 i686 athlon i386 GNU/Linux

    $ gcc --version
    gcc (Ubuntu/Linaro 4.5.2-8ubuntu4) 4.5.2
    Copyright (C) 2010 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions.  There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

    $ java -version
    java version "1.6.0_24"
    OpenJDK Runtime Environment (IcedTea6 1.11.5) (6b24-1.11.5-0ubuntu1~11.04.1)
    OpenJDK Client VM (build 20.0-b12, mixed mode, sharing)

I see the funny display that RobertG describes.


While opening the file, the program produced messages at the console.
I shall attach typescript, but it may be of interest that this one
happened a few times ...

    warn:legacy.osl:15569:1:/home/terry/lo_hacking/git/libo2/oox/source/docprop/docprophandler.cxx:319: For now unexpected tags are ignored!


The extra quotation marks are evident in the dialog box Format Cells ,
tab Numbers, category Number, pane Format.  Coming soon: screenshots
from 3.6.4.3 and 4.0beta.

HTH,
Terry.
Comment 5 Terrence Enger 2012-12-16 23:36:15 UTC
Created attachment 71611 [details]
Format cells dialog from 3.643
Comment 6 Terrence Enger 2012-12-16 23:38:12 UTC
Created attachment 71613 [details]
Format cells dialog from 4.0beta1