Bug 57596 - Quotes used in custom formatting shows in results also in calc
Summary: Quotes used in custom formatting shows in results also in calc
Status: CLOSED DUPLICATE of bug 58179
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha1
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-11-27 07:24 UTC by Jaise James
Modified: 2012-12-18 18:46 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Single Quote showing result area when used in format code area (50.21 KB, image/png)
2012-11-27 07:24 UTC, Jaise James
Details
Result shows in calc (2.02 KB, image/png)
2012-11-27 07:25 UTC, Jaise James
Details
Same problem exsist graph used in writer copied from calc (5.04 KB, image/png)
2012-11-27 07:25 UTC, Jaise James
Details
Simple file showing th bug. (7.11 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-12-06 23:11 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaise James 2012-11-27 07:24:23 UTC
Created attachment 70640 [details]
Single Quote showing result area when used in format code area

Quotes used in custom formatting[in formating code area] shows in results.
Comment 1 Jaise James 2012-11-27 07:25:04 UTC
Created attachment 70641 [details]
Result shows in calc

Result shows in calc
Comment 2 Jaise James 2012-11-27 07:25:56 UTC
Created attachment 70642 [details]
Same problem exsist graph used in writer copied from calc

Same problem exsist graph used in writer copied from calc
Comment 3 m.a.riosv 2012-12-06 23:11:52 UTC
Created attachment 71103 [details]
Simple file showing th bug.

I can reproduce in
Win 7x64 Ultimated
LibreOffice Version 4.0.0.0.alpha1+ (Build ID:704fdf2b23d0e0480f29e0e56f631c2835eed02)

Not in 3.6.4.3
Comment 4 Eike Rathke 2012-12-18 18:46:04 UTC
In attachment https://bugs.freedesktop.org/attachment.cgi?id=71103 the format is actually
#" Kg"\"
so the trailing " _has_ to be displayed because it is escaped by \ backslash. Anyhow, for an unescaped trailing quote this is a duplicate.

Btw, would had been nice to not set all attachments to MIME type text/plain ...

*** This bug has been marked as a duplicate of bug 58179 ***