Bug 58873 - Locking/protecting cells to difficult/hard
Summary: Locking/protecting cells to difficult/hard
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: All macOS (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-29 23:56 UTC by Ivan Stephen
Modified: 2021-07-19 10:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Stephen 2012-12-29 23:56:39 UTC
Currently, protecting cells is very complicated, and just not worth the hassle of trying to figure it out.  It needs to be rethought from the begininng. Incidentally -  I am not a software designer, so lack the ability to add this functionality.
Comment 1 m.a.riosv 2012-12-30 03:19:39 UTC
Hi Ivan,

All stuff first time, seems complicated. In this case is not the only software in which cell protection works in this way. Many years in many software working so.

A- You can set if a cell is protect in Menu/Format/Cell (Ctrl+1), and using cell styles (F11).

B- To be active the cell protection depends on if Sheet protection is active. Menu/tools/protection/sheet, with options to select or not at protected cells.

So four states:
1- Cell no protected + Sheet no protected = cell editable.
2- Cell no protected + Sheet protected = cell editable.
3- Cell protected + Sheet no protected = cell editable.
4- Cell protected + Sheet protected = cell no editable.

I do not think you can expect some developer take care of this request for enhancement. Even only thinking in compatibility issues.
Comment 2 Ivan Stephen 2012-12-30 05:51:48 UTC
Thanks for the help.  However, if you look online, you'll find that other people are having the same challenge with it.  Also, to be truly useful, any tool or function needs to be straightforward to use.  Quite simply -  if I want to protect a single cell or column (or the whole sheet or even the whole file), I should be able to do so with ONE quick visit to the toolbar or menu.  Anything more complicated is unnecessary, and likely to cause users to not bother, even when the function would be very useful.

Regards,

Ivan Stephen
istephen@vaxxine.com
905-688-5270

On Sat, 29 Dec, 2012, at 10:19 PM, bugzilla-daemon@freedesktop.org wrote:

> mariosv changed bug 58873 
> What	Removed	Added
> CC	  	mariosv@miguelangel.mobi
> 
> Comment # 1 on bug 58873 from mariosv
> Hi Ivan,
> 
> All stuff first time, seems complicated. In this case is not the only software
> in which cell protection works in this way. Many years in many software working
> so.
> 
> A- You can set if a cell is protect in Menu/Format/Cell (Ctrl+1), and using
> cell styles (F11).
> 
> B- To be active the cell protection depends on if Sheet protection is active.
> Menu/tools/protection/sheet, with options to select or not at protected cells.
> 
> So four states:
> 1- Cell no protected + Sheet no protected = cell editable.
> 2- Cell no protected + Sheet protected = cell editable.
> 3- Cell protected + Sheet no protected = cell editable.
> 4- Cell protected + Sheet protected = cell no editable.
> 
> I do not think you can expect some developer take care of this request for
> enhancement. Even only thinking in compatibility issues.
> 
> You are receiving this mail because:
> You reported the bug.
Comment 3 Jorendc 2012-12-30 19:58:30 UTC
I second that it's to hard to lock/protect a cell...
(In reply to comment #1)
 
> So four states:
> 1- Cell no protected + Sheet no protected = cell editable.
No doubt: correct behavior (and expected behavior) 
> 2- Cell no protected + Sheet protected = cell editable.
If I protect a sheet ... why are the cells in that sheet editable? It doesn't make sense... If I block a sheet, I would like to block it entirely. I would not like to format individual/a range of cell(s) to protect them also...

> 3- Cell protected + Sheet no protected = cell editable.
This also doesn't make sense ... If I try to protect a single cell, not the whole sheet ... I would like to lock them individually, and not the cells AND the sheet...
> 4- Cell protected + Sheet protected = cell no editable.
> 
> I do not think you can expect some developer take care of this request for
> enhancement. Even only thinking in compatibility issues.

This doesn't make sense at all :s

Set bug status to NEW, because I can't find any other duplicate enhancement requests.
Comment 4 Urmas 2012-12-31 14:26:18 UTC
That is exactly how it should work. You design a form with sheet unprotected, then mark cells as unprotected and set sheet protection to the form to work for the end user.