Download it now!
Bug 58895 - Image file destroyed when saving docx (and some other minor errors concerning docx)
Summary: Image file destroyed when saving docx (and some other minor errors concerning...
Status: RESOLVED DUPLICATE of bug 52226
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-31 00:23 UTC by untraceable
Modified: 2013-06-29 12:32 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description untraceable 2012-12-31 00:23:06 UTC
Saving the original docx file again with Libre Office results in a reading error of the included image, when reopened.

To reproduce:
- Open docx (see link below)
- Export to any pdf (standard over symbol)
- Save the docx file again with a random, small change (e.g. remove the underline or insert a new space somewhere)


Other minor differences to the representation in Word
------------------------------------------------------ 
- samariterlehrer@... (in the middle of the second page) is underlined, but in Word it isn't.
- The horizontal lines on the second page extend to the right margin and start on the same position as the text in Word. When displayed with Libre Office the lines don't touch any of the black margins, but when saved and reopened as docx in Libre Office, they touch both black margins.
- Image might get displaced when saving.


Example files (and this description) can be found at http://ul.to/zgxez2a5


Program Versions
----------------
Libre Office Version 3.6.4.3 (Build ID: 2ef5aff)
Word 2007 (including all updates) for the original docx

This bug may be related to BUG 52226, due to the read error.


Update
------
Looking into the docx as ZIP archive reveals that the image file gets renamed from image1.png to image10.png and only the PNG header (8 bytes) is saved. Where the image saving process succeeded, the image was renamed to image9.png, but the original size and content was kept.
Comment 1 Florian Reisinger 2013-04-21 14:37:25 UTC
As it really reads like a dup (Link is not working), marking as such....

*** This bug has been marked as a duplicate of bug 52226 ***
Comment 2 untraceable 2013-06-28 00:09:27 UTC
Crossposted new information and another link to the files in

Bug 52226 , Comment 19 :
https://bugs.freedesktop.org/show_bug.cgi?id=52226#c19