Bug 58900 - EDITING: Graph contents gone once the data rows receive new data
Summary: EDITING: Graph contents gone once the data rows receive new data
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: bibisectRequest
Depends on:
Blocks: 59335
  Show dependency treegraph
 
Reported: 2012-12-31 08:03 UTC by Marc Burkhardt
Modified: 2015-12-17 07:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screen 1 (247.42 KB, image/png)
2012-12-31 08:03 UTC, Marc Burkhardt
Details
Screen 2 (197.57 KB, image/png)
2012-12-31 08:04 UTC, Marc Burkhardt
Details
Example (12.72 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-12-31 08:19 UTC, Marc Burkhardt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Burkhardt 2012-12-31 08:03:40 UTC
Created attachment 72331 [details]
Screen 1

Problem description: 
The graph's contents are invisible (just the graph's background showing) once I edit the data rows that are used to display the graph.

Steps to reproduce:
1. Open spreadsheet with graoh
2. Edit spreadsheet
3. ....

Current behavior:
See screenshots

Expected behavior:
Screen 2 look the same as screen 1
              
Operating System: Linux (Other)
Version: 3.6.4.3 release
Last worked in: unspecified
Comment 1 Marc Burkhardt 2012-12-31 08:04:39 UTC
Created attachment 72332 [details]
Screen 2
Comment 2 Marc Burkhardt 2012-12-31 08:19:24 UTC
Created attachment 72333 [details]
Example

Another example with a new spreadsheet. The graph doesn't show anything from the start...
Comment 3 Marc Burkhardt 2012-12-31 08:31:39 UTC
Could be a duplicate of #58741
Comment 4 Marc Burkhardt 2013-01-01 11:03:08 UTC
I think the last known working version was 3.6.3.2
Comment 5 Markus Mohrhard 2013-01-10 03:03:38 UTC
No problems with the file in master.
Comment 6 Marc Burkhardt 2013-01-10 07:53:43 UTC
(In reply to comment #4)
> I think the last known working version was 3.6.3.2

I downgraded to this version and it works as expected.
Comment 7 Kohei Yoshida 2013-01-24 21:16:39 UTC
Mark, Do you use the distro packaged version, or one downloaded from libreoffice.org?  If former, what's your distro and version?
Comment 8 Kohei Yoshida 2013-01-24 21:20:15 UTC
I can reproduce it using my 3.6 build, but 4.0 loads just fine.
Comment 9 Marc Burkhardt 2013-01-24 22:22:46 UTC
Hi there,

I use Gentoo. Therefore it's an individually compiled version from the tarball of the specific version.
Comment 10 Björn Michaelsen 2013-06-26 15:14:19 UTC
Contrary to Comment 6, attachment 72333 [details] does not show a graph. So no minor release regression as its in 3.6.0 release already.
Comment 11 Marc Burkhardt 2013-07-04 10:06:48 UTC
(In reply to comment #10)
> Contrary to Comment 6, attachment 72333 [details] does not show a graph. So
> no minor release regression as its in 3.6.0 release already.

As stated earlier, the problem shows up in 3.6.4.3 but not 3.6.3.2 - how come you assume it's in 3.6.0?

I will try to retest in 4.0.4.2 as it's marked stable in Gentoo now. Will report back once I got it to compile.
Comment 12 Marc Burkhardt 2013-07-04 12:55:25 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > Contrary to Comment 6, attachment 72333 [details] does not show a graph. So
> > no minor release regression as its in 3.6.0 release already.
> 
> As stated earlier, the problem shows up in 3.6.4.3 but not 3.6.3.2 - how
> come you assume it's in 3.6.0?
> 
> I will try to retest in 4.0.4.2 as it's marked stable in Gentoo now. Will
> report back once I got it to compile.

OK, checked again with 4.0.4.2 - it does NOT work. The graphs are not shown.

What does the rendering of the graphs rely on? Could it be my xorg-server, NVIDIA blob or something?
Comment 13 Marc Burkhardt 2013-07-11 18:18:25 UTC
I've got some news:

The revert to the 3.6 version initially seemed to be working. However, as I update some content even in _that_ version the graphs now go away. It seems to interfere with something external.

I can also reproduce the phenomenon on my workstation at work with the document attached to this report. It's not Gentoo, but Ubuntu. Version of LO, Ubuntu can be provided.

Can someone provide a list of _all_ libs that are needed and relevant for rendering by LO?
Comment 14 Marc Burkhardt 2013-07-11 18:20:32 UTC
(In reply to comment #13)
> I've got some news:
> 
> The revert to the 3.6 version initially seemed to be working. However, as I
> update some content even in _that_ version the graphs now go away. It seems
> to interfere with something external.
> 
> I can also reproduce the phenomenon on my workstation at work with the
> document attached to this report. It's not Gentoo, but Ubuntu. Version of
> LO, Ubuntu can be provided.
> 
> Can someone provide a list of _all_ libs that are needed and relevant for
> rendering by LO?

Just to make it clear again: the graphs are initially shown and go away when I update the data rows. So, rendering in general is not broken as it seems.
Comment 15 Marc Burkhardt 2013-07-11 18:23:52 UTC
(In reply to comment #14)
> (In reply to comment #13)
> > I've got some news:
> > 
> > The revert to the 3.6 version initially seemed to be working. However, as I
> > update some content even in _that_ version the graphs now go away. It seems
> > to interfere with something external.
> > 
> > I can also reproduce the phenomenon on my workstation at work with the
> > document attached to this report. It's not Gentoo, but Ubuntu. Version of
> > LO, Ubuntu can be provided.
> > 
> > Can someone provide a list of _all_ libs that are needed and relevant for
> > rendering by LO?
> 
> Just to make it clear again: the graphs are initially shown and go away when
> I update the data rows. So, rendering in general is not broken as it seems.

Closing and reopening the document makes the graphs even initially go away. I think this bug eats documents - annoying the same way as a couple of month ago as all my cell notes were gone upon 'Save...'. Damn.
Comment 16 Marc Burkhardt 2013-07-11 18:37:21 UTC
(In reply to comment #15)
> (In reply to comment #14)
> > (In reply to comment #13)
> > > I've got some news:
> > > 
> > > The revert to the 3.6 version initially seemed to be working. However, as I
> > > update some content even in _that_ version the graphs now go away. It seems
> > > to interfere with something external.
> > > 
> > > I can also reproduce the phenomenon on my workstation at work with the
> > > document attached to this report. It's not Gentoo, but Ubuntu. Version of
> > > LO, Ubuntu can be provided.
> > > 
> > > Can someone provide a list of _all_ libs that are needed and relevant for
> > > rendering by LO?
> > 
> > Just to make it clear again: the graphs are initially shown and go away when
> > I update the data rows. So, rendering in general is not broken as it seems.
> 
> Closing and reopening the document makes the graphs even initially go away.
> I think this bug eats documents - annoying the same way as a couple of month
> ago as all my cell notes were gone upon 'Save...'. Damn.

Running 

equery f app-office/libreoffice | grep "\.so$" | xargs ldd | grep " => " | awk '{ print $1 }' | sort | uniq

I got this list of unique libs:

libatk-1.0.so.0 libbasebmplo.so libbasegfxlo.so libboost_date_time.so.1.52.0 libbz2.so.1 libcairo.so.2 libcdr-0.0.so.0 libcharttoolslo.so libchartviewlo.so libclucene-contribs-lib.so.1 libclucene-core.so.1 libclucene-shared.so.1 libcmis-0.2.so.2 libcolamd.so.0 libcom_err.so.2 libcomphelpgcc3.so libcrypto.so.1.0.0 libc.so.6 libcurl.so.4 libdb-4.8.so libdbalo.so libdbtoolslo.so libdbulo.so libdl.so.2 libdrm.so.2 libEGL.so.1 libexpat.so.1 libexttextcat-2.0.so.0 libffi.so.6 libfilelo.so libfontconfig.so.1 libforlo.so libforuilo.so libfreetype.so.6 libgbm.so.1 libgcc_s.so.1 libgcrypt.so.11 libgdk_pixbuf-2.0.so.0 libgdk_pixbuf_xlib-2.0.so.0 libgdk-x11-2.0.so.0 libgio-2.0.so.0 libglib-2.0.so.0 libGL.so.1 libGLU.so.1 libgmodule-2.0.so.0 libgmp.so.10 libgnutls.so.28 libgobject-2.0.so.0 libgpg-error.so.0 libgraphite2.so.3 libgssapi_krb5.so.2 libgstinterfaces-0.10.so.0 libgstreamer-0.10.so.0 libgthread-2.0.so.0 libgtk-x11-2.0.so.0 libharfbuzz.so.0 libhelplinkerlo.so libhogweed.so.2 libhunspell-1.3.so.0 libhyphen.so.0 libi18nisolang1gcc3.so libi18nregexplo.so libi18nutilgcc3.so libICE.so.6 libicudata.so.49 libicui18n.so.49 libicule.so.49 libicuuc.so.49 libidn.so.11 libjawt.so libjemalloc.so.1 libjpeg.so.8 libjvmaccessgcc3.so.3 libjvmfwk.so.3 libk5crypto.so.3 libkeyutils.so.1 libkrb5.so.3 libkrb5support.so.0 liblber-2.4.so.2 liblcms2.so.2 libldap-2.4.so.2 liblocaledata_en.so liblpsolve55.so.0 libltdl.so.7 liblzma.so.5 libmergedlo.so libmhash.so.2 libmsfilterlo.so libm.so.6 libmythes-1.2.so.0 libnettle.so.4 libnspr4.so libnss3.so libnssutil3.so libnvidia-glcore.so.313.30 libnvidia-tls.so.313.30 libodbcbaselo.so libooxlo.so libOpenVG.so.1 libp11-kit.so.0 libpango-1.0.so.0 libpangocairo-1.0.so.0 libpangoft2-1.0.so.0 libpcre.so.1 libpixman-1.so.0 libplc4.so libplds4.so libpng16.so.16 libpthread.so.0 libpython2.7.so.1.0 libpyuno.so libraptor2.so.0 librasqal.so.3 librdf.so.0 libreg.so.3 libresolv.so.2 librptlo.so librt.so.1 libsasl2.so.3 libsaxlo.so libsclo.so libsdlo.so libsmime3.so libSM.so.6 libsotlo.so libssh2.so.1 libssl3.so libssl.so.1.0.0 libstdc++.so.6 libstore.so.3 libsvllo.so libswdlo.so libswlo.so libtllo.so libucbhelper4gcc3.so libudev.so.1 libuno_cppuhelpergcc3.so.3 libuno_cppu.so.3 libuno_purpenvhelpergcc3.so.3 libuno_salhelpergcc3.so.3 libuno_sal.so.3 libutil.so.1 libutllo.so libuuid.so.1 libvbahelperlo.so libvcllo.so libvclplug_genlo.so libvisio-0.0.so.0 libwayland-client.so.0 libwayland-server.so.0 libwpd-0.9.so.9 libwpd-stream-0.9.so.9 libwpg-0.2.so.2 libwps-0.2.so.2 libX11.so.6 libX11-xcb.so.1 libXau.so.6 libxcb-dri2.so.0 libxcb-render.so.0 libxcb-shm.so.0 libxcb.so.1 libxcb-xfixes.so.0 libXcomposite.so.1 libXcursor.so.1 libXdamage.so.1 libXdmcp.so.6 libXext.so.6 libXfixes.so.3 libXinerama.so.1 libXi.so.6 libxml2.so.2 libxmlreader.so libXrandr.so.2 libXrender.so.1 libxslt.so.1 libz.so.1

Can anyone point me to something?
Comment 17 Robinson Tryon (qubit) 2013-10-23 16:45:20 UTC
Removing comma from whiteboard (please use a space to delimit values in this field)
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Whiteboard#Getting_Started
Comment 18 Joel Madero 2013-10-29 20:04:56 UTC
Also cannot reproduce - 


Operating System: Ubuntu 13.10
Version: 4.1.2.3 release

That being said - I'm tempted to push this back to unconfirmed as it seems like no one can actually confirm this behavior any longer which makes it very likely that it's environment specific and not a problem with LibreOffice itself (per say). 

@Marc - you've tried resetting your profile? https://wiki.documentfoundation.org/UserProfile

also are you willing to bibisect this bug? Using gentoo I assume you have some Linux skills - bibisecting is relatively straight forward:

https://wiki.documentfoundation.org/QA/HowToBibisect

You'll want th bibisect40 package (not the daily) as it seems like this was introduced for you before release of 4.0 stable?
Comment 19 Marc Burkhardt 2013-10-29 20:25:18 UTC
Hi there,

I upgraded to 4.1.2.3 yesterday (Gentoo stable release). The problem still persists. I cann try to wipe my profile, sure.

I unfortunately don't have he time actually to bisect this as the build can take up to two hours each even on my i7. :/ I will try to estimate if there's any room for the 'bisecting project'...
Comment 20 Joel Madero 2013-10-29 21:53:24 UTC
No need to build anything - the package is on the wiki - just download it and you can run soffice from within. Directions are pretty straight forward - I believe you need a total of 5 gigs or so available for the bibisect40 package
Comment 21 Kohei Yoshida 2014-05-18 13:59:17 UTC
NEEDINFO, since none of us can reproduce it.
Comment 22 retired 2014-08-25 10:06:42 UTC
Ubuntu 14.04, LO 4.3.0.4 WORKSFORME.

Please re-open if this persists with LO 4.3.0.4 or newer and add requested additional info.
Comment 23 Robinson Tryon (qubit) 2015-12-17 07:07:23 UTC
Migrating Whiteboard tags to Keywords: (bibisectrequest)
[NinjaEdit]