Bug Hunting Session
Bug 58919 - Cursor is at Left when Table is converted to RTL in Impress
Summary: Cursor is at Left when Table is converted to RTL in Impress
Status: VERIFIED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-CTL
  Show dependency treegraph
 
Reported: 2013-01-01 16:19 UTC by gokul
Modified: 2018-09-17 17:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Cursor is in Left Side whereas the Cursor as to be to Right (532.26 KB, application/zip)
2013-01-01 16:19 UTC, gokul
Details
Alignment Problem (75.89 KB, image/jpeg)
2013-02-20 06:55 UTC, gokul
Details
Behavior after patch (78.81 KB, image/png)
2013-02-20 12:14 UTC, gokul
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gokul 2013-01-01 16:19:36 UTC
Created attachment 72362 [details]
Cursor is in Left Side whereas the Cursor as to be to Right

When an Table is Inserted in Impress The table alignment shows in Center For 
LTR Table And
When the table is Converted to RTL Table The Cursor Position is Still in Left,
Actually the cursor has to be in Right Side in each cell
Comment 1 Karthikeyan Krishnamurthi 2013-01-09 05:51:24 UTC
confirmed with Libreoffice 3.6 in ubuntu 12.04
Comment 2 gokul 2013-02-20 06:55:57 UTC
Created attachment 75161 [details]
Alignment Problem

Problem still exist with alignment of the table.
In RTL Table the text alignment has to be Right but it is not.

And their is another problem when we perform undo operation the
alignment moves to center whereas it has to be to Left
Comment 3 gokul 2013-02-20 12:14:27 UTC
Created attachment 75168 [details]
Behavior after patch

I have proposed an patch for this 
        https://gerrit.libreoffice.org/#/c/2290/
Check the attachment for the current behavior.

But the Other problem which i have stated in previous comment
still exist.
When undo operation is performed the alignment shifts to Center.
Comment 4 Muthu 2013-03-05 13:10:20 UTC
I would suggest inputs from UX team, please?
Comment 5 Lior Kaplan 2013-03-08 10:34:59 UTC
I haven't reviewed the patch (yet), but I think we need to better define the bug we want to fix.


Problem #1:
When inserting a table into impress, and checking it's alignment the result is aligned to the left. After selecting another object and checking the table again it's alignment change to the center.

Problem #2:
Changing table directionality doesn't change cell's alignment (which stays to the left), although directionality is now RTL.

From the screenshot I couldn't understand to which problem are you referring. Let me know which of the problems the patch fixes, and I'll test it.
Comment 6 gokul 2013-03-08 10:50:24 UTC
(In reply to comment #5)
> From the screenshot I couldn't understand to which problem are you
> referring. Let me know which of the problems the patch fixes, and I'll test
> it.

The Actual Problem when i reported is problem#2 that you have mentioned in previous comment.

When we change the table from LTR to RTL, The alignment has to be to Right, But present behavior is all cell alignment still Remains in Left.

My Patch works Towards this problem. As per my analysis, when the SvxAdjust is set to Center it will never change to Right so instead of checking it for Left while setting Right, If we check if it is right or not. and then set the value.


When i was working on this i see their is another problem in undo, which does not shift back properly, we can report this as separate bug. Because the alignment was center when we change LTR table to RTL and do undo it changes to Center.
Comment 7 Commit Notification 2013-03-08 13:26:30 UTC
Gokul committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=909d745baf9a5d071892d8c04874ff279a9a477e

Fix for fdo#58919 now the cursor/alignment is Right for RTL Table



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2013-03-13 17:05:13 UTC
Lior Kaplan committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c60c9d7de6f3cb89fc7e582d0ca173985ccc1a8a

Revert "Fix for fdo#58919 now the cursor/alignment is Right for RTL Table"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Lior Kaplan 2013-03-13 17:06:54 UTC
The commit above was reverted with coordination with Gokul, as it creates a regression - changing directionality overrides center/justify alignment.

We agreed on this preferred behavior: "In any case, the directionality should behave as in writer, which does affect the alignment, but only if it's left/right (not center/justify)."
Comment 10 QA Administrators 2015-02-19 15:50:16 UTC Comment hidden (obsolete)
Comment 11 Lior Kaplan 2015-03-12 18:59:34 UTC
Still relevant in LibO 4.3.3.2
Comment 12 tommy27 2016-04-16 07:29:10 UTC Comment hidden (obsolete)
Comment 13 Xisco Faulí 2017-07-13 10:16:02 UTC
Setting Assignee back to default. Please assign it back to yourself if you're
still working on this issue
Comment 14 Omer Zak 2017-11-03 01:47:20 UTC
Works for me at:

Version: 5.4.2.2.0+
Build ID: 1:5.4.2-3~bpo9+1
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.utf8); Calc: group

OS: Debian 64bit Stretch (Debian 9.2, with some backported packages)
Comment 15 Lior Kaplan 2018-09-17 17:54:04 UTC
works for me as well.

Version: 6.1.1.1
Build ID: 1:6.1.1~rc1-2

Debian GNU/Linux on AMD64