Bug 58933 - FILEOPEN: RTF-filter; Addition of empty paragraphs in table’s cells
Summary: FILEOPEN: RTF-filter; Addition of empty paragraphs in table’s cells
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: Other All
: high critical
Assignee: Miklos Vajna
QA Contact:
URL:
Whiteboard: target:4.0.0.0beta2+ target:4.1.0 tar...
Keywords: filter:rtf, regression
: 58937 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-02 05:56 UTC by ape
Modified: 2015-12-17 14:45 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ape 2013-01-02 05:56:24 UTC
Open file (attachment 67922 [details]). You will see, that is added the empty paragraph before each text paragraphs in the 2nd cell of the 1st row of table 1:
\cell
\pard\intbl\qr\sl0\lin2 {\f0\fs20\b\cf1 \u1040?\u1076?\u1088?\u1077?\u1089?: 119021, \u1056?\u1086?\u1089?\u1089?\u1080?\u1103?, \u1075?. \u1052?\u1086?\u1089?\u1082?\u1074?\u1072?, \u1091?\u1083?. \u1051?\u1100?\u1074?\u1072? \u1058?\u1086?\u1083?\u1089?\u1090?\u1086?\u1075?\u1086?, \u1076?. 16}\par
\pard\intbl\qr\sl0\lin2 {\f0\fs20\b\cf1 \u1090?\u1077?\u1083?. (495) 739-70-00}\par
\pard\intbl\qr\sl0\lin2 {\f0\fs20\b\cf1 \u1092?\u1072?\u1082?\u1089? (495) 739-70-70}\cell

I can make mistakes, but LOdev_4.0.0 processes incorrectly the code “\pard\intbl\qr\sl0\lin2 {…}” inside “\cell”.
This bug wasn’t in LibreOffice 3.6.4.
Comment 1 Jorendc 2013-01-02 17:07:09 UTC
@Vmiklos: As discussed at IRC: I add you to CC in a kind way ;).

Kind regards,
Joren
Comment 2 Petr Mladek 2013-01-07 15:57:04 UTC
It is a regression and I am sure that Miklos will look at it ASAP.

On the other hand, it is not a real data loss because the data are not removed. The document can be fixed relatively easily => should not be marked as a blocker => reducing the severity a bit.
Comment 3 Miklos Vajna 2013-01-09 14:23:29 UTC
*** Bug 58937 has been marked as a duplicate of this bug. ***
Comment 4 Miklos Vajna 2013-01-09 14:31:06 UTC
This is caused by my fix for bug 57708, I'll take care of this.
Comment 5 Not Assigned 2013-01-09 15:00:34 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=555bc780c83114220012e198b5471a0d7452fb32

fdo#58933 RTF import: avoid fake pars / cells when having graphic inside cells



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Miklos Vajna 2013-01-09 16:32:36 UTC
Fixed in master, marking as resolved.

-4-0 review: https://gerrit.libreoffice.org/1617

-3-6 review: https://gerrit.libreoffice.org/1618
Comment 7 Not Assigned 2013-01-09 19:22:07 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=10a6a58e8d55f5d6c1ce7b6cba38f710b6edab6f&h=libreoffice-3-6

fdo#58933 RTF import: avoid fake pars / cells when having graphic inside cells


It will be available in LibreOffice 3.6.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Not Assigned 2013-01-09 19:22:26 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=075a1e6fdaebd441be4cb46fbc30ef7ded4cabaa&h=libreoffice-4-0

fdo#58933 RTF import: avoid fake pars / cells when having graphic inside cells


It will be available in LibreOffice 4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Robinson Tryon (qubit) 2015-12-17 14:45:53 UTC
Migrating Whiteboard tags to Keywords: ('rtf_filter;' -> filter:rtf)
[NinjaEdit]