Download it now!
Bug 58937 - FILEOPEN: RTF-filter; Addition of empty cell in the table
Summary: FILEOPEN: RTF-filter; Addition of empty cell in the table
Status: RESOLVED DUPLICATE of bug 58933
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: Other All
: high critical
Assignee: Miklos Vajna
URL:
Whiteboard: target:4.0.0.0beta2+
Keywords: filter:rtf, regression
Depends on:
Blocks:
 
Reported: 2013-01-02 07:43 UTC by ape
Modified: 2015-12-17 14:45 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
RTF file (WinWord-2007) (65.68 KB, text/rtf)
2013-01-02 07:43 UTC, ape
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ape 2013-01-02 07:43:11 UTC
Created attachment 72374 [details]
RTF file (WinWord-2007)

1. The attached file was created by Microsoft Word 2007:
- the file (attachment 67922 [details]) was opened;
- the table has been copied to the clipboard;
- the new empty document has been created;
- the clipboard was inserted into the new file;
- this document was saved as RTF file.

2. Open the attachment by LibreOffice_3.6.4. You can see the view of this file with the same as in Microsoft Word 2007.

3. Open the attachment by LibreOffice_4.0.0. You will see, that is added the empty cell after the 2nd cell of the 1st row of table. This is a regression.
Comment 1 Julien Nabet 2013-01-02 20:33:04 UTC
On pc Debian x86-64, I can reproduce it with master, 4.0 and even 3.6 sources!
On Win7 with 3.6.4.3, it's ok.

Miklos: would you have some time to take a look?
Comment 2 Petr Mladek 2013-01-07 15:57:48 UTC
It is a regression and I am sure that Miklos will look at it ASAP.

On the other hand, it is not a real data loss because the data are not removed. The document can be fixed relatively easily => should not be marked as a blocker => reducing the severity a bit.
Comment 3 Miklos Vajna 2013-01-09 11:53:28 UTC
Interesting, the fake cell is not added if I remove the picture.
Comment 4 ape 2013-01-09 12:23:45 UTC
(In reply to comment #3)
> Interesting, the fake cell is not added if I remove the picture.

Miklos, Bug 58933 was gone, too.
Comment 5 Miklos Vajna 2013-01-09 14:23:29 UTC
Hi ape,

Thanks for mentioning that bug! It turns out the same same commit introduced both bugs, and the fix will be the same as well. That other one was reported earlier: let's close this as a duplicate, then.

Miklos

*** This bug has been marked as a duplicate of bug 58933 ***
Comment 6 Robinson Tryon (qubit) 2015-12-17 14:45:33 UTC
Migrating Whiteboard tags to Keywords: ('rtf_filter;' -> filter:rtf)
[NinjaEdit]