Download it now!
Bug 58940 - CONFIGURATION: Can not change paths used by LibreOffice
Summary: CONFIGURATION: Can not change paths used by LibreOffice
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-02 10:05 UTC by [REDACTED]
Modified: 2013-10-25 15:34 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
strace log of failed attempt to add LibreOffice template file path (5.27 KB, application/x-bzip)
2013-03-09 00:13 UTC, Rafael D.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description [REDACTED] 2013-01-02 10:05:20 UTC
Problem description: 

Can not change the paths used by LO in Linux Mint 14

Steps to reproduce:
1. Tools > Options
2. LibreOffice > Paths
3. Select 'My Documents' > Edit
4. Select new folder, OK

Current behavior:

Path reverts to /home/<username>/

Expected behavior:

New path should save
Operating System: Linux (Other)
Version: 3.6.4.3 release
Comment 1 Julien Nabet 2013-01-02 20:08:46 UTC
On pc Debian x86-64 with 3.6 sources updated some days ago, I don't reproduce the problem.

Could you check permissions of ~/.config/libreoffice/3/registrymodifications.xcu ? (for me, it's 600)
Could you try to launch LO from console and tell us if you notice any specific message when setting the path?
Did you try with a brand new LO profile?
Comment 2 Rafael D. 2013-01-02 22:26:34 UTC
I also have had this problem since installing Linux Mint 14 (64 bit). Did not have this problem with Linux Mint 13 (but it was older HDD). 

It was fresh install with new /home directory from scratch and new LO profile.

I have tried the following fixes without success:

1) Deleted the file .libreoffice/3/user/registrymodifications.xcu 

2) Deleted the user directory and .lock file in same path

3) Uninstalled and reinstalled Libreoffice

4) Created a new Linux Mint user with Admin rights.

Notes:
Permissions for ~/.config/libreoffice/3/registrymodifications.xcu are 600 (actually 100600). 

I also have a .lock file under ../3/. 

I changed my hostname after install, and wonder if that's a cause. I did it correctly (in two places in Linux Mint), but am just looking for ideas. But another Linux Mint user with same problem did not change his hostname.
Comment 3 Rafael D. 2013-01-02 22:31:18 UTC
Sorry. I'm running version: 3.6.2.2, updated through software mgr.
Comment 4 Julien Nabet 2013-01-03 07:01:47 UTC
Rafael: If LO is closed, you shouldn't have a lock file. What's its name?
By any chance, would you have another Linux distribution to test?

I gave a try to Win 7 with 3.6.4.3, I don't reproduce this too.

All this makes me wonder if it could be a Mint packaging problem.

Rainer: do you reproduce this on one of your environments?
Comment 5 Rafael D. 2013-01-03 14:03:06 UTC
Julien: Sorry, I don't have lock file when LO is closed. 
I don't have another Linux distribution to test on this computer.

I tried and am unable to change the permissions on registrymodifications.xcu
Comment 6 Julien Nabet 2013-01-03 14:30:39 UTC
Rafael: can you give the output of this command?
ls -l ~/.config/libreoffice/3/user
Comment 7 Rafael D. 2013-01-03 14:40:46 UTC
Here you go. Username is rafaeld. I appreciate your gathering info about this. Let me know anything else you want me to try (short of reinstalling Mint).

rafaeld@xps4 ~ $ sudo ls -l ~/.config/libreoffice/3/user
[sudo] password for rafaeld: 
total 184
drwxr-xr-x 2 rafaeld rafaeld   4096 Dec 21 17:32 autocorr
drwxr-xr-x 2 rafaeld rafaeld   4096 Dec 21 17:32 autotext
drwxr-xr-x 2 rafaeld rafaeld   4096 Jan  3 09:29 backup
drwxr-xr-x 3 rafaeld rafaeld   4096 Jan  3 08:00 basic
drwxr-xr-x 3 rafaeld rafaeld   4096 Dec 21 17:32 config
drwxr-xr-x 3 rafaeld rafaeld   4096 Dec 21 17:32 database
drwxr-xr-x 4 rafaeld rafaeld   4096 Dec 21 17:32 extensions
drwxr-xr-x 2 rafaeld rafaeld   4096 Dec 21 17:32 gallery
drwxr-xr-x 4 rafaeld rafaeld   4096 Dec 21 17:32 psprint
-rw------- 1 rafaeld rafaeld 125003 Jan  3 09:29 registrymodifications.xcu
drwxr-xr-x 2 rafaeld rafaeld   4096 Dec 21 17:32 Scripts
drwxr-xr-x 2 rafaeld rafaeld   4096 Dec 28 18:00 store
drwxr-xr-x 2 rafaeld rafaeld   4096 Dec 21 17:32 temp
drwxr-xr-x 2 rafaeld rafaeld   4096 Dec 21 17:32 template
drwxr-xr-x 3 rafaeld rafaeld   4096 Dec 21 17:32 uno_packages
drwxr-xr-x 2 rafaeld rafaeld   4096 Jan  1 21:13 wordbook
Comment 8 Julien Nabet 2013-01-03 14:48:10 UTC
rafael:
I don't understand something:
why do you have to add a sudo to this command since it's your home?
if user = rafaeld
your directory ~ (=home) must be completely accessible, mustn't it?
In brief, in a brand new terminal the command ls -l ~/.config/libreoffice/3/user
 must work
Comment 9 Rafael D. 2013-01-03 14:58:12 UTC
Sorry. Newbie mistake. I opened new terminal window and got this:

rafaeld@xps4 ~ $ ls -l ~/.config/libreoffice/3/user
total 184
drwxr-xr-x 2 rafaeld rafaeld   4096 Dec 21 17:32 autocorr
drwxr-xr-x 2 rafaeld rafaeld   4096 Dec 21 17:32 autotext
drwxr-xr-x 2 rafaeld rafaeld   4096 Jan  3 09:44 backup
drwxr-xr-x 3 rafaeld rafaeld   4096 Jan  3 08:00 basic
drwxr-xr-x 3 rafaeld rafaeld   4096 Dec 21 17:32 config
drwxr-xr-x 3 rafaeld rafaeld   4096 Dec 21 17:32 database
drwxr-xr-x 4 rafaeld rafaeld   4096 Dec 21 17:32 extensions
drwxr-xr-x 2 rafaeld rafaeld   4096 Dec 21 17:32 gallery
drwxr-xr-x 4 rafaeld rafaeld   4096 Dec 21 17:32 psprint
-rw------- 1 rafaeld rafaeld 125094 Jan  3 09:44 registrymodifications.xcu
drwxr-xr-x 2 rafaeld rafaeld   4096 Dec 21 17:32 Scripts
drwxr-xr-x 2 rafaeld rafaeld   4096 Dec 28 18:00 store
drwxr-xr-x 2 rafaeld rafaeld   4096 Dec 21 17:32 temp
drwxr-xr-x 2 rafaeld rafaeld   4096 Dec 21 17:32 template
drwxr-xr-x 3 rafaeld rafaeld   4096 Dec 21 17:32 uno_packages
drwxr-xr-x 2 rafaeld rafaeld   4096 Jan  1 21:13 wordbook
Comment 10 Julien Nabet 2013-01-03 16:04:15 UTC
Rafael: thank you for your feedback. I've got no more questions to ask but I'm stuck for the moment :-(
Comment 11 Julien Nabet 2013-01-03 16:51:59 UTC
Rafael: what path did you try (I mean, is it a symbolic link, a net share, ...)?
As for me, I've just tried my home.
Comment 12 Rafael D. 2013-01-03 17:35:21 UTC
If you mean, which path did I try to set in Options, it was a directory under home (it happens to be within a Dropbox folder, but that doesn't matter).
Comment 13 Julien Nabet 2013-01-03 21:19:30 UTC
Rafael: For the test, could you give a try to something else than a dropbox folder?
Comment 14 Julien Nabet 2013-01-03 21:20:35 UTC
Rafael: I put in see also a bugtracker which indicates a problem with dropbox
Comment 15 Rafael D. 2013-01-03 21:56:39 UTC
I tested trying to designate for template path a folder /home/<username>/<foldername> and it did not work. So problem is not specific to Dropbox.
Comment 16 [REDACTED] 2013-01-03 22:01:40 UTC
My output:

brucey@Brucey ~ $ ls -l ~/.config/libreoffice/3/user
total 228
drwxr-xr-x 2 brucey brucey   4096 Nov 22 14:31 autocorr
drwxr-xr-x 2 brucey brucey   4096 Nov 22 14:31 autotext
drwxr-xr-x 2 brucey brucey   4096 Dec 21 04:17 backup
drwxr-xr-x 3 brucey brucey   4096 Jan  3 20:03 basic
drwxr-xr-x 3 brucey brucey   4096 Nov 22 14:31 config
drwxr-xr-x 3 brucey brucey   4096 Nov 22 14:31 database
drwxr-xr-x 5 brucey brucey   4096 Dec 13 11:23 extensions
drwxr-xr-x 2 brucey brucey   4096 Nov 23 05:06 gallery
drwxr-xr-x 4 brucey brucey   4096 Nov 22 14:31 psprint
-rw------- 1 brucey brucey 171717 Jan  3 20:03 registrymodifications.xcu
drwxr-xr-x 2 brucey brucey   4096 Nov 22 14:31 Scripts
drwxr-xr-x 2 brucey brucey   4096 Nov 26 04:42 store
drwxr-xr-x 2 brucey brucey   4096 Nov 22 14:31 temp
drwxr-xr-x 2 brucey brucey   4096 Nov 22 14:31 template
drwxr-xr-x 3 brucey brucey   4096 Nov 22 14:31 uno_packages
drwxr-xr-x 2 brucey brucey   4096 Nov 23 04:33 wordbook


I have also tested with Ubuntu 12.04 on the same laptop (LO 3.5.x) and the bug does not exist. I also tested the latest mainline linux kernel with LM 14, but this did not fix it.

This bug was reported in launchpad by another Linux Mint 14 user. So that's 3 different people with the same issue, so I'm assuming its LM14 specific. I will unistall this LO and update to the latest version and let you know how I get on.

I also have dropbox installed, but have tried other folders and they do not work. Could dropbox be effecting it at all though? I could uninstall it if you like.
Comment 17 [REDACTED] 2013-01-03 22:19:47 UTC
Additional info:

When editing, for example, the 'Gallery' path, I click 'Add' and select  /home/<username>/<folder>/<subfolder>, click OK, the path on that screen then shows as /home/<username>, I select that radio button and click OK. On the main paths screen Gallery is now shown as /home/<username>/.congfig/libreoffice/3/user/gallery;/home/<username>
Comment 18 Julien Nabet 2013-01-03 22:25:18 UTC
Adam/Rafael: with the comment 16 from Adam, it really seems a packaging problem from Mint.
To confirm, perhaps one of you could completely uninstall LO (+ delete LO profile directory) and install LO packages from Libreoffice website.
Comment 19 [REDACTED] 2013-01-03 23:29:46 UTC
I was already running a clean install from your websit.

But I have uninstalled it again + the profile dir.

I have installed the latest stable from the LO website and the bug still exists.
Comment 20 Rafael D. 2013-01-04 00:06:28 UTC
I uninstalled the LO I got from the package manager. I purged it completely and deleted the libreoffice directory under /home/<username>/.config

I then installed LO by downloading from the website: Version 3.6.4.3 (Build ID: 2ef5aff)

The bug still exists.  Thank you again for gathering information about this.
Comment 21 Julien Nabet 2013-01-04 06:53:30 UTC
Michael: I'm stuck again with this one. I thought it could be distrib package bug but it doesn't seem so. Any idea about this one?
Comment 22 Rafael D. 2013-01-04 10:55:55 UTC
I am a relative newbie, but in the spirit of generating possible ideas or questions, I offer the following two facts FWIW, neither of which relate to LibreOffice:

1) I changed the hostname immediately after installing Linux Mint 14. I changed it in both places and followed instructions exactly. It seems correct now. Another guy experiencing this bug did not change his hostname. 

2) Print to file: Results always go to /home/<username>
see post here: http://forums.linuxmint.com/viewtopic.php?f=47&t=120962 that has received no response.

When I "print to file" on this same system, it won't let me select a folder through the "other" dropdown. This always worked well in Linux Mint 12 and 13. The normal procedure that I've followed for years is: Go "print to file". Then "save in folder: other" and browse to a folder. Then create a file name, and print. Now it lets me do that, but then always puts the file in the /home/<username> directory, ignoring what I specified.

I've spent hours Googling forums, but only find people trying to change the default folder for "print to PDF", which is different.

(Although I'm a newbie, I've installed Linux Mint about 5-6 times now successfully, and am methodical and not going a lot of other things during the install.)
Comment 23 Martin McDowell 2013-01-05 12:10:14 UTC
Same thing happening to me. Fresh install of Ubuntu 12.10 with LO Version 3.6.2.2 (Build ID: 360m1(Build:2))

ls -l ~/.config/libreoffice/3/user
total 88
drwxrwxr-x 2 natasa natasa  4096 Jan  4 12:34 autocorr
drwxrwxr-x 2 natasa natasa  4096 Jan  4 12:34 autotext
drwxrwxr-x 2 natasa natasa  4096 Jan  5 12:36 backup
drwxrwxr-x 3 natasa natasa  4096 Jan  5 12:36 basic
drwxrwxr-x 3 natasa natasa  4096 Jan  4 12:34 config
drwxrwxr-x 3 natasa natasa  4096 Jan  4 12:34 database
drwxrwxr-x 4 natasa natasa  4096 Jan  4 12:34 extensions
drwxrwxr-x 2 natasa natasa  4096 Jan  4 12:34 gallery
drwxrwxr-x 4 natasa natasa  4096 Jan  4 12:34 psprint
-rw------- 1 natasa natasa 28477 Jan  5 12:36 registrymodifications.xcu
drwxrwxr-x 2 natasa natasa  4096 Jan  4 12:34 Scripts
drwxrwxr-x 2 natasa natasa  4096 Jan  4 12:34 store
drwxrwxr-x 2 natasa natasa  4096 Jan  4 12:34 temp
drwxrwxr-x 2 natasa natasa  4096 Jan  4 12:34 template
drwxrwxr-x 3 natasa natasa  4096 Jan  4 12:34 uno_packages
drwxrwxr-x 2 natasa natasa  4096 Jan  4 12:34 wordbook


Running LO from CLI produced the following output:

javaldx: Could not find a Java Runtime Environment! 
Please ensure that a JVM and the package libreoffice-java-common
is installed.
If it is already installed then try removing ~/.libreoffice/3/user/config/javasettings_Linux_*.xml
Warning: failed to read path from javaldx
Fontconfig warning: "/usr/lib/libreoffice/share/fonts/truetype/fc_local.conf", line 13: Having multiple <family> in <alias> isn't supported and may not works as expected

By the way there seem to be some grammar issues here. This wasn't my typo ;-)
Comment 24 [REDACTED] 2013-01-06 08:11:58 UTC
That's interesting that someone has the bug that's not on Linux Mint.

I have tested the bug on my Ubuntu 12.10 installation and can confirm the bug does exist there.

Remember Linux Mint 14 is based on Ubuntu 12.10.

Users have said the bug does not exist on Linux Mint 13 (based on Ubuntu 12.04) and I also confirm the bug does not exist in Ubuntu 12.04.

So looks like the issue is coming from Ubuntu 12.10
Comment 25 Rafael D. 2013-01-06 15:40:21 UTC
Just installed Linux Mint 14 XFCE (the lightweight version of Mint) on a netbook, and have the same bug. So it's not particular to the way I did the install on my desktop computer, or to the main edition of Mint.
Comment 26 James A Jones, Jr 2013-02-28 16:04:41 UTC
Trying to edit paths under Options menu does not work. I can click on the folder I want but when I click OK to confirm nothing changes. 

This is a problem for My Documents, and for Templates. No changes are accepted.
Comment 27 Rainer Bielefeld Retired 2013-02-28 16:14:05 UTC
Adam, please consider:
<http://wiki.documentfoundation.org/BugReport_Details#Version>
If you also did this mistake in other Bugs please undo your Version changes there!
Comment 28 [REDACTED] 2013-02-28 16:25:39 UTC
Do you mean James?
Comment 29 Rainer Bielefeld Retired 2013-02-28 16:42:38 UTC
@Adam (In reply to comment #28):
Yes, sorry, Comment 26 was @James A Jones, Jr
Comment 30 James A Jones, Jr 2013-02-28 16:45:31 UTC
Sorry about that. I am new to Bugzilla.

I was trying to report that the bug I have encountered affects Libreoffice 4.0.0.3 release.

I am running Kubuntu 12.10 (AMD64) with KDE 4.10 on a Lenovo R61i. I removed LO 3 and installed the downloaded LO 4 but cannot change paths.
Comment 31 Julien Nabet 2013-03-08 22:47:23 UTC
Adam/Rafael/James/Martin: just reread the comments and noticed a Java problem in comment23, what's your precise Java version?
Comment 32 Rafael D. 2013-03-08 22:54:49 UTC
(In reply to comment #31)
Thanks for your interest. Sorry for dumb question, but how do I check my java version? I searched "java" in software mgr and found only an openjdk installed. Cheers.
Comment 33 Julien Nabet 2013-03-08 22:56:28 UTC
Rafael: on console, just type this (no need to be root):
java -version
then copy paste the output.
Comment 34 Rafael D. 2013-03-08 23:01:15 UTC
(In reply to comment #33)
rafaeld@xxxx ~ $ java -version
java version "1.7.0_15"
OpenJDK Runtime Environment (IcedTea7 2.3.7) (7u15-2.3.7-0ubuntu1~12.10)
OpenJDK 64-Bit Server VM (build 23.7-b01, mixed mode)
rafaeld@xxxx ~ $
Comment 35 Julien Nabet 2013-03-08 23:13:05 UTC
Ok mine on Debian testing updated today is older:
java version "1.7.0_03"
OpenJDK Runtime Environment (IcedTea7 2.1.6) (7u3-2.1.6-1)
OpenJDK 64-Bit Server VM (build 22.0-b10, mixed mode)

Rafael: could you try to retrieve a strace (it's different from backtrace), see https://wiki.documentfoundation.org/BugReport#How_to_get_a_strace_log_.28Linux.29 ?
It could help to see what's LO trying to do and so to try to understand the root cause of the problem.
Comment 36 Rafael D. 2013-03-08 23:25:55 UTC
(In reply to comment #35)
I went to do this, but it says I do not have the soffice installed and can get it as part of libreoffice-common, which I do not have installed. Then I realized I have another (recent) problem that I have to solve first: I am unable to install ANY new software at this time. I tried to solve that a week ago and then got busy. Will try to solve both, but cannot promise success today. Thanks again.
Comment 37 [REDACTED] 2013-03-08 23:45:07 UTC
I no longer have LM14 installed. If the others are not able to assist, I am willing to re-install when I get a spare moment and provide you the info
Comment 38 Rafael D. 2013-03-09 00:13:13 UTC
Created attachment 76200 [details]
strace log of failed attempt to add LibreOffice template file path

strace log of failed attempt to add LibreOffice template file path
Comment 39 Julien Nabet 2013-03-09 00:40:18 UTC
Rafael: I'm not an strace expert so perhaps I missed something but noticed nothing special.

Michael: any idea about this, I'm a bit stuck?
Comment 40 QA Administrators 2013-09-24 02:01:20 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 41 Rafael D. 2013-09-24 14:07:31 UTC
I no longer have this problem after installing Linux Mint 15 (64 bit). 

I never heard any solution for the original problem. It may not have been a LibreOffice problem, but rather an Ubuntu/Mint issue. I don't know.

I am not the original submitter. I and others did provide information months ago. Perhaps the issue is moot now. I leave to others the final decision.
Comment 42 Julien Nabet 2013-09-25 20:15:07 UTC
Adam: following last Rafael's comment, any update?
Comment 43 Joel Madero 2013-10-25 15:34:30 UTC
Due to Rafael's comment, marking as WFM.

@Adam - if this is still an issue for you with LibreOffice 4.1, please mark as UNCONFIRMED and provide any information which has been requested.

Thanks to all for supporting LibreOffice!