Bug 58942 - Help: "Standard" number format stands for "General" number format
Summary: Help: "Standard" number format stands for "General" number format
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Laurent BP
URL:
Whiteboard: BSA target:4.2.0
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-02 11:17 UTC by Laurent BP
Modified: 2013-08-30 13:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2013-01-02 11:17:10 UTC
Problem description: 

Steps to reproduce:
1. Tools > Options > LibreOffice Calc > Calculate

Current behavior:
Last option indicates:
Limit decimals for general number format

Expected behavior:
"General" number format is present nowhere else in UI. In Format > Cell or number format button, it stands for "Standard" number format

Option label should be changed in:
Limit decimals for Standard number format

Also, Help is ambiguous:
https://help.libreoffice.org/Common/Calculate#Limit_decimals_for_general_number_format
speaks about "general number format" and 
https://help.libreoffice.org/Common/Calculate#Decimal_places
about Standard number format, but refer to the same format.
              
Operating System: All
Version: 4.0.0.0.beta2
Comment 1 Michel Rudelle 2013-01-08 10:55:37 UTC
I confirm the inadequacy of the message displayed: "general number format"
Presence verified on versions 3.5, 3.6, 4.0
Comment 2 Laurent BP 2013-08-23 18:00:57 UTC
Thanks to Eike I realised that the problem is not with the UI, but with the translation in the "Locale setting" and not the UI.

At least Help is incorrect for Tools > Options > LibreOffice Calc > Calculate
"Decimal places"
https://help.libreoffice.org/Common/Calculate#Decimal_places
Replace
Defines the number of decimals to be displayed for numbers with the <emph>Standard</emph> number format.
by
Defines the number of decimals to be displayed for numbers with the <emph>General</emph> number format.
file
help/source/text/shared/optionen/01060500.xhp
line 220
Comment 3 Commit Notification 2013-08-29 11:20:26 UTC
Laurent Balland-Poirier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=ee477f38f8f425f5bde8105be49b9a6d9e5c4321

fdo#58942 Help Standard number format stands for General



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.