Bug Hunting Session
Bug 59045 - Shortcut (accelerators, mnemonic) doesn't match between English version and Japanese version.
Summary: Shortcut (accelerators, mnemonic) doesn't match between English version and J...
Status: RESOLVED DUPLICATE of bug 41169
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta2
Hardware: Other All
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-05 07:27 UTC by KIRIHARA Masaharu
Modified: 2013-11-15 04:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description KIRIHARA Masaharu 2013-01-05 07:27:51 UTC
I'm not sure what a key sequence is called exactly (shortcut? accelerator? mnemonic?), 
but e.g. when using Impress with Japanese user interface language on Windows, 
in File(F) -> Print(P) -> Impress Tab -> Size(S) area 
shortcut keys are not shown, like (of course, written in Japanese)
 - Original size(
 - Fit to printable page(
 - Distribute on multiple sheets of paper(
 - Tile sheet of paper with repeated slides(

I found shortcut keys for each are ALT+G, ALT+I, ALT+J, and ALT+K.
So, description of this area should be (of course, written in Japanese)
 - Original size(G)
 - Fit to printable page(I)
 - Distribute on multiple sheets of paper(J)
 - Tile sheet of paper with repeated slides(K)

But, in a user interface language as English, it's shown as
 - Original si(z)e
 - (F)it to printable page
 - Distribute on (m)ultiple sheets of paper
 - (T)ile sheet of paper with repeated slides


The shortcut keys are different 
in English and Japanese user interface languages.


I've reported it to Japanese LibreOffice group:
  http://listarchives.libreoffice.org/ja/discuss/msg02012.html
  http://listarchives.libreoffice.org/ja/discuss/msg02014.html
And, they said the shortcut keys are assigned dynamically.
They guess it's difficult those are matched in every language.

===
I wish each shortcut key is matched in English and Japanese user interface languages (and other languages).

And, though Japanese LibreOffice group might be responsible for the problem written below, the shortcut keys in Japanese user interface language should be shown clearly.
Comment 1 KIRIHARA Masaharu 2013-01-05 08:13:09 UTC
I've checked the shortcut of 4.0.0.0 beta2 is also unmatched in English and Japanese user interface languages.

(I found the problem of unshown shortcut keys in Japanese user interface language was solved in 4.0.0.0 beta2.)
Comment 2 Naruhiko Ogasawara 2013-01-05 23:57:54 UTC
Few additional comments from Japanese translator point of view:

1) I'm not sure all accelerators *should* be same in each languages,
   however such kind of decision is up to each localization team.

2) Japanese translation team want to use same accelerators with English,
   but another translators (especially latin-character language users)
   might want to use their own accelerators.

3) So better way to solve this issue is remove automatically-accelerator
   creation logic and move every accelerators to each terms.

For example, "Original Size" in the report is:

https://translations.documentfoundation.org/ja/libo_ui/translate.html#unit=29929367

It might be better "Original Si~ze" than "Original Size" for translators.


However, I don't know how hard it will be fixed, or it has historical policy and cannot change.  If so, please let us know.
Comment 3 Joel Madero 2013-01-09 20:51:34 UTC
Kohei - any opinions on this one?
Comment 4 Joel Madero 2013-01-15 19:17:44 UTC
I'm just going to mark this as a valid enhancement request, I don't think that it's a bug but could use some discussion.

Marking as:
Enhancement
High (I think this affects virtually every user, worth having a conversation about)
Comment 5 V Stuart Foote 2013-11-15 04:32:47 UTC
setting as duplicate of MAB bug 41169

*** This bug has been marked as a duplicate of bug 41169 ***