Bug Hunting Session
Bug 59059 - text:condition on text:section is misinterpreted
Summary: text:condition on text:section is misinterpreted
Status: RESOLVED DUPLICATE of bug 55814
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-05 15:43 UTC by Jos van den Oever
Modified: 2013-02-11 18:52 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jos van den Oever 2013-01-05 15:43:47 UTC
When a document has a section like this:
  <text:section text:name="Section0" text:condition="ooow:true" text:display="condition">

the section should be hidden. The ODF specification says about text:condition on text:section:
===
The text:condition attribute specifies the condition under which a section is hidden. The condition is encoded as a string. If the value of text:display is condition, the text:condition attribute shall be present.
===

The expression ooow:true is specific to LibreOffice and not standardized. On loading a document with the above fragment, the section is shown and not hidden. Also pressing F9 to evaluate the text:condition expression does not hide the paragraph. (Since this evaluation is cheap, it would be preferable that pressing F9 is not needed).

This document demonstrates the issue and has the above fragment:
https://bugs.freedesktop.org/attachment.cgi?id=58546

When saving the document after pressing F9, ooow:true is replaced by ooow:0. This is wrong and this is the bug. Also, when the initial string is ooow:1, it evaluates to ooow:0 when pressing F9.
Comment 1 pierre-yves samyn 2013-02-11 18:52:29 UTC
Hello

I confirm the bug but I close as duplicate of 55814 (oldest) in which I precise the context

Regards
Pierre-Yves

*** This bug has been marked as a duplicate of bug 55814 ***