Bug 59063 - UI Page Pane crash when moved
Summary: UI Page Pane crash when moved
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-05 18:55 UTC by Noble Hays
Modified: 2013-10-25 15:33 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
os x crash report when redocking pages pane (48.71 KB, text/plain)
2013-03-10 22:09 UTC, brian.bj.parker99
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Noble Hays 2013-01-05 18:55:22 UTC
When I went to move my page pane from the left to the top. The page pane seems to have crashed. Now it takes up all of the window and doesn't draw anything. I can grab it to move it, but it doesn't move. The only way to see anything in the drawing is to close the page pane.
Comment 1 Jean-Baptiste Faure 2013-01-06 13:06:00 UTC
Not sure to understand what you describe.
Please, could you attach a screencopy of what happens?

Best regards. JBF
Comment 2 Julien Nabet 2013-01-06 16:22:47 UTC
On pc Debian x86-64 with 3.6 sources updated today, I don't reproduce this.
Would it be possible you test with a newer version (3.6.4) or use LO package from Libreoffice website?
If not, could you try to provide a backtrace by following this link? (see https://wiki.documentfoundation.org/BugReport#How_to_get_a_backtrace_.28on_Linux.29)

Jean-Baptiste: page pane (where there are all the slides) is at left by default. Undock it then dock it to the top.
Hope I didn't misunderstand what Noble meant :-)
Comment 3 Jean-Baptiste Faure 2013-01-06 20:42:44 UTC
Ok, I think I reproduced the problem. You can restore the normal layout by ctrl+double-click on the upper grey area with Slides as a title on the left hand side and a small cross on the right. After that the window become undocked and you can dock it back on the left.

Best regards. JBF
Comment 4 brian.bj.parker99 2013-03-10 22:09:59 UTC
Created attachment 76298 [details]
os x crash report when redocking pages pane
Comment 5 brian.bj.parker99 2013-03-10 22:11:57 UTC
In OS X undocking and redocking the pages pane in Draw reliably crashes LO. Crash report attached above. Version 4.0.1.2 (Build ID: 84102822e3d61eb989ddd325abf1ac077904985)
Comment 6 QA Administrators 2013-09-24 02:01:24 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 7 Jean-Baptiste Faure 2013-09-25 14:54:35 UTC
(In reply to comment #5)
> In OS X undocking and redocking the pages pane in Draw reliably crashes LO.
> Crash report attached above. Version 4.0.1.2 (Build ID:
> 84102822e3d61eb989ddd325abf1ac077904985)

@Brian: what you describe is not the same problem as the one reported by the original reporter. If you still encounter this behavior, please fill a bug report for that.

Best regards. JBF
Comment 8 Jean-Baptiste Faure 2013-09-25 14:55:59 UTC
@Noble Hays: does the comment #3 helps to solve your problem?

Best regards. JBF
Comment 9 Joel Madero 2013-10-25 15:33:19 UTC
Due to lack of information marking as INVALID.

@Noble - if you are still experiencing this problem with 4.1, please provide the requested information and mark the bug as UNCONFIRMED. QA will then try to figure out what's going on.


Thanks for supporting LibreOffice!