Bug Hunting Session
Bug 59083 - Export Chart as SVG produces zero byte files
Summary: Export Chart as SVG produces zero byte files
Status: RESOLVED DUPLICATE of bug 60137
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta2
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 62062 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-06 16:32 UTC by Pedro
Modified: 2013-07-13 19:00 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Just a simple chart. (18.61 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-01-07 18:01 UTC, Pedro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2013-01-06 16:32:57 UTC
Exporting a Chart in Calc works as expected for bitmap formats (PNG, JPG, TIF) and even for WMF. However exporting to SVG produces a zero byte file.
Comment 1 Jorendc 2013-01-07 17:48:01 UTC
Can you attach an example chart?

Thanks in advance,
Joren
Comment 2 Pedro 2013-01-07 18:01:54 UTC
Created attachment 72643 [details]
Just a simple chart.

Any chart will provide the unwanted result. Here is one I had lying around to save you some time.
Comment 3 Jorendc 2013-01-07 20:04:29 UTC
I can confirm using Version 4.1.0.0.alpha0+ (Build ID: 907050b4f479465c25249d58aa6f8297c306468); Ubuntu 12.10
Comment 4 Robert Samuel 2013-01-08 18:57:11 UTC
I'm not sure if it is the same bug, but I can't also export draw/presentation to SVG using the command-line nor using UNO. I thought it was related, since charts are internally represented as drawing (I think).


How to reproduce (command-line):

1 - Create a new presentation (or draw) and save it as test.odp (or test.odg)

2 - Execute command-line to convert: 
$ ./soffice --convert-to svg ~/test.odp
convert /home/robert/test.odp -> /home/robert/LibreOffice/libo/solver/unxlngx6.pro/installation/opt/program/test.svg using impress_svg_Export
Error: Please reverify input parameters...

3 - What was expected (output when converting to PNG):
$ ./soffice --convert-to png ~/test.odp
convert /home/robert/test.odp -> /home/robert/LibreOffice/libo/solver/unxlngx6.pro/installation/opt/program/test.png using impress_png_Export


How to reproduce (UNO):

1 - Create a new presentation (or draw) and save it as test.odp (or test.odg)

2 - Copy the latest unoconv with python3 support:
$ wget https://raw.github.com/xrmx/unoconv/fc59dd90f03cf88f4cf16c07204809f2239284ee/unoconv

3 - Start LO with socket:
$ ./soffice --accept="socket,host=127.0.0.1,port=2001;urp;StarOffice.ServiceManager" --norestore --nofirststartwizard --nologo

4 - Use unoconv (with python from LO) to export to SVG:
$ ./python ./unoconv -f svg -p 2001 ~/test.odp
unoconv: UnoException during export phase:
Unable to store document to file:///home/robert/test.svg (ErrCode 3088)
Properties: (...)

5 - What was expected (output when converting to PNG):
$ ./python ./unoconv -f png -p 2001 ~/test.odp


PS1: Opening the odp file and using File->Export (to SVG) works normally. The SVG file is generated and works properly.
PS2: I can also confirm that the reported bug (export chart to SVG) also generate an empty file.

System: Ubuntu 12.10. LO Version 4.1.0.0.alpha0+ (Build ID: 93a9e52dccf15b53fc1935145df24306e3a4fc3)
Comment 5 Sylvain Lenoir 2013-03-06 08:23:02 UTC
I can confirm using Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89) with Windows Vista 32b (Family Edition).
So to bypass this problem, I copy/past the Chart from Calc to Draw. And then, from Draw I can save the document in .svg format.
It works but not really convenient.
Comment 6 Jorendc 2013-03-19 22:46:45 UTC
*** Bug 62062 has been marked as a duplicate of this bug. ***
Comment 7 Roman Schleicher 2013-04-10 08:08:40 UTC
The but still exists in Version 4.0.2.2 (Build ID: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3) on Windows 7 Professional x32. Every SVG-export leads to an 0-byte file which can't be opened.
Comment 8 Gerry 2013-04-30 14:53:01 UTC
I think this bug is a duplicate of bug 60137. The good thing is that this bug is already fixed. It will be available in version 4.1.

I close this bug entry as a duplicate of the other one. In case you think it is not a duplicate, please feel free to reopen it again.

*** This bug has been marked as a duplicate of bug 60137 ***
Comment 9 Pedro 2013-04-30 15:03:42 UTC
Hi Gerry

(In reply to comment #8)
> I think this bug is a duplicate of bug 60137. The good thing is that this
> bug is already fixed. It will be available in version 4.1.
> 
> I close this bug entry as a duplicate of the other one. In case you think it
> is not a duplicate, please feel free to reopen it again.
> 
> *** This bug has been marked as a duplicate of bug 60137 ***

Actually, Bug #60137 is a duplicate of this bug. It is easy to see by the bug number which one was submitted first :)

The important thing is that it is fixed :)

If this is possible, the fix should be cherry picked into the 4.0 branch ASAP
Comment 10 Florian Manschwetus 2013-07-13 18:47:48 UTC
As I could confirm this bug is still there in 4.1.0.2 this seems to be a different problem, as the export works in draw when using the ui.
But for integration with latex a batch operation working also while the file is open is desired.
Comment 11 Florian Manschwetus 2013-07-13 19:00:13 UTC
sorry I wwas fouled by comment 4

*** This bug has been marked as a duplicate of bug 60137 ***