Bug 59128 - FILESAVE [DOCX filter]: WinWord-2007 can't open DOCX file with formulas if the file was created LOdev-4
Summary: FILESAVE [DOCX filter]: WinWord-2007 can't open DOCX file with formulas if th...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: Other All
: highest blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-01-08 12:07 UTC by ape
Modified: 2013-01-20 02:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
ODT file with formulas as an example (18.35 KB, text/vnd.oasis.opendocument)
2013-01-08 12:07 UTC, ape
Details
The file without the piece (6.14 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-01-13 03:22 UTC, ape
Details
Perhaps that fixing other bugs (see the picture in an attachment) caused regression (139.90 KB, image/png)
2013-01-13 04:21 UTC, ape
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ape 2013-01-08 12:07:39 UTC
Created attachment 72672 [details]
ODT file with formulas as an example

WinWord-2007 can't open DOCX file with formulas if the file was created LOdev-4.0.0:
1. Open ODT file with formulas (attachment).
2. Save this file as a Microsoft Word 2007/2010XML or Office OpenXML Text.
3. Try to open this DOCX file using Microsoft Word 2007.
Pop-up window reports the result:
“Cannot open the file because of errors in its content.
Details:
invalid character in its name.
Location: part:/word/footer1.xml, line: 2, column: 440”
Comment 1 ape 2013-01-10 07:46:45 UTC
(In reply to comment #0)
> Pop-up window reports the result:
> “Cannot open the file because of errors in its content.
> Details:
> invalid character in its name.
> Location: part:/word/footer1.xml, line: 2, column: 440”

This is a fragment of:
<w:1D><w:top w:val="none"/><w:left w:val="none"/><w:bottom w:val="none"/><w:insideH w:val="none"/><w:right w:val="none"/><w:insideV w:val="none"/></w:1D>
in between
<w:pStyle w:val="style40"/> and <w:pPr></w:pPr></w:p></w:ftr>

It's absent in LibreOffice_3.6.4.3
Comment 2 ape 2013-01-13 02:53:13 UTC
Petr!
  I added you to "CC," because the bug is in LOdev_4.0.0.1+ (ID: b0e35a54631d0e514860ae53cd7b408bb3d2e14). It seems to me that the regression associated with the export filter's violation in the ISO (OOXML) file's description must be resolved before LibreOffice_4.0.0.final will be published.
--
ape
Comment 3 ape 2013-01-13 03:22:30 UTC
Created attachment 72943 [details]
The file without the piece

(In reply to comment #1)
> This is a fragment of:
> <w:1D><w:top w:val="none"/><w:left w:val="none"/><w:bottom
> w:val="none"/><w:insideH w:val="none"/><w:right w:val="none"/><w:insideV
> w:val="none"/></w:1D>
> in between
> <w:pStyle w:val="style40"/> and <w:pPr></w:pPr></w:p></w:ftr>
--
I removed this piece from the file "2_formulas \ word \ footer1.xml", using a text editor. Now Microsoft Word 2007 opens a new file "correction_2_formulas.docx".
Comment 4 ape 2013-01-13 04:21:17 UTC
Created attachment 72944 [details]
Perhaps that fixing other bugs (see the picture in an attachment) caused regression
Comment 5 Pedro 2013-01-16 15:38:26 UTC
I can confirm that this also occurs in 4.0.0.1 (aka 4.0.0 RC1)

It is indeed a regression. The file is exported correctly under 3.6.4.3
Comment 6 ape 2013-01-17 04:29:17 UTC
(In reply to comment #3)
> I removed this piece from the file "2_formulas \ word \ footer1.xml", using
> a text editor. Now Microsoft Word 2007 opens a new file
> "correction_2_formulas.docx".

Export problem occurs if the Cyrillic characters used in a variable name.
WinWord-2007 will recognize Cyrillic characters in the formula only as text, not as a variable name.
Comment 7 ape 2013-01-20 02:45:10 UTC
Bug is absent in LibO-Dev_4.0.0.1_Win_x86 (Time: 2013-01-19_01.04.55; ID: baa9a119dabfc5e5dbb5c174cebf8c24298bad6), so I changed the status.