Bug Hunting Session
Bug 59130 - EDITING: Random crash when copy and pasting text from another page in LibreOffice
Summary: EDITING: Random crash when copy and pasting text from another page in LibreOf...
Status: RESOLVED DUPLICATE of bug 58177
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-08 12:49 UTC by benimnetz
Modified: 2013-06-04 17:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Apple generated crashlog (75.49 KB, text/plain)
2013-01-08 12:49 UTC, benimnetz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description benimnetz 2013-01-08 12:49:28 UTC
Created attachment 72674 [details]
Apple generated crashlog

Problem description: 
LibreOffcie randomly crashes pressinv CMD+V to insert copied text on Mac OS X 10.8. The text has been cut from the same document. This happened twice to me in the same document. The document recovery was not able to recover my newest changes.

Steps to reproduce:
Happens randomly
1. Open LibreOffice Writer
2. Open a document
3. Select text from on page and cut it with cmd+x
4. Try to insert the text on another page

Current behavior:
LibreOffice crashes, the latest changes are lost


Expected behavior:
Text gets pasted


Here is my crashlog from Apple:
Process:         soffice [729]
Path:            /Applications/LibreOffice.app/Contents/MacOS/soffice
Identifier:      org.libreoffice.script
Version:         3.6.4.3 (???)
Code Type:       X86 (Native)
Parent Process:  launchd [144]
User ID:         501

Date/Time:       2013-01-08 13:26:37.250 +0100
OS Version:      Mac OS X 10.8.2 (12C60)
Report Version:  10

Interval Since Last Report:          200241 sec
Crashes Since Last Report:           1
Per-App Crashes Since Last Report:   1
Anonymous UUID:                      B12F4440-2D62-6BC7-83D0-7570C7E504C9

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000

VM Regions Near 0:
--> __PAGEZERO             0000000000000000-0000000000001000 [    4K] ---/--- SM=NUL  /Applications/LibreOffice.app/Contents/MacOS/soffice
    __TEXT                 0000000000001000-0000000000002000 [    4K] r-x/rwx SM=COW  /Applications/LibreOffice.app/Contents/MacOS/soffice

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   ???                           	0x059f64f2 0 + 94332146
1   dudenkorrektor.uno.dylib      	0x132d2ac6 Duden::SessionData::StartSession() + 258
2   dudenkorrektor.uno.dylib      	0x132d607f Duden::DudenWrapper::GetOrCreateSessionHandle(short, short, bool) + 283
3   dudenkorrektor.uno.dylib      	0x1329ddec Duden::MenuExtender::InsertMenuEntriesThesaurus(com::sun::star::ui::ContextMenuExecuteEvent const&, com::sun::star::uno::Reference<com::sun::star::lang::XMultiServiceFactory>&, rtl::OUString const&) + 4804
4   dudenkorrektor.uno.dylib      	0x13295973 Duden::ContextMenuInterceptor::notifyContextMenuExecute(com::sun::star::ui::ContextMenuExecuteEvent const&) + 2631
5   libsfxlo.dylib                	0x007d3968 SfxViewShell::TryContextMenuInterception(Menu&, rtl::OUString const&, Menu*&, com::sun::star::ui::ContextMenuExecuteEvent) + 376
6   libsfxlo.dylib                	0x00767903 SfxPopupMenuManager::ExecutePopup(ResId const&, SfxViewFrame*, Point const&, Window*) + 387
7   libsfxlo.dylib                	0x005927f2 SfxDispatcher::ExecutePopup(unsigned short, Window*, Point const*) + 242
8   libswlo.dylib                 	0x1e6b6472 SwEditWin::Command(CommandEvent const&) + 5714
9   libvcllo.dylib                	0x01aca895 ImplCallCommand(Window*, unsigned short, void*, unsigned char, Point*) + 245
10  libvcllo.dylib                	0x01acd07e ImplHandleMouseEvent(Window*, unsigned short, unsigned char, long, long, unsigned long, unsigned short, unsigned short) + 5598
11  libvcllo.dylib                	0x01acd4d2 ImplWindowFrameProc(Window*, SalFrame*, unsigned short, void const*) + 850
12  libvcllo.dylib                	0x01b2f288 -[SalFrameView sendMouseEventToFrame:button:eventtype:] + 520
13  libvcllo.dylib                	0x01b2b702 -[SalFrameView rightMouseDown:] + 66
14  com.apple.AppKit              	0x95ab0bf1 -[NSWindow sendEvent:] + 7432
15  com.apple.AppKit              	0x95aaba0f -[NSApplication sendEvent:] + 4278
16  libvcllo.dylib                	0x01b210fc -[VCL_NSApplication sendEvent:] + 108
17  libvcllo.dylib                	0x01ad8714 AquaSalInstance::Yield(bool, bool) + 516
18  libvcllo.dylib                	0x017eff60 Application::Yield(bool) + 96
19  libvcllo.dylib                	0x017f004c Application::Execute() + 76
20  libsofficeapp.dylib           	0x000784db desktop::Desktop::Main() + 6171
21  libvcllo.dylib                	0x017f9582 ImplSVMain() + 354
22  libvcllo.dylib                	0x01ad7d7b AquaSalInstance::handleAppDefinedEvent(NSEvent*) + 75
23  libvcllo.dylib                	0x01b211cb -[VCL_NSApplication sendEvent:] + 315
24  com.apple.AppKit              	0x959c572c -[NSApplication run] + 951
25  com.apple.AppKit              	0x959686f6 NSApplicationMain + 1053
26  libvcllo.dylib                	0x01ad9337 ImplSVMainHook(int*) + 343
27  libvcllo.dylib                	0x017f9611 SVMain() + 17
28  libsofficeapp.dylib           	0x000a74e5 soffice_main + 437
29  org.libreoffice.script        	0x00001f0e main + 30
30  org.libreoffice.script        	0x00001872 _start + 216
31  org.libreoffice.script        	0x00001799 start + 41

... to long for the box, full crashlod is attached

Operating System: Mac OS X
Version: 3.6.4.3 release
Comment 1 Julien Nabet 2013-01-10 21:15:23 UTC
Could you give a try after having removed Duden? (of course just for the test)
Comment 2 benimnetz 2013-01-12 14:29:44 UTC
Hi,

i disabled the duden plugin and did not experience any issues afterwards in the same document.
I also contact the duden support about that, hopefully that helps, did not get a reply yet.

Thanks you anyway for looking into that. From my prespective, it seems related to the bugs you added to see also.
Comment 3 Julien Nabet 2013-01-12 14:46:56 UTC
benimnetz: thank you for your feedback, what's your Duden version?

Thorsten: another Duden case, I put you in cc.
Comment 4 benimnetz 2013-01-12 14:49:49 UTC
Duden Version is the latest from their website, the test version altought: Version 9, dates to 31.8.2012.
Comment 5 Julien Nabet 2013-06-04 17:25:54 UTC
According to the stacktrace, we have a dup here.

*** This bug has been marked as a duplicate of bug 58177 ***