Bug 59212 - Some buttons in Basic dialog needs localization
Summary: Some buttons in Basic dialog needs localization
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
4.0.0.1 rc
Hardware: Other All
: medium normal
Assignee: Andras Timar
QA Contact:
URL:
Whiteboard: target:4.1.0 target:4.0.0.2
Keywords:
: 59421 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-10 19:43 UTC by Leif Lodahl
Modified: 2013-01-15 16:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (41.13 KB, image/png)
2013-01-10 19:43 UTC, Leif Lodahl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leif Lodahl 2013-01-10 19:43:09 UTC
Created attachment 72800 [details]
Screenshot

Some buttons in the macro administration dialog needs localization.
The following buttons are English in the Danish version:
Run
Assign
Edit
Organizer...

To reproduce:
Alt+F11
Comment 1 Andras Timar 2013-01-15 15:21:43 UTC
*** Bug 59421 has been marked as a duplicate of this bug. ***
Comment 2 Not Assigned 2013-01-15 15:22:44 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bf442dcaa02f844d7b69d6851287a186f77344b3

fdo#59212 UI elements were untranslatable in Basic Macro dialog



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 miles 2013-01-15 15:54:46 UTC
WARNING - The patch for bug #59212 does not solve everything - I noticed and reported also missing localization for buttons "Delete", "Rename..." and "Create" in the BeanShell/JavaScript/Pythons macro organizer dialog!
So I am not sure this should be marked as FIXED RESOLVED.
Comment 4 Not Assigned 2013-01-15 16:00:46 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c72bded3901c67129c5867ff209f7e108b232120&h=libreoffice-4-0

fdo#59212 UI elements were untranslatable in Basic Macro dialog


It will be available in LibreOffice 4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.