Bug 59253 - shift-drag does not add to selection
Summary: shift-drag does not add to selection
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Object-Selection-Alignment
  Show dependency treegraph
 
Reported: 2013-01-11 17:20 UTC by Anastasius
Modified: 2018-11-04 21:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test drawing of moderate complexity (10.82 KB, application/vnd.oasis.opendocument.graphics)
2013-01-11 17:20 UTC, Anastasius
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anastasius 2013-01-11 17:20:17 UTC
Created attachment 72871 [details]
test drawing of moderate complexity

In moderately complex drawings, adding to a selection by shift-drag sometimes does not work. In more complex drawings, with a few objects selected already, usually it does not work at all.

Step to reproduce this:
(1) Open the attached LO-testDrawing.odg
(2) Select one or two objects (e.g. first 2 rectangles) with dragging a rectangle over them. (it's the same problem if I select the first object with a mouse click)
(3) press the SHIFT key and hold it while selecting one more object by dragging a rectangle
Repeat step (3) a few times.

After adding a few objects, maybe 5 or 10, selecting further objects this way does not work: nothing is added to the selection; the objects selected previously remain selected.
If the objects selected are more complex, like the curves, the bug comes earlier (sometimes it is impossible to add anything to the selection by shift-drag after one item); for simple objects like the rectangle it is possible to select more of them.

The bug is not perfectly reproducible; thus it might be a multithreading issue/race condition.

Possibly related bug: 36208 https://bugs.freedesktop.org/show_bug.cgi?id=36208

LO Version 3.6.4.3 (Build ID: 2ef5aff), Mac OS X 10.6.8, 2.4 GHz Intel Core2Duo, 3GB 667 MHz DDR2 SDRAM.
Comment 1 Michael 2013-06-30 11:06:10 UTC
Hi, 

thanks for your bug report.
I tried to reproduce it on Mac OSX 10.8.4 2.5Ghz i5 16GB DDR3.
With LO 3.6.7.1 and 4.1.0.1 I could select all elements in the test document the way you described it without error.
Please retest it with the newest version of the software and reopen this bug if you can reproduce it.
Comment 2 Anastasius 2013-07-01 13:56:49 UTC
Problem persist in LO 4.1.0.1 Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e915
When several objects are selected, adding to the selection by a shift-click works, adding by shift-drag does not. Maybe a race condition, and Michael's Mac is faster, or it's due to a difference between OS X 10.6 and 10.8
Comment 3 Anastasius 2013-09-17 13:34:09 UTC
Still the same with LO 4.0.4.2.

One more observation that might help to nail it down:

It seems that the problem occurs only if a Bezier curve has been selected previously.

If the selection contains a Bezier curve, shift drag does not add to the selection.  Instead, shift-drag over a Bezier curve selected previously activates all Bezier handles within the shift-drag rectangle.  If there is no Bezier curve inside the shift-drag rectangle, nothing happens.
Comment 4 Anastasius 2013-09-26 20:25:57 UTC
Finally, I think I got very close to the heart of the problem:

The problem exists only if a Bezier curve is already selected and LO is in 'Edit Points' (F8) mode.
It seems that it is intended that shift-drag allows to select several points of a Bezier curve so that one can translate (shift) all of these points when modifying a curve.

This translation works only for *one* Bezier curve.  If two Bezier curves are selected and one selects points in both with shift-drag, one can still modify the points in only *one* curve (the one where one shifts the points).

I would suggest to switch off that feature (selecting points of a Bezier curve instead of objects) if more than one object is selected:
Then, shift-drag should behave as normal, adding to the selection, irrespective of whether the selection contains a Bezier curve or not. Otherwise, in a complex drawing, where it is not obvious that the selection contains a Bezier curve, the user will become crazy because one can't add to the selection the usual way.
Comment 5 Joel Madero 2014-11-06 17:45:38 UTC
Never confirmed - moving to UNCONFIRMED so QA looks at it. Thanks
Comment 6 A (Andy) 2014-11-06 21:26:02 UTC
For me not reproducible with LO 4.3.3.2, Win 8.1, but unfortunately I have no opportunity to test it on Mac OSX.

I suppose this issue is still prevailing?
Comment 7 Alex Thurgood 2014-11-10 11:45:11 UTC
Confirming on

Version: 4.4.0.0.alpha2+
Build ID: c1358e5dc875bb923f4b5472ba615ebd19f0d057

osx 10.10
Comment 8 Alex Thurgood 2014-11-10 11:46:43 UTC
(In reply to Alex Thurgood from comment #7)
> Confirming on
> 
> Version: 4.4.0.0.alpha2+
> Build ID: c1358e5dc875bb923f4b5472ba615ebd19f0d057
> 
> osx 10.10

Followed instructions in comment 4 with test document provided
Comment 9 QA Administrators 2015-12-20 16:19:04 UTC Comment hidden (obsolete)
Comment 10 Alex Thurgood 2015-12-21 09:01:11 UTC
Confirming also in

Version: 5.2.0.0.alpha0+
Build ID: ce3d3f5543e3e132a3473af27aa2c827336add0f
CPU Threads: 2; OS Version: -; UI Render: default; 
Locale : fr-FR (fr.UTF-8)
Comment 11 QA Administrators 2017-01-03 19:57:21 UTC Comment hidden (obsolete)
Comment 12 eisa01 2017-08-27 19:32:41 UTC
I can confirm this issue as described in comment #4 on both Mac and Windows, so setting as All

1. Select one of the text boxes
2. Shift drag to select more of them
3. Shift drag over one of the cur ve items
4. Shift drag over more objects, and they are not added

-> If one of the cur ve objects are selected, you can't shift drag more

Version: 5.4.0.3
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
Locale: en-US (en_US.UTF-8); Calc: group

Version: 5.4.0.3 (x64)
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 1; OS: Windows 6.1; UI render: default; 
Locale: en-US (en_US); Calc: group
Comment 13 QA Administrators 2018-08-28 02:43:04 UTC Comment hidden (obsolete)
Comment 14 Alex Thurgood 2018-09-19 10:49:18 UTC
Still reproducible with
Version: 6.1.1.2
Build ID: 5d19a1bfa650b796764388cd8b33a5af1f5baa1b
Threads CPU : 8; OS : Mac OS X 10.13.6; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group threaded