Bug 59256 - Use LibreOffice dialogs option for print dialog is ignored
Summary: Use LibreOffice dialogs option for print dialog is ignored
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: Other All
: high major
Assignee: Andras Timar
URL:
Whiteboard: target:4.2.0 target:4.1.4
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-01-11 18:56 UTC by Ruslan Kabatsayev
Modified: 2013-11-13 14:19 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Dialog screeenshot (84.69 KB, image/png)
2013-01-11 23:55 UTC, m.a.riosv
Details
Dialog screeenshot (84.69 KB, image/png)
2013-01-11 23:58 UTC, m.a.riosv
Details
Dialog in linux (61.88 KB, image/png)
2013-01-12 09:45 UTC, Ruslan Kabatsayev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ruslan Kabatsayev 2013-01-11 18:56:42 UTC
Whatever the state of "Use LibreOffice dialogs" option for Print dialogs is, I always get LibreOffice dialog.
When this option is unset, GTK print dialog should appear.
Works OK in 3.6.5.0+, doesn't work in 4.1.0.0.alpha0+ (Build ID: 0260f0b256c3675bb6d836c0a2babb7626577b7)
Comment 1 Joel Madero 2013-01-11 19:29:39 UTC
For me I never have gotten a non LibreOffice print dialog. Since you say it worked on 3.6.5 I'll leave it be at the current version. 

To test:
1. Open LibreOffice
2. Go to General Options
3. Tick/Untick option to use LibreOffice dialog for printing
4. Bring up Print Dialog (ctrl + p)
5. See if there is any difference at all between checked/unchecked

Compare when it is unticked to when you try printing from another application. I always see LibreOffice dialog.

Marking as regression as Ruslan has said in older version it worked for him. 

If someone else sees this as a regression also, please bibisect if possible

Marking As:
New (confirmed)
Major (a major component of LibreOffice - printing - is not functioning correctly)
High (default for major bug)

Thanks Ruslan for reporting.
Comment 2 m.a.riosv 2013-01-11 22:09:12 UTC
Hi,

The option in Menu/Tools/LibreOffice/General is only for Open/Save dialog not for other dialogs.

So for me not a bug.
Comment 3 Joel Madero 2013-01-11 22:10:24 UTC
Underneath save/open there is "print" which has a similar option. I've seen some people don't have this (no idea why).
Comment 4 m.a.riosv 2013-01-11 23:55:42 UTC
Created attachment 72878 [details]
Dialog screeenshot

Win7x64 Ultimate
Version 4.1.0.0.alpha0+ (Build ID: 3db92283955741b490dc2d4f9e1782b179fee89)
TinderBox: Win-x86@6, Branch:master, Time: 2013-01-11_04:53:05
Comment 5 m.a.riosv 2013-01-11 23:58:49 UTC
Created attachment 72879 [details]
Dialog screeenshot

Proper content type
Comment 6 Ruslan Kabatsayev 2013-01-12 09:45:34 UTC
Created attachment 72896 [details]
Dialog in linux

Maybe this depends on OS, it might have been removed but not cleaned up in Linux.
Comment 7 Joel Madero 2013-01-12 18:25:02 UTC
It looks like in Windows you don't get the option to use LibreOffice dialogs. I'll have to ask one of the developers why this is so
Comment 8 Ivan Timofeev (retired) 2013-01-14 16:18:46 UTC
According to
http://opengrok.libreoffice.org/xref/core/vcl/unx/gtk/gdi/salprn-gtk.cxx#lcl_useSystemPrintDialog
system print dialog is an experimental feature.

Ruslan, can you confirm that enabling experimental features fixes the problem for you?
Comment 9 Ruslan Kabatsayev 2013-01-14 18:06:09 UTC
(In reply to comment #8)

> Ruslan, can you confirm that enabling experimental features fixes the
> problem for you?

Yes, it does make the option work, but then the bug should be in the fact that the option is there when experimental features are disabled.
Comment 10 Commit Notification 2013-11-13 09:30:13 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=97747499b26314bb308b12cd331bf0d99f21c96c

fdo#59256 hide this option when experimental features are disabled



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2013-11-13 14:19:29 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=310396aaa9c8b0e25053decbb673af339eebdec3&h=libreoffice-4-1

fdo#59256 hide this option when experimental features are disabled


It will be available in LibreOffice 4.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.