Bug 59273 - FILEOPEN: Writer doesn't display all table cells in DOCX file
Summary: FILEOPEN: Writer doesn't display all table cells in DOCX file
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.1 rc
Hardware: Other All
: medium normal
Assignee: Mateusz
URL:
Whiteboard: bibisected40 target:4.1.0 target:4.0.3
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-01-12 09:33 UTC by Mateusz
Modified: 2016-10-10 10:47 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
source file (5.05 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-01-12 09:33 UTC, Mateusz
Details
LibreOffice 3.6.4.3 VS 4.0.0.1 with Mac OSX 10.8.2 (299.70 KB, image/png)
2013-01-15 18:14 UTC, Jorendc
Details
How it's look in Word for Mac (=microsoft word for Mac osx) = correct behavior (93.54 KB, image/png)
2013-01-15 18:15 UTC, Jorendc
Details
LO 4.1 - 29.03.13 - huge regression (69.54 KB, image/png)
2013-04-01 07:51 UTC, Mateusz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mateusz 2013-01-12 09:33:58 UTC
Created attachment 72895 [details]
source file

Hey

There are steps to reproduce:

1. Choose right border of "Data wystawienia" row (right, upper corner of table)
2. Grab it and drag on the left. 
3. There will appear new row "Zaksięgować pod datą"

This picture show how it should looks. 
https://bugs.freedesktop.org/attachment.cgi?id=70160
Comment 1 Mateusz 2013-01-12 09:43:38 UTC
Comment on attachment 72895 [details]
source file

>PK��ìt@���������������_rels/.rels­MKAïýCîÝl+ÈÎö"Bo"õìîÐÎ3i­ÿÞA
>ºP Ç¼yóðÒmÎþ NAêiAq0Ѻ0jxÛ=/`Ó/ºW>ÔJ\*ªÞ¢aIÅLì©41q¨!fORÇ<b"³§qݶ÷2 1ÕÖjÈ[»µûHü76z²$&f^¦\¯³8.NydÑ`£y©qùj4x]hý{¡8ÎðS4GÏA®yñY8X¶·(¥[Fwÿi4o|˼ÇlÑ^âÍ¢ÃÙôPKèÐ#Ù���=��PK��ìt@���������������word/_rels/document.xml.rels­Ë
>Â0E÷~E½M[ADv#B·R? ¦Ó6(ú÷ªPÄE39÷0ÉÈ­ëµbD1TB×½j«ýrE¾È8p¸®7åtÞ-¥Nt(¹´A&¶ûPÚ.μEÆñÚOä_LRÖlY'@ª»Áغiz;-. ÎßtÈmÁ³èt|:g¼ºÈÚpÈ·ÁØú%±S¢ÑÊWü4à[bl½$ýúÞüPKE
èyÈ�����PK��ìt@���������������word/document.xmlí\ïnâ8ÿ~OåóµIP®îZíÝêºZz:i¿Çw8r)ùX©ÚgXícÜ#¼×Ù8N --éB!TJâ?ãÏü<ÇnÞ¼½ñ1B,Â4hαm(ÔÃA¿eþ}ýî¨a
PË£È|{ö˸éQ8ôQÀ
ÑB5i˲ ÁòAtäcÈhD{üR¿I{=Qz3S
>Ö2MËJiQÖ£Ì\$YßR$)/«bÛu!¸7à0Ò­â?ò®¯Ã5¦Ì("|¢øú�Y3½Fe;E¸gxå¢ ªÐ<êïRo,ï¼KÒ[ÉÏÐ#@Z&A=nZiáï¢!aåY¢
>¤
>Øòç"#
>¶gÏIˬº!É ÕlôùÔ]Ê9õKoýÐ.yx¢"Ø»JXøèÄÎ	^ÄÃ{ò±/î稪ÕJãT	·í¸uwYvý´¶,;ç¦pÅ¥ÜÙ÷RuC"E7�ò¬µZÊ
wB¹.álu^7ÕU§þY¢ÅnuBd¬Töèb}¤3i¸À}AË|G¢DJQëÜ$0Ý÷åý¾¯V{¡_÷KOì{¯ g)Ó[VnåpvI;|L2ÓE2QU
C_UÁdDt7+{ïé<
Ø wPøYÄÒò£º´Hgí¿fªLU}
QS¬ËPhSéô<Ò=@¢"X]Eάj½æ¢S_/|ëÓ,é·ÇÝ¢Ótrd½ÒU \çx%â¶1Þf£o%ÞVâíp`Äc1ËÇáê�w¹yKØn	¶@6?O¾!õðÉÝjôZyä=o)¬4à8¢}ëâà+îªÁßÍ~ûfð§/~RWÂ`_að:0ðQ	¡<êqcÛ9®ØNekNÍnìö/î(>¾7]øU2dÜwV½c)×o[Ü5CÓï¯Ovc?î�~@ïÔ4n:LWN9ÈÒ©zÖê]¢æ72>N�üéwF½/ÿýÅ`z;#Q'wÐ01ò¦·Ã¾ÁAüìM°'®$í*]Û.ÖUVÕÃÅݱÑRÎáÏáA|ãKL90é-årT47ß»Z¡]K»uºú¯ÕѾ¼* \<xSxéÔ*Õ×ñ2§ôEìOMoE`XF
ûD÷döJì¬NHY2¹ó<½Ý9Õzéu9ÄÅàÆm¬ÃJÜìn>cÄAÎcë0.AõzAõôwëêxkR槥UùÔ¬ìÔëôï±wRsǺùHµ«;6îÊ­Ïmå+ÏX÷ô4
·à7û±ºÞÏ÷>E¸ç\.67ø^¬rKØò´4øK­*8_¿«`ØÏøôÀpHÒKä+
ySß5(Ð7<Eè¦n)@7¼
ú©Ã~Gþãð`¶Eí64S»®+EZ£2*qNd­¥b]" ?äyb%¤r¢Úó¤°pHY]
ýk%jÏõ<±*ßh3­©æþ÷.]`&ºiæB	»îªbBù	ã`Ü£ºS­Í$Äjc
>ÜúL樧*׺´ô·(¬ü gÿPKAG��XD��PK��ìt@���������������word/numbering.xmlͱn0÷>òÞ 4
>dÔUôp6È6Iúö=c(U%`óõ?û,ow7V{*dÕð->ò(Ï¢âç}ö¯	ò¤"¼ uÃi~¨D»ìe{Ýð©�Î\n®)*j7˼¤ÈEÓR{§F0¢ 3¾6¢hES)áMVãÀ÷cÌHÅQ=ÉQ*ArõÙ1ï)½0\Ô¶*XRä÷O(¨]H­!áöì^ä0º©ËîtzTU	C
èw ·û÷âG>jzR¦Ü~	½(Ï®À´LQ¸
>н}Ç4`ÅØ,	?÷׺¯	î»ãþã}®ùFëxº¯¯£¾k¾ëÀîkaã«Ã¨ïÊ5ß$§ûZØøê0êºæ»ôýdºð@ã>*GÎ)/£gÖ@[eFcç·ÇÖ@[eF×Î)ák ­²N£ÊsÊQ2ãðh«¬Ó?ÊøéRbå¼þù¸¡<][þîÉa5·§ìPKïVÅ7��	��PK��ìt@���������������word/styles.xml½VÍRÛ0¾÷)<ºÇNÁ0t	i¦¥ö&ÛD,i${éCð}÷ªìX§Ø´å${wµÚïÛ]­NÏïêÜT³�ymä�xLØ,@o.Z=ä(Y)g %(t~öæ4ë+½¤ ³©~ ¹Ö¢ïº*CÕÀnÊeµù37ã2G qP×o·ÜάC§\¯â�& ¬¯Â-°Ä3ż0g8É­o1
Ð[,î)#ÜBwÚêJ/\Ld¾d$æÙ3-9-äª\Í6
>8 f秮tÜî!ëÂTçݧ*B`TóË¥SÖZËJëò|Y.&Ü«�ÝÄ:ÌyÏÌòã"U)¬ô@\©ªðV�
ªXI¹FriÅ&öúje~×Jj[F1YHbs­ÍؾÎ[Ãñ#i¶&£�·LõþÜwêä~gß~þÈ`átJXAüUÀNax'±�cc³2NÐ[úYÝUle^	ëqÃȪ"`äjO5%F[Îvê"´©²fSL4£®Ûºî+PשCÝ.I$­o·Ý6ïð·hnòìí\70Å)ÕÎÄ2ë伦ÃÂFP7£:¬¿óáÅþ4Ú8v<ZÐk/F7Ávë7£þ¸!àî×ÜmÿgÀ½f=úo;T	ê|Úy~1jC0#r¤íʾÛZC`;¬®
1nÎkI®øT;ð%µe7o1ßñ+ï5d÷¤»7î}w4,NÿáçH­¢´>$¿Ö[hDÌ{í]q²¿þFz6í6ºô2¯+måÒ�®WîǨæó½ÍÌï·=ã4	͸Vx~½6©Íi|ý6`Ô¯ÃèM7¼Q¿£¯YXöKýPKNö¼ô��ç��PK��ìt@���������������word/fontTable.xml­±NÃ0wÂòN: *jRua£¸&×Æí|&&o6P7ûþÿî³ÿÛî>¬=zÖä
>ù°Ê¤@WS£Ý¹oÕÓýF
>à0ä°²ÜwÛÈ©ÝqÙÐåJqÝ¢^Q.i'òBºú³äÎSÌiº5jeÊv²¼Î1w`¦ÒY0²p1Ô-xÆÑÓ)dI5õÕf«~²OB§CÝÎõ¼£ÁQRØèë`dYë[³öɲZüGÍüOTÕ÷bÿ\MH0á¤yÈ÷°Õ³oÀ/V¼ùS
àÝ/ÌëËOPKõ±À��é��PK��ìt@���������������docProps/app.xml1o1÷þ(;äèP!Bªºµ0¤í%>ÄQlüûVºvîøÞ³?[Oo¯94XF¹ZR@ñb9òݾ,ÖR»\£¼É­yÐG Ñ	Fyb®¥È ;Zö¸ôdÂwÙ
>§)zxFÎPX=Ã+C	uÊâæÂÿô÷ÿèÃÞjçm!×äÌÛ}3i5Ú"»dc³êö,ô®Ö½ãÞy¾!áÄbÿ}M|bZýÑê·óPKDZÏ���V��PK��ìt@���������������docProps/core.xmlOO0ï~
>Ò;´1¦¨ÙÉ%Fg4Þò²5Ò?iëؾ½Ðmuº¼ñö÷ðôm5ÛÊ>ÙuB«åA	(®[¡V5z]ÎÓ[8ÏTËz­ F;phÖ\UÜP®-<YmÀz.EÊQnj´öÞP_d.	5¶ùq´+lÿd+À!7Xg-óOÂÔD#:([æËöAÐr=HPÞá<Ëñ+߸øÆ1<¡=Xé.Â!äÖH
Ã
eàÆþ9~_<¾OM~ÔT5å6t_ì¼÷Ë9j
>))Ó,IIóòQá?ɹֶyf|Ý	ULT\¥gÎ/Æãë´w»î<åaíÿ%¯ÏJ¡.T}ã¦ßצùPK7ÊÐ:����PK��ìt@���������������[Content_Types].xml½OO0ïû¤WEÆ`ºM×¾@#ý¾Ýܾ½/Û$FÍJ¼4}¿ç)4Ëé-ÔÎì2ËYV:¥m[²§ú>½aËjQÔ{ЬÅu1ú[ÎQv`fÎ¥Æ#"-C˽/¢~ç×\:ÁÆ4¬*	´d%B|JÆôȳáÉ»c``Lxßk)"ùñ­Uhé4$3Øi4Àø÷¤WÔ	§Üe4þoèÐñ\Óh	c~hóÁI@¤E'wÐvÒÃnÌ%ç«'%0î{Àù
½øµX÷0¿ÁX}Nâ«à<rýYvT Ròð¢>ÿF¶táç¿üCú+qQðãzPKTÍ8)��`��PK���ìt@èÐ#Ù���=�������������������_rels/.relsPK���ìt@E
èyÈ��������������������word/_rels/document.xml.relsPK���ìt@AG��XD���������������$��word/document.xmlPK���ìt@ïVÅ7��	���������������ª��word/numbering.xmlPK���ìt@Nö¼ô��ç���������������y	��word/styles.xmlPK���ìt@õ±À��é���������������ª��word/fontTable.xmlPK���ìt@DZÏ���V���������������ì
��docProps/app.xmlPK���ìt@7ÊÐ:�����������������ù��docProps/core.xmlPK���ìt@TÍ8)��`���������������r��[Content_Types].xmlPK����	�	�=��Ü����
Comment 2 Joel Madero 2013-01-14 17:55:42 UTC
Can you describe the problem a bit more? I see reproducible steps but don't see a clear description of the problem. Thanks.

Marking as NEEDINFO, once you provide this info please open the bug back up as UNCONFIRMED.

Thanks!
Comment 3 Mateusz 2013-01-14 18:34:31 UTC
I thought my bug report is clear enough. Sorry for my mistake.

So, in original file, table is built from 4 columns

( screenshot: https://bugs.freedesktop.org/attachment.cgi?id=70160 ) 

LO import whole table but displays only 3 columns. Forth column is associated with third one and if I want see missed column I must grab the latest border (from the right side) and drag it on the left.
Comment 4 Jorendc 2013-01-15 18:14:04 UTC
I can reproduce that behavior;

Also the tables looks quite different in 3.6 vs 4.0.
Comment 5 Jorendc 2013-01-15 18:14:43 UTC
Created attachment 73112 [details]
LibreOffice 3.6.4.3 VS 4.0.0.1 with Mac OSX 10.8.2
Comment 6 Jorendc 2013-01-15 18:15:20 UTC
Created attachment 73113 [details]
How it's look in Word for Mac (=microsoft word for Mac osx) = correct behavior
Comment 7 Mateusz 2013-01-16 16:06:10 UTC
(In reply to comment #5)
> Created attachment 73112 [details]
> LibreOffice 3.6.4.3 VS 4.0.0.1 with Mac OSX 10.8.2

I have the same on 3.6.3.2 and 4.0.0.1 with Ubuntu 10.0.4 (earlier I didn't know that it's regression)

Joel Madero, could You find author of this changes alike you do it at fdo#59275 case?
Comment 8 Joel Madero 2013-01-16 16:15:03 UTC
I can only bibisect a bug that I have a working version and a non working version. For instance if on 3.6.3.2 it worked but then by 3.6.4 it is broken, then it's a regression I can track down, if it's just broken on multiple versions then I can't bibisect it. 


Adding Michael - any opinions?
Comment 9 Mateusz 2013-01-16 16:57:55 UTC
So this error exists only in 4.0.0.1. LibreOffice 3.6.3.2 (Ubuntu) and 3.6.4.3 (Mac) are free from this bug.
Comment 10 Mateusz 2013-01-22 17:06:26 UTC
I tested daily build from 21.01.13 and bug still exist there. Meanwhile I test it with some master build (LO 4.1) and in this compilation, file has been displayed correctly, like in Word.
Comment 11 Mateusz 2013-02-07 17:07:30 UTC
Joel, could you fix it before 4.0.1 release? It's regressions regarding to 3.6 line.
Comment 12 Michael Stahl (CIB) 2013-02-20 22:31:23 UTC
bibisect says it changed in b6c016da23d309b4ac7d154bc33a22397974ed73..d85fd8a85501547d5bb87822d2589a07aed7f2d6

which contains this:

commit ad913681c0e0cdaaa706329f518f59ee54b86d43
Author: Miklos Vajna <vmiklos@suse.cz>
Date:   Mon Nov 19 12:41:39 2012 +0100

    n#780645 DOCX import: add support for fixed column width



looking at the file we find...

      <w:tblGrid>
        <w:gridCol w:w="4289"/>
        <w:gridCol w:w="1363"/>
        <w:gridCol w:w="1695"/>
        <w:gridCol w:w="1"/>
      </w:tblGrid>

        <w:tc>
          <w:tcPr>
            <w:tcW w:type="dxa" w:w="1"/>
            <w:gridSpan w:val="2"/>
            ...
          </w:tcPr>
          <w:p>
            ...
            <w:r>
              ...
              <w:t>Zaksięgować pod datą</w:t>
            </w:r>
          </w:p>
        </w:tc>

        <w:tc>
          <w:tcPr>
            <w:tcW w:type="dxa" w:w="1"/>
            <w:gridSpan w:val="2"/>
            ...
          </w:tcPr>
          <w:p>
            ...
            <w:r>
              <w:rPr/>
              <w:t>31.01.2012</w:t>
            </w:r>
          </w:p>
        </w:tc>

which seems to say that the last column has a width of 1 (one) twips
which would explain why it is ~invisible in Writer.

the mystery is more why does Word display it very visibly...
Comment 13 Miklos Vajna 2013-03-26 10:49:51 UTC
So it turns out the n#780645 bugdoc contained <w:tblLayout w:type="fixed"/>, but I failed to notice this detail when creating the testcase. I'll adjust the importer not to consider fixed column width, when the layout type is auto, which is the default ('17.4.53 tblLayout (Table Layout)' section of 'ISO/IEC 29500-1:2008(E)').
Comment 14 Commit Notification 2013-03-26 14:26:03 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7329df74df134a77d078f47d5c8b70d54c5d1edb

fdo#59273 import w:tblLayout of DOCX tables



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Miklos Vajna 2013-03-26 15:35:27 UTC
4-0 review: https://gerrit.libreoffice.org/3058
Comment 16 Commit Notification 2013-03-26 16:50:40 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0dd9158a1fe48dee192a954a8ea24c2efcd64a86&h=libreoffice-4-0

fdo#59273 import w:tblLayout of DOCX tables


It will be available in LibreOffice 4.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 17 Mateusz 2013-04-01 07:51:27 UTC
Created attachment 77266 [details]
LO 4.1 - 29.03.13 - huge regression

@Miklos Vajna 

I have no idea what You done but whole table is broken and everything looks much worse than before.
Comment 18 Miklos Vajna 2013-04-02 08:36:38 UTC
Seems this is caused by commit 6718482c072defe5d885030826fef5ef833732e9, which went in on 28th. So it is not me who have "done something", but Sven. ;-)

Anyway, I'll look into this.
Comment 19 Commit Notification 2013-04-02 10:04:21 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c433a482cf249485e7fa3e71362b107f0eafa705

fdo#59273 DOCX import: fix table width when w:tblW is missing



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 20 Miklos Vajna 2013-04-02 10:28:34 UTC
No fix to backport, as 6718482c072defe5d885030826fef5ef833732e9 wasn't backported to -4-0, either.

And forgot to say, thanks for the feedback! :-)
Comment 21 Mateusz 2013-04-03 11:00:42 UTC
Miklos Vajna

Every new change turn out to be (another) annoying regression. Pleas look at https://bugs.freedesktop.org/show_bug.cgi?id=59274