Bug 59299 - [PERSONAS] only applies to toolbars at top
Summary: [PERSONAS] only applies to toolbars at top
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.1 rc
Hardware: All All
: medium enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:4.4.0
Keywords: difficultyInteresting, easyHack, skillCpp, topicUI
: 60653 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-12 22:57 UTC by h.venhorst
Modified: 2016-09-24 19:30 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of Writer with persona (171.64 KB, image/png)
2013-01-12 22:57 UTC, h.venhorst
Details
screenshot of Writer with persona - take 2 (171.64 KB, image/png)
2013-01-12 23:11 UTC, h.venhorst
Details
bottomtoolbar/statusbar with theme, theme text color (665.55 KB, image/png)
2014-09-11 08:45 UTC, Michael Jaumann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description h.venhorst 2013-01-12 22:57:45 UTC
Created attachment 72930 [details]
screenshot of Writer with persona

Personas are only applied to toolbars at the top of the window.
Toolbars to the left- right- and bottom, and floating toolbars remain standard
Comment 1 h.venhorst 2013-01-12 23:11:23 UTC
Created attachment 72931 [details]
screenshot of Writer with persona - take 2
Comment 2 Jorendc 2013-01-13 14:15:05 UTC
Hi,

Thanks for reporting. 
That's the correct behavior so far. Maybe this will be available in later versions. Therefore this is not a bug, but an enhancement. I see Kendy is already in CC, so he'll have a look at it when he have time for it.

Kind regards,
Joren
Comment 3 Florian Reisinger 2013-01-26 15:04:57 UTC
Valid with Version 4.0.0.2 .0.2 (Build ID: 5991f37846fc3763493029c4958b57282c2597e)@ Win7 x64
Comment 4 Adolfo Jayme 2013-02-12 19:07:48 UTC
*** Bug 60653 has been marked as a duplicate of this bug. ***
Comment 5 Jan Holesovsky 2013-11-11 09:11:14 UTC
The bars at the left and right are not possible - the personas / themes do not have suitable bitmaps for that.

The bottom (toolbar + status bar) would be possible; unfortunately cannot get to that soon, so if anybody wanted to hack on this, let me give you code pointers, and turn this into a (slightly advanced) EasyHack:

http://opengrok.libreoffice.org/search?q=GetPersonaHeader&project=core&defs=&refs=&path=&hist=

You have to do a similar thing for the footer too.  The footer bitmap is already in place, you just need to provide that as a bitmap, and then use in the toolbox (in vcl/source/window/toolbox.cxx) that is at the bottom (pThis->GetAlign() == WINDOWALIGN_BOTTOM), and in the status bar - vcl/source/window/status.cxx (StatusBar::ImplInitSettings()).

The status bar will be easier, so I highly recommend first implement the functionality for the status bar only, and then let's make it begin in the bottom toolbar :-)
Comment 6 Michael Jaumann 2014-09-10 07:19:33 UTC
Hi, i want to work on this bug.
Comment 7 Michael Jaumann 2014-09-11 08:42:42 UTC
He,

as far as i am i have a view questions:

1. this features works:

  persona/themes on the bottom toolbars/ statusbar.

  textColor is the same as in the menu bar.(menubar textcolor changes with switching between personas). (Wasnt implemented till yet in the upper toolbars)
 -> needs a restart of LO after changing theme
2. dosent work as expected :

persona consists of two parts: header and footer bitmap. the problem is that the header and footer bitmap are the same. My solution. I use for the top toolbars the top area and for the bottom toolbars the part up from the bottom area.

Is my solution okay? Created an attachment the shows the progress.

Thanks !
Comment 8 Michael Jaumann 2014-09-11 08:45:14 UTC
Created attachment 106112 [details]
bottomtoolbar/statusbar with theme, theme text color
Comment 9 Michael Jaumann 2014-09-12 09:19:24 UTC
header/footer bitmaps works now,

removed persona feature for statusbar.
Comment 10 Commit Notification 2014-09-29 17:45:43 UTC
Michael Jaumann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0ed0974298992ae871a8fbe79f856cf2588aeec6

fdo#59299 Personas for bottom toolbars



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Mike §chinagl 2014-12-20 21:56:55 UTC
This bug fix comes with LibreOffice 4.4 (release notes https://wiki.documentfoundation.org/ReleaseNotes/4.4) 


Firefox themes now apply also to bottom toolbars.

See a graphic of the work:
https://wiki.documentfoundation.org/File:Toolbartheme.png
Comment 12 Robinson Tryon (qubit) 2015-12-16 00:38:41 UTC Comment hidden (obsolete)