Download it now!
Bug 59398 - Using KDE dialogs - saving files or export PDF > libreoffice crash
Summary: Using KDE dialogs - saving files or export PDF > libreoffice crash
Status: RESOLVED DUPLICATE of bug 69002
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-15 08:09 UTC by thomi_ch
Modified: 2013-11-19 16:07 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice error message (11.01 KB, image/png)
2013-01-15 08:09 UTC, thomi_ch
Details
writer crash gdbtrace (23.70 KB, text/x-log)
2013-11-11 12:41 UTC, josephk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description thomi_ch 2013-01-15 08:09:44 UTC
Created attachment 73053 [details]
LibreOffice error message

Hey all

My System: Kubuntu 12.10

LSB Version:    core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch
Distributor ID: Ubuntu
Description:    Ubuntu 12.10
Release:        12.10
Codename:       quantal


apt-cache policy libreoffice
libreoffice:
  Installed: 1:3.6.4-0ubuntu1~quantal1
  Candidate: 1:3.6.4-0ubuntu1~quantal1
  Version table:
 *** 1:3.6.4-0ubuntu1~quantal1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ quantal/main amd64 Packages
        100 /var/lib/dpkg/status
     1:3.6.2~rc2-0ubuntu4 0
        500 http://ch.archive.ubuntu.com/ubuntu/ quantal-updates/universe amd64 Packages
     1:3.6.2~rc2-0ubuntu3 0
        500 http://ch.archive.ubuntu.com/ubuntu/ quantal/universe amd64 Packages


KDE 4.9.5


Reproduce:
1. Create new writer/calc document with some text and save it, default filename will be "Untitled 1.odt/ods"

2. Click on PDF icon or do "File / Export as PDF", filename will be "Untitled 1.pdf"

3. Error happens, see attachment: libreoffice-error-01.png

This happens eter if LibreOffice dialogs ar choosen or that one from KDE


If i change the filename from "Untitled 1.odt" to "Untitled1.odt" (w/o space), then PDF export works.

Above also occurs if the path of the filename contains spaces...

Sometimes LibreOffice crashes complete and on writer open i need to recover the file...

Thanks for any hint/solution/fix

Regards
thomi
Comment 1 thomi_ch 2013-01-15 09:50:29 UTC
Hey

I found one issue:
locked files, that are still in the folder of the file, removed those but I think it relates to libreoffice-kde. I have tested this:

Tools/Options
LibreOffice/General: "Use LibreOffice dialogs" for Open/Save and print

1. create new odt file, save it as "Untitled 1.odt"
2. close LibreOffice
3. open above file "Untitled 1.odt"
4. export to PDF, filename as proposed with automatic file name extension

Do step 1 to 4 two, three times...

Next, change dialog options in Tools/Options to not using LibreOffice dialogs, so it uses on my system KDE dialogs.
On Step 1 (create and save) LibreOffice writer crashes and this file remains on the destination file i wanted to save the new file:

.~lock.Untitled 1.odt#

On next LibreOffice writer start, it asked me to recover "Untitled 1"...
Then i tried again to save it... see first attachment " LibreOffice error message". I think this cases the remaining lock file... If i remove the lock file writer crashes and i need to recover it again... While trying save it again.. it starts over -> crash -> remaining lock file -> recover...


I think it's not only related to PDF export, it also related for saving a new file...

Will change also the title here.. hope some other can confirm above steps...

Thanks
thomi
Comment 2 Trebacz 2013-01-30 00:28:36 UTC
I'm seeing the same issue. I'm using Kubuntu 12.10. I saw the problem on pdf export and save as. All of my file names had spaces in them. Switching to "LibreOffice dialogues" does seem to work. I continue to monitor.
Comment 3 emilio.recio 2013-09-12 16:55:57 UTC
same issue here for "save as..." dialog box
Comment 4 josephk 2013-11-11 12:41:16 UTC
bug CONFIRMED in Writer 4.1.3.2.

actually, removing libreoffice-kde package on Arch Linux solves the problem.

Debug file attached.

First bug report here, hope it gets quickly fixed, i've lost a hour work..
Comment 5 josephk 2013-11-11 12:41:58 UTC
Created attachment 89022 [details]
writer crash gdbtrace
Comment 6 Rene Engelhard 2013-11-11 12:46:08 UTC
see also http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=728987 - _maybe_ it's the same one?
Comment 7 emrecio 2013-11-11 20:40:53 UTC
Rene - it is definitely the same one.
Comment 8 excognac 2013-11-12 13:22:09 UTC
I have the same issue with the following differences under 13.10 kubuntu: 
apt-cache policy libreoffice
libreoffice:
  Installed: (none)
  Candidate: 1:4.1.2~rc3-0ubuntu1
  Version table:
     1:4.1.2~rc3-0ubuntu1 0
        500 http://hu.archive.ubuntu.com/ubuntu/ saucy/universe amd64 Package

Never crashed while creating pdf.

I only can truly reproduce the crash when I hover with mouse over directories into "Save as" files OR when I try to change format from default OR rename the file in that field.
Comment 9 josephk 2013-11-15 20:21:06 UTC
i'd contact the libreoffice-kde mantainer, if there is one at all.

the actual state of the code is quite disappointing.

Operator could mark this bug as CONFIRMED.
Comment 10 Maxim Monastirsky 2013-11-19 16:07:11 UTC
Don't know about the original report, but the latest comments look like a duplicate of Bug 69002, which already has a pending patch at gerrit: https://gerrit.libreoffice.org/#/c/6685/

*** This bug has been marked as a duplicate of bug 69002 ***