Download it now!
Bug 59399 - FILEOPEN: LibreOffice cannot open .xlsx file in strict variant
Summary: FILEOPEN: LibreOffice cannot open .xlsx file in strict variant
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.3.0 target:4.2.3
Keywords:
Depends on:
Blocks: OOXML-Import-Strict
  Show dependency treegraph
 
Reported: 2013-01-15 08:42 UTC by paolog
Modified: 2016-10-25 18:06 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
test file produced with Microsoft Excel 2013 preview (7.87 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-01-15 08:42 UTC, paolog
Details

Note You need to log in before you can comment on or make changes to this bug.
Description paolog 2013-01-15 08:42:28 UTC
Created attachment 73054 [details]
test file produced with Microsoft Excel 2013 preview

The attached file was saved by the preview of Excel 2013 in the "strict" variant. Try to open it. LibreOffice does not detect this file format, but opens the dialog to choose a file type. If you select "Office Open XML" the file cannot be opened.

              
Operating System: Debian
Version: 3.5.4 release
Comment 1 S K 2013-02-10 11:03:22 UTC
This file doesn't open in in LibreOffice 4.0.0.3. 

It's type is not detected. When checking Office Open XML SpreadSheet it shows "Input/Ouput error"
Comment 2 ringe 2013-03-08 18:46:00 UTC
This file can't be opened in 4.0.1.2 either. LibO tries to repair but fails.
Comment 3 retired 2013-12-13 11:21:05 UTC
Setting this to NOTABUG. The file is plain broken. If I try opening it with any LO version I get Input/Output Error.

But if I try opening the file with Word 2011 on OSX 10.9 Excel will not open the file as well with the info that the file format is invalid.

So if Excel cannot open this, the behavior is not a bug but expected.
Comment 4 Philip Smith 2014-01-17 18:37:18 UTC
I believe the point is that this kind of .xlsx file, made by Excel 2013 (if requested), is in the *new* MS format OOXML strict variant that old Excel (pre 2013?) cannot read and LO cannot yet read. As this format has become an ISO standard, and as people start to use the strict variant for standards/compatibility reasons, it would be very useful for LO to support it (though also encourage use of ODF).

Bug 56048 is the same thing for the new .docx format and has just been made highest priority.
Comment 5 retired 2014-01-18 08:18:23 UTC
Philip, thanks a lot for clarifying what's requested here. So MS Office 2013 is needed for testing this  I guess. That's not available on OSX (thanks MS for that).

Setting to NEW and sorry for closing this to quickly.
Comment 6 Jorendc 2014-03-19 22:30:10 UTC
Should be fixed, thanks to Markus (see commit: http://cgit.freedesktop.org/libreoffice/core/commit/?id=e34870c2396db160c15e3e9bbf3efabf55ee2839 and related in the same date-range).

@Markus: please feel free to correct me if I'm wrong :-).

Attached documents opens correctly, tested using Windows 8.1 with LibreOffice Version: 4.3.0.0.alpha0+
Build ID: 90dd4320de6ace24e464979630a2c9fbab35f64b
TinderBox: Win-x86@39, Branch:master, Time: 2014-03-19_00:22:53

Kind regards,
Joren
Comment 7 Markus Mohrhard 2014-03-20 00:17:38 UTC
Also available in the upcoming 4.2.3