Bug 59463 - EDITING: "Record/track changes": image deletion isn't recorded
Summary: EDITING: "Record/track changes": image deletion isn't recorded
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: Other All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0
Keywords:
Depends on:
Blocks: Track-Changes-Image
  Show dependency treegraph
 
Reported: 2013-01-16 13:05 UTC by Andrew Shadura
Modified: 2021-08-31 09:11 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Shadura 2013-01-16 13:05:36 UTC
Deleting or adding images while “record changes” is on, isn't actually saved; when “show changes” is enabled, those aren't displayed as changes (with overstrike/underline and colour).

Reproducible always regardless of the file format.
Comment 1 Joel Madero 2013-01-16 16:36:53 UTC
Verified on 3.6.3.2, changing version.

@Reporter - Version reflects the oldest version that you have seen this behavior, not the newest that it has been tested on. We use comments to say we tested on a later release.

Marking as:
New (confirmed)
Normal (bug that affects a basic feature of LibO, makes it only half functional)
Low (only affects one subset of a feature, inserting images, not a lot of users affected)


Thanks for helping out!
Comment 2 m.a.riosv 2013-01-16 23:53:39 UTC
I do not think this is a bug, maybe can be request for enhancement.

In the LibreOffice help

"
Recording Changes 

The review function is available in LibreOffice for text documents and spreadsheet documents.

Not all changes are recorded. For example, the changing of a tab stop from align left to align right is not recorded. However, all usual changes made by a proofreader are recorded, such as additions, deletions, text alterations, and usual formatting.
"
Comment 3 Andrew Shadura 2013-01-16 23:57:55 UTC
“If a bug is documented, it is a feature”. It doesn't work like this. A direct LO competitor does that in the supported format, so it's certainly a bug, or a bad format support.
Comment 4 Andrew Shadura 2013-01-16 23:59:22 UTC
(In reply to comment #2)
> I do not think this is a bug, maybe can be request for enhancement.

Also, see this:

> such as additions, deletions, text alterations, and usual formatting.

It doesn't say “text deletions”. So it applies to images as well, doesn't it?
Comment 5 A (Andy) 2015-02-06 22:28:25 UTC
Reproducible with LO 4.4.0.3, Win 8.1.

I think Track Changes should record deletions of images.
Comment 6 QA Administrators 2016-02-21 08:35:57 UTC Comment hidden (obsolete)
Comment 7 Gonzalo HIGUERA DÍAZ 2017-02-16 22:58:18 UTC
This is still a valid bug/enhancement request on LibreOffice 5.3.0.3 (running on macOS 10.12.3 Sierra). When choosing to compare a document with a previous version where an image has been replaced by another, only the image from the starting document is shown and there is no mention of the change in the Manage Changes window.
Comment 8 Alex Thurgood 2017-02-17 14:08:10 UTC
The feature in question was never (completely) implemented to my knowledge, at least not in OpenOffice.org prior to the creation of the LibreOffice project and certainly not in StarOffice before that.

Setting as RFE.
Comment 9 Commit Notification 2021-04-27 14:28:34 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d6322bcedc197a654abc7d64bfea8cf570f123bf

tdf#59463 track changes: record deletion of images

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 László Németh 2021-04-27 14:34:49 UTC
Limit this issue only for deletion, separating image insertion in a different bug report. Insertion differs from the (likely more important, because lossy) deletion, and it's not possible to use the same workaround for it.a
Comment 11 László Németh 2021-04-27 14:35:01 UTC
tdf#59463 track changes: record deletion of images

Instead of deleting the image object without
recording the deletion, delete the anchor point
in the text to record the deletion, if Record
Changes is enabled.

Note: only images anchored as characters can be
recorded this way, so change the anchor before
the deletion, if needed. This less problem, than
hidden, i.e. non-tracked deletion of images.
Comment 12 Roman Kuznetsov 2021-04-28 09:14:34 UTC
(In reply to László Németh from comment #11)
> tdf#59463 track changes: record deletion of images
> 
> Note: only images anchored as characters can be
> recorded this way, so change the anchor before
> the deletion, if needed. This less problem, than
> hidden, i.e. non-tracked deletion of images.

So it's only partially fixed? What will happen if i have an image with paragraph anchiring? And if I didn't read your note?
Comment 13 Andrej Shadura 2021-04-28 10:02:49 UTC
(In reply to László Németh from comment #11)
> Note: only images anchored as characters can be
> recorded this way, so change the anchor before
> the deletion, if needed. This less problem, than
> hidden, i.e. non-tracked deletion of images.

László, I assume you created a separate bug to track the remaining part of the issue, could you please link it here so that we subscribe to it?

Köszönöm :)
Comment 14 László Németh 2021-04-28 13:36:09 UTC
(In reply to Roman Kuznetsov from comment #12)
> (In reply to László Németh from comment #11)
> > tdf#59463 track changes: record deletion of images
> > 
> > Note: only images anchored as characters can be
> > recorded this way, so change the anchor before
> > the deletion, if needed. This less problem, than
> > hidden, i.e. non-tracked deletion of images.
> 
> So it's only partially fixed? What will happen if i have an image with
> paragraph anchoring? And if I didn't read your note?

It is fixed for all anchoring types: it changes the anchor automatically in the recorded deletion. Undo and Cut haven't been changed: Undo reverts both image deletion and anchor change at once. Cut & Paste copies the image with the original anchor, but if track changes is enabled, it records the deletion of the image at Cut, too.

It seems, it's possible to store the deleted image with "paragraph" and "to-char" anchor in ODF, but unfortunately, that is not back-compatible in LibreOffice: change tracking shows a deleted space, and in the case of anchoring to "paragraph", the image is imported as not deleted, which could be a serious problem.
Comment 15 László Németh 2021-04-28 13:53:19 UTC
(In reply to Andrej Shadura from comment #13)
> (In reply to László Németh from comment #11)
> > Note: only images anchored as characters can be
> > recorded this way, so change the anchor before
> > the deletion, if needed. This less problem, than
> > hidden, i.e. non-tracked deletion of images.
> 
> László, I assume you created a separate bug to track the remaining part of
> the issue, could you please link it here so that we subscribe to it?
> 
> Köszönöm :)

Andrej, it is already queued, so my colleague will file it within a few days, and link it here, too. Дзякуй for asking! :)
Comment 16 László Németh 2021-04-30 14:09:30 UTC
@Andrej: Thanks to Gábor Kelemen, here is the new bug: 

https://bugs.documentfoundation.org/show_bug.cgi?id=141994

Also the deleted images (also deleted flying tables etc. anchored to character) got a crossing out:

https://bugs.documentfoundation.org/show_bug.cgi?id=78864
Comment 17 Dieter 2021-08-31 09:11:42 UTC
Bug 144206: Add this improvement to documentation