Download it now!
Bug 59470 - FILEOPEN: Libreoffice doesn't respect text formatting when importing XLSX file
Summary: FILEOPEN: Libreoffice doesn't respect text formatting when importing XLSX file
Status: CLOSED DUPLICATE of bug 55875
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-16 14:55 UTC by Antonello
Modified: 2013-01-16 16:03 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
xlsx file that will be wrongly imported (8.09 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-01-16 14:55 UTC, Antonello
Details
An equivalent working .xls file (17.00 KB, application/vnd.ms-excel)
2013-01-16 14:57 UTC, Antonello
Details
an other real-case example of wriongly xlsx file (8.65 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-01-16 14:58 UTC, Antonello
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Antonello 2013-01-16 14:55:57 UTC
Created attachment 73147 [details]
xlsx file that will be wrongly imported

In the attached .xlsx file a cell has the **string** "DEC01". This is wrongly interpreted by libreoffice as a date rather than a text.
It works correctly instead opening the equivalent.xls file.
              
Operating System: Ubuntu
Version: 3.6.2.2 release
Comment 1 Antonello 2013-01-16 14:57:06 UTC
Created attachment 73148 [details]
An equivalent working .xls file
Comment 2 Antonello 2013-01-16 14:58:01 UTC
Created attachment 73149 [details]
an other real-case example of wriongly xlsx file
Comment 3 Eike Rathke 2013-01-16 16:03:19 UTC
Fixed in 3.6.4 with the fix for bug 55875

*** This bug has been marked as a duplicate of bug 55875 ***