Bug Hunting Session
Bug 59472 - Calc locks other open spreadsheets when selecting cells for function in function guide
Summary: Calc locks other open spreadsheets when selecting cells for function in funct...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: x86-64 (AMD64) Windows (All)
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-16 15:55 UTC by jon
Modified: 2015-03-28 21:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jon 2013-01-16 15:55:46 UTC
When having two windows open in Calc and in one of them you start the function guide, select a function and click the selection button for the data for it. You can now select the data in the spreadsheet, but the other window with another spreadsheet will be locked. It will in fact be locked until you close the function guide of the first window altogether.

Steps to reproduce:

Open two spreadsheets in calc (each in its own window)
Click a cell in spreadsheet one and open the function guide (insert -> function)
Double-click a function to add it
Click the selection button to select cells to use for the function

Spreadsheet two will now be locked until you exit the function guide of spreadsheet one. The second window should not be affected at all by these actions.
Comment 1 Markus Mohrhard 2013-01-16 16:42:57 UTC
What do you expect from a modal dialog?
Comment 2 jon 2013-01-16 16:47:17 UTC
(In reply to comment #1)
> What do you expect from a modal dialog?

I expect a modal dialog to lock its parent window, not the sibling windows of its parent.
Comment 3 Ken Biondi 2013-06-22 03:02:10 UTC
This is not really a defect of LO, but a request to make a current feature better.  There is a work around for this in the following link

https://help.libreoffice.org/Calc/Referencing_a_Cell_in_Another_Document
Comment 4 QA Administrators 2015-03-16 23:57:53 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

    Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
    https://www.libreoffice.org/download/

    If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
  
  If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

    Update the version field
    Reply via email (please reply directly on the bug tracker)
    Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-03-16
Comment 5 Jean-Baptiste Faure 2015-03-28 21:51:36 UTC
Works as expected in LibreOffice 4.4.3.0.0+ built at home under Ubuntu 14.10 x86-64. Second file is not locked.

Closing as WorksForMe.

Best regards. JBF