Bug 59516 - FILEOPEN: Native MySQL-connector couldnt be installed under Windows in LO 4.0
Summary: FILEOPEN: Native MySQL-connector couldnt be installed under Windows in LO 4.0
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.0.0.1 rc
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 59533 61367 (view as bug list)
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2013-01-17 15:39 UTC by Robert Großkopf
Modified: 2013-08-06 09:46 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2013-01-17 15:39:31 UTC
With windows you could install and work with mysql-connector-ooo-1.0.1-windows-intel or aoo-my-sdbc-1.1.0. Both versions couldn't be installed any more since LO 4.0 RC1:
loading component library failed: ... mysqlc.uno.dll
Comment 1 Fernand 2013-01-18 08:14:49 UTC
works still on LO 4.0 dev with windows XP
Comment 2 Robert Großkopf 2013-01-19 08:47:30 UTC
*** Bug 59533 has been marked as a duplicate of this bug. ***
Comment 3 Robert Großkopf 2013-01-19 08:48:41 UTC
Confirmed by the report https://bugs.freedesktop.org/show_bug.cgi?id=59533 , which I marked as duplicate of this report.
Comment 4 Michael Stahl (CIB) 2013-01-19 14:19:48 UTC
i bet this is caused by lack of STLPort library, which is needed
on 32-bit Linux and 32-bit Windows; if the extension still works
on other platforms then that's the reason.
Comment 5 Lionel Elie Mamane 2013-04-15 08:38:09 UTC
*** Bug 61367 has been marked as a duplicate of this bug. ***
Comment 6 Robert Großkopf 2013-04-16 15:17:58 UTC
Removed 63585 from "See Also:" - seems to be a wrong link. Has nothing to do with MySQL or Base.
Comment 7 Michael Meeks 2013-05-20 12:18:20 UTC
A re-compiled version that will work should now be here:

http://extensions.libreoffice.org/extension-center/mysql-native-connector-for-libreoffice-4.x

Thanks to Jesus; so closing this - thanks for the report !
Comment 8 w.sirges 2013-05-21 21:15:11 UTC
I just checked the link, but it's still not there.
Comment 9 Fernand 2013-05-22 12:48:37 UTC
ok i reported the problem to Jézus Corius
Comment 10 w.sirges 2013-05-31 18:49:59 UTC
Ahem, it's still not there.
Comment 11 Thorsten Behrens (CIB) 2013-06-05 15:15:57 UTC
(In reply to comment #10)
> Ahem, it's still not there.
>
It seems to be, for me - are you still not able to obtain it?
Comment 12 Jesus Corrius 2013-06-05 15:18:44 UTC
(In reply to comment #10)
> Ahem, it's still not there.

It's also possible to download it from here:

https://dl.dropboxusercontent.com/u/193133/mysql-connector-ooo.oxt
Comment 13 w.sirges 2013-06-05 20:52:40 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > Ahem, it's still not there.
> >
> It seems to be, for me - are you still not able to obtain it?

With the link posted in comment #7, there is still no extension available to me. I tried with Firefox, IE & Opera. No luck.

But I now have the new extension. Fernand (comment #9) was so kind to send it to me by email, and the additional link provided by Jesus (comment #12) is working as well. Thank you both!

Right now I'm setting up/updating a VM to carry out some tests. This may take some time, I'll keep you informed.
Comment 14 ribotb 2013-06-06 08:58:59 UTC
Hi,

I downloaded extension with Jesus Corrius url.
Download is OK.
Installation under Win 7 32bits with LO 4.0 and LO 4.1.0 beta1 is OK.
Extension works correctly.

Thanks,
Bernard Ribot
Comment 15 Jochen 2013-06-06 09:09:41 UTC
(In reply to comment #14)

May I ask: how can the "normal" user know about the url or the procedure about installing mysql-connector or receiving the extension (e.g. online-help in LO or something else).
Comment 16 Jesus Corrius 2013-06-06 09:18:09 UTC
I think now the download should work fine for everybody in the extensions site.
Comment 17 ribotb 2013-06-06 10:34:46 UTC
It's still not there !

Bernard
Comment 18 w.sirges 2013-06-08 20:31:45 UTC
I have finished my tests and can confirm that the new connector is working correctly with Windows 7 & 8, both 32 & 64 bits. Thanks to all that helped!
Comment 19 Michael Meeks 2013-06-10 09:04:44 UTC
so - re-marking fixed :-) ribotb - can you confirm ?
Comment 20 ribotb 2013-06-11 09:20:23 UTC
Sorry for the delay.

Yes, I confirm. Extension (downloaded at url given in comment#12) can be installed under LO4 and it works.
Tested with LO4.0.3 and LO4.1.0 beta2.

Bernard