Bug Hunting Session
Bug 59706 - EDITING: writer provides no cursor access in boxes outside text margin
Summary: EDITING: writer provides no cursor access in boxes outside text margin
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-22 10:42 UTC by k.wuestermann
Modified: 2013-06-24 02:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description k.wuestermann 2013-01-22 10:42:07 UTC
In writer you can't access a box (German: Rahmen) which is located outside the normal text margin with left mouse click. It is because of the blue line for creating a heading line.

With a right click into the box, you get the context menu. By pressing ESC key the cursor is in the box.

---------------------------------------

How to reproduce:
1. new document
2. increase the top margin
3. create a text box
4. set the anchor to side (german:Seite)
5. drag the box above the to margin
6. left mouse click into the boy -> the cursor stays where is was and you see the blue line to create a heading line
7. use the blue field an create a heading line -> now you can click into the box

--------------------------------------

Expected behavior:
You can left click into the box without creating a heading line
Operating System: Linux (Other)
Version: 3.6.4.3 release
Comment 1 Joel Madero 2013-06-24 02:09:02 UTC
This seems to work for me with version 4.1 RC.

In English we don't have "anchor to side" in options, we have:

1. Anchor to page
2. Anchor to paragraph
3. To Character
4. As Charactoer


Results:
1. Works fine, dragged it up to header area, clicked off of box, left clicked into box and was able to get into the text box without creating a header

2. Same

3. Same

4. Can't because it's a character so can't move it into header

It's a little finicky but it works if I go a little slow - if I rush it the header thing does pop up and become in the way a bit but it seems to work.


Marking as WFM - if it's still an issue for you with version 4.0 or later please mark as UNCONFIRMED and we'll investigate again.