Bug Hunting Session
Bug 59714 - Using footnotes in large files causes extreme slowness
Summary: Using footnotes in large files causes extreme slowness
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-01-22 15:22 UTC by David
Modified: 2013-02-28 11:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample large document (912.26 KB, application/vnd.oasis.opendocument.text)
2013-01-22 15:22 UTC, David
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David 2013-01-22 15:22:23 UTC
Created attachment 73456 [details]
sample large document

Sorry guys.  I guess I'm the beta tester you love to hate.  After a couple other issues being fixed in version 4.0 I still am unable to upgrade.  This bug is probably related to bug 58029.  IO have attached a document to demonstrated this problem.  I am currently using Debian Testing on a quad core 3Ghz computer with 4GB memory. I'm assuming that the problem started with 3.5 since that is where the other bug started.  Version 3.4.6 works fine with this document.  I'm also assuming that this bug will affect all platforms since bug 58029 affected all platforms.  Load the document and you immediately notice that editing anything is a painfully slow process.  When checking the memory processes my one core is maxed out and the memory usage keeps climbing until the program crashes.  As in bug 58029 I think it has something to do with the headers.  When I turned them on things seemed to immediately get worse.
Comment 1 David 2013-01-22 15:29:10 UTC
I should mention that I'm testing it with the version found in http://dev-builds.libreoffice.org/daily/libreoffice-4-0/Linux-x86_64_11-Release-Configuration/2013-01-21_10.37.28/.
Comment 2 Julien Nabet 2013-01-22 19:33:21 UTC
Comment on attachment 73456 [details]
sample large document

mimetype fixed
Comment 3 David 2013-01-22 20:18:58 UTC
I forgot to also mention that the attachment is the same test document used in bugs 58029 & 52080 except that footnotes were added to the document.
Comment 4 David 2013-01-23 01:00:19 UTC
I did some more testing.  I think it's a footnotes problem. Without the headers being turned on the memory usage creeps up and one CPU core is maxed out.  Turning on the headers may just make it unusable more quickly. I changed the description to reflect this.
Comment 5 headsup 2013-02-02 15:07:53 UTC
Thanks for reporting this. 

I tested on w8 pro, x86 32 bit Libreoffice versions 3.6.5.2, 4.0.0.2, and 4.0.0.3. If you try to edit the header or the footer the application becomes unresponsive and eventually stops working and closes down. 

The document contains 7200 pages so it is unusually large IMHO.

I changed importance from highest / major to high / major as per triage flowchart.
Comment 6 David 2013-02-02 20:00:51 UTC
It may seem unusually large but I do have some files that I am unable to use on 4.0.  If you watch the cpu memory usage you'll notice that it keeps increasing.  On version 3.4.6 the document will load and then the cpu usage goes down and stays level.
Comment 7 David 2013-02-06 13:59:11 UTC
@Michael Meeks
I added you to the CC list because you fixed bug 58029 which I am almost certain is related to this bug.  When footnotes are added the same issue occurs as in that bug. See https://bugs.freedesktop.org/show_bug.cgi?id=58029#c11
Comment 8 David 2013-02-27 20:24:57 UTC
This bug seems to have been corrected as of version 4.0.1 RC1.  I don't know what fixed the problem but I've been using it for several days now and have not had an issue with this bug.  If I have the auto-spell check turned off when I load a document then the processor usage goes to near 0% soon after loading.  If the spell check is turned on then 1 core with show high usage until it finally gets done with the spell check but it doesn't seem to cause the program to behave more slowly.  Probably with an older computer it would be noticeable but that would be another bug.
Comment 9 Michael Meeks 2013-02-28 11:05:10 UTC
Hi David; thanks for that - yes, I strongly suspect the header/footer widgets are created for -every-page-in-the-universe- regardless of whether they are visible or not. That in turn creates some nightmare scalability problems.

I guess some more work to improve that would be good :-) but for now we fixed the scalability problem of ~1000's of VCL child-windows in writer :-)

Thanks for closing.