Bug 59731 - CRASH when close file after drag & drop slide from other document's Slides Pane
Summary: CRASH when close file after drag & drop slide from other document's Slides Pane
Status: RESOLVED DUPLICATE of bug 45911
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-22 19:22 UTC by Rich Ercolani
Modified: 2013-01-23 09:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
One of two files for reproducing this problem (21.12 KB, application/vnd.oasis.opendocument.presentation)
2013-01-23 07:58 UTC, Rich Ercolani
Details
The other of two files for reproducing this problem (181.00 KB, application/vnd.ms-powerpoint)
2013-01-23 07:58 UTC, Rich Ercolani
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rich Ercolani 2013-01-22 19:22:22 UTC
Problem description: 
Was editing a presentation, tried to drag a slide into a new position - the slide that was in the new position was of the template for the document, and did not contain the original information. Attempting to undo this caused OpenOffice to crash.

Steps to reproduce:
1. Move slide 
2. If slide is broken, try to undo
3. Crash

Current behavior:
Crash

Expected behavior:
Allow continued editing
              
I'll attach a copy of the requisite document for this to occur as soon as I can create a minimal document - it has information that is not public in it, so I need to scrub it.

Bug occurs on 3.6.2 and 3.6.4.3 - will try other versions while trying to clean up problem report.
Operating System: Windows 7
Version: 3.6.4.3 release
Comment 1 Rainer Bielefeld Retired 2013-01-23 07:32:29 UTC
OpenOffice.org???

@reporter:
Thank you for your report – unfortunately important information is missing.
May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to find out what information will be useful to reproduce your problem? 
Please:
- Write a meaningful Summary describing exactly what the problem is
- Attach a sample document (not only screenshot) or refer to an existing 
  sample document in an other Bug with a link; to attach a file to this 
  bug report, just click on "Add an attachment" right on this page.
- Contribute a document related step by step instruction containing every 
  key press and every mouse click how to reproduce your problem 
  (similar to example in Bug 43431)
– if possible contribute an instruction how to create a sample document 
  from the scratch
- add information 
  -- concerning your PC (video card, ...)
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO version (with Build ID if it's not a public release)
     and localization (UI language, Locale setting)
  –- Libo settings that might be related to your problems 
    (video hardware acceleration, Experimental features enabled, ...)
  -- how you launch LibO and how you opened the sample document
  –- Whether your problem persists when you renamed your user profile 
     before you launch LibO (please see
     <https://wiki.documentfoundation.org/UserProfile#User_profile_location>)
  -- everything else crossing your mind after you read linked texts
Comment 2 Rich Ercolani 2013-01-23 07:58:02 UTC
Created attachment 73498 [details]
One of two files for reproducing this problem

One...
Comment 3 Rich Ercolani 2013-01-23 07:58:27 UTC
Created attachment 73499 [details]
The other of two files for reproducing this problem

Two...
Comment 4 Rich Ercolani 2013-01-23 08:02:03 UTC
So, instructions for reproducing this.

1) Open one of the files
2) Open the other file
3) Drag-copy the slide from the PPT into the ODP
4) Attempt to quit without saving
5) Choose "Save" or "Discard" - it doesn't matter, it'll crash either way.
6) Boom! Crashes for me every time on 3.6.4.3 (Build ID: 2ef5aff) on Windows 7 x64.

The attached documents were originally an ODP of a presentation and an exported copy of said presentation to PDF - I ran into a problem where on reopening the ODP, the template slide I had been using, which had been copied from a freely available template online, had lost its background color. I attempted to copy a slide from the ppt (which did not have this problem) back to the odp and ran into this.

How these two files ended up in a state such that this could happen is...a fascinating question.
Comment 5 Rich Ercolani 2013-01-23 08:03:06 UTC
(In reply to comment #4)
> So, instructions for reproducing this.
> 
> 1) Open one of the files
> 2) Open the other file
> 3) Drag-copy the slide from the PPT into the ODP
> 4) Attempt to quit without saving
> 5) Choose "Save" or "Discard" - it doesn't matter, it'll crash either way.
> 6) Boom! Crashes for me every time on 3.6.4.3 (Build ID: 2ef5aff) on Windows
> 7 x64.
> 
> The attached documents were originally an ODP of a presentation and an
> exported copy of said presentation to PDF - I ran into a problem where on
> reopening the ODP, the template slide I had been using, which had been
> copied from a freely available template online, had lost its background
> color. I attempted to copy a slide from the ppt (which did not have this
> problem) back to the odp and ran into this.
> 
> How these two files ended up in a state such that this could happen is...a
> fascinating question.

...export to PPT, not PDF.

Similar to the above conflation of LibreOffice and OpenOffice.org - my apologies, I'm tired, and do know which I mean, even if I cannot type.
Comment 6 Rich Ercolani 2013-01-23 08:08:08 UTC
Additional notes:

- Reproducible for me even after removing my LibreOffice user profile
- if you select save on the save/discard prompt, it does appear to correctly save the result, but the resulting odp and (unmodified) ppt still suffer from this problem
- I'm running on a ThinkPad T420s with an Intel HD3000 and an NVIDIA NVS 4200M onboard, with driver versions 9.17.10.2867 and 9.18.13.479 (in NVIDIA download land, that translates to 304.79), respectively.
- This occurs with nothing else perceptibly running on the system for me - e.g. a clean boot with no other things open (other than, implicitly, explorer, since I am opening these by file association and double-clicking).
Comment 7 Rich Ercolani 2013-01-23 08:10:13 UTC
I'll go play the git bisect game and see if I can figure out where this starts and stops (I was going to just get a backtrace, but if I'm going to set up a debug environment just for that, I might as well also bisect...)
Comment 8 Rainer Bielefeld Retired 2013-01-23 09:45:24 UTC
[Reproducible] with reporter's sample document and Server Installation of "LibreOffice 3.6.2.1 rc  English UI/ German Locale [Build-ID:  ba822cc] on German WIN7 Home Premium (64bit).

Also works with 2 newly created Presentations without any edited contents:
1. Copy - Drag and Drop Slide of 1 Presentation (from Slides Pane) to 
   Slides pane of the other one
2. In P. with 2 slides: menu 'Files -> Close -> Discard'
   CRASH

Crash does not happen if you copy / paste from context menu.

Works fine with "LibreOffice 3.6.5.1 rc" German UI/ German Locale [Build-ID: 5b93205] {pull date 2013-01-18} on German WIN7 Home Premium (64bit), so I am pretty sure that this one is a DUP of "Bug 45911 - crash when drag/drop slide between two instances of Impress"

@reporter:
Thank you for your attention.
Please feel free to reopen this Bug if you find evidence that we have an independent issue here  (for example because the fix for the other bug does not work for you

*** This bug has been marked as a duplicate of bug 45911 ***
Comment 9 Rainer Bielefeld Retired 2013-01-23 09:51:01 UTC
This one also WFM with server  installation of  "LOdev  4.0.0.1+   -  ENGLISH UI / German Locale  [Build ID:  072fc07107e9849ed7050d18575b42049db9657)]"  {tinderbox: Win-x86@6, pull time 2013-01-16 09:31:57} on German WIN7 Home Premium (64bit) with own separate User Profile
Comment 10 Rainer Bielefeld Retired 2013-01-23 09:51:35 UTC
... what means that there are some doubts that this one really is a DUP