Bug 59798 - CONFIGURATION: Wrong Version info 4.0 .0.2
Summary: CONFIGURATION: Wrong Version info 4.0 .0.2
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.0.0.2 rc
Hardware: Other Windows (All)
: medium minor
Assignee: Andras Timar
URL:
Whiteboard: target:4.1.0 target:4.0.0
Keywords: regression
: 59960 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-24 11:01 UTC by Rainer Bielefeld Retired
Modified: 2013-02-01 05:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (25.54 KB, image/png)
2013-01-24 11:01 UTC, Rainer Bielefeld Retired
Details
About Screen (181.88 KB, image/png)
2013-01-24 11:44 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-01-24 11:01:42 UTC
Created attachment 73559 [details]
Screenshot

K. J. Wehorn's observation on <libreoffice-qa@lists.freedesktop.org> thread libreoffice-qa@lists.freedesktop.org is reproducible.

Anywhere I see "4.0 .0.2" instead of  "4.0.0.2"
Comment 1 Michael Stahl (CIB) 2013-01-24 11:22:59 UTC
that's not the About screen that K. J. Weghorn complained about
but some installation program, so there are 2 problems.
Comment 2 Andras Timar 2013-01-24 11:35:04 UTC
The root is the sama: we abuse PRODUCTEXTENSION variable as the second part of version number.
Comment 3 Michael Stahl (CIB) 2013-01-24 11:38:46 UTC
well previously we were abusing SHORT_PRODUCTEXTENSION for the same purpose :)
Comment 4 Rainer Bielefeld Retired 2013-01-24 11:44:33 UTC
Created attachment 73561 [details]
About Screen

András already anticipated my suspect concerning common root.
Comment 5 Michael Stahl (CIB) 2013-01-24 11:47:10 UTC
in my Windows master build i get in the About dialog
"Version 4.1.0.0.alpha0+",
and on Linux for my dbgutil build of 4.0RC2 i get "Version 4.0.0.2",
so can't reproduce that problem.

the Win installation wizard does have the spurious space in my master build.
which i'm guessing is from
instsetoo_native/inc_openoffice/windows/msi_languages/Control.ulf:en-US = "{&TahomaBold10}Welcome to the Installation Wizard for [ProductName]"
Comment 6 Not Assigned 2013-01-24 12:13:37 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3c0f360995741c16e93f49b1a1e771d0f4e40dc7

fdo#59798: MSI installer spurious space in version number



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Not Assigned 2013-01-24 12:41:08 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e2d60ae0bf885a39bb392729797b0fc6ec3a5fe5

fdo#59798: fix SDK MSI version "LOdev 4.1 SDK.0.0.alpha0"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Michael Stahl (CIB) 2013-01-24 12:50:33 UTC
the 2 commits should fix the LO installer and LO SDK installer version strings.

the reason why i'm getting the right version numbers in About dialog is that i'm using en_US build and you're not; i've changed some strings but forgot to tell timar about it so the translations are now out of sync.
Comment 9 Not Assigned 2013-01-24 13:11:36 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=72f0e26b6a5f7b3bb32d713227de189e0a7a2b4f&h=libreoffice-4-0

fdo#59798: MSI installer spurious space in version number


It will be available in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Not Assigned 2013-01-24 13:11:55 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c6a1ebfd96e0d05bd6b93d49dd3fdebc518c9328&h=libreoffice-4-0

fdo#59798: fix SDK MSI version "LOdev 4.1 SDK.0.0.alpha0"


It will be available in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Pedro 2013-01-24 18:37:27 UTC
Why isn't this cherry picked for 4.0.0? Isn't it in time for RC3?

It's not an important bug but... it just looks sloppy... If it's already fixed why not include it?
Comment 12 Andras Timar 2013-01-24 20:19:07 UTC
It is nominated for 4.0 RC3 but it needs 3 reviews. I'm pretty sure that it will go in. I'm talking about the installer part. I fixed the About box in translations module in libreoffice-4-0-0 branch.
Comment 13 Not Assigned 2013-01-28 08:29:15 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-0-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=55ede5572e4b242f73caaf557802ff38e6d1af29&h=libreoffice-4-0-0

fdo#59798: MSI installer spurious space in version number


It will be available already in LibreOffice 4.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Not Assigned 2013-01-28 08:29:33 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-0-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=67fcef018003a4baa8a758bb79cad459016009bc&h=libreoffice-4-0-0

fdo#59798: fix SDK MSI version "LOdev 4.1 SDK.0.0.alpha0"


It will be available already in LibreOffice 4.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Jean-Baptiste Faure 2013-02-01 05:18:44 UTC
*** Bug 59960 has been marked as a duplicate of this bug. ***