Bug Hunting Session
Bug 59803 - LibreOffice steals focus from other applications after startup
Summary: LibreOffice steals focus from other applications after startup
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-24 13:05 UTC by daniel.schaaaf
Modified: 2019-08-13 12:26 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description daniel.schaaaf 2013-01-24 13:05:20 UTC
1) start LibreOffice (with a big document to cause a long loading time)
2) switch to another application

=> LibreOffice will claim focus after it finished loading the document

When I switch focus to another application, I do this consciously to work with that application. LibreOffice is disturbing me by re-claiming focus.
Instead of stealing focus from another application, LibreOffice should flash its tab in the taskbar to show me that I can start working with my document.

Some LibreOffice documents take ages to load (10-60 seconds for big spread sheets) and I do not want to stare at a LibreOffice start screen during that time. When I continue working in another application, I do not want LibreOffice to interrupt me.
Comment 1 ign_christian 2013-07-26 07:33:44 UTC
Reproducible on LO 4.0.4.2 (Win7 32bit)

> Instead of stealing focus from another application, LibreOffice should flash
> its tab in the taskbar to show me that I can start working with my document.
I think that's the usual behavior like other applications.
Comment 2 QA Administrators 2015-04-01 14:40:39 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 3 Buovjaga 2015-04-22 12:02:48 UTC
No problem for me. WFM. Feel free to set back to NEW, if I'm wrong.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha0+ (x64)
Build ID: 211c12b9c64facd1c12f637a5229bd6a6feb032a
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-18_01:51:17
Locale: fi_FI
Comment 4 kie000 2019-08-13 12:15:09 UTC
V 6.1.3.2 (x64) Win7 64bit
CPU threads: 8; OS: Windows 6.1; UI render: default; 
Locale: en-GB (en_GB); Calc: group threaded

Steps to reproduce:
Libreoffice fully closed
Open a spreadsheet (ods) file with Libreoffice being the default app.


This has gotten so much worse it's really annoying, I don't mind the program grabbing focus once when it is completely loaded but the program now grabs focus THREE TIMES on startup at varied intervals.

Please fix this, LibreOffice should be a useful app, not an annoying pest.

But I agree with the original poster, Libreoffice should not steal focus, it should flash the taskbar button for the app.
Comment 5 kie000 2019-08-13 12:26:26 UTC
Also Version: 5.3.2.2
Build ID: 6cd4f1ef626f15116896b1d8e1398b56da0d0ee1
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
Locale: en-GB (en_GB); Calc: CL

The bug has even gotten worse since version 5 which only took focus twice on startup so far as I can tell although V5 did take focus before it was even ready.