Bug 59919 - EDITING: enhancement request: keep selected object in center when zooming -> works with Ctrl in Impress and Draw
Summary: EDITING: enhancement request: keep selected object in center when zooming -> ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-27 02:19 UTC by bugquestcontri
Modified: 2017-07-26 14:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugquestcontri 2013-01-27 02:19:06 UTC
When a object is selected and zoom in is used (clicking on the "+" at the right bottom of the screen) depending on the position of the object, is moves out of the screen. Readjusting of the position of the object is needed before continuation of zooming in possible. 

The same enhancement should be done for Draw as well

This would increase productivity.

Most likely the same 

I can be contacted.
Operating System: Windows XP
Version: 3.6.4.3 release
Comment 1 Jorendc 2013-02-06 14:55:53 UTC
I can reproduce this behavior using Impress (not tested with draw).

But I can't reproduce this behavior using this feature in Writer. Using the '+' in writer, I'll zoom to the object I selected/to the cursor.

Tested with LibreOffice Version 4.1.0.0.alpha0+ (Build ID: 1a3c90a292c7fc9060604151de9dc51eecf5b6a) with Linux Mint 14 x64

Kind regards,
Joren
Comment 2 Emir Sarı (away) 2013-02-08 02:25:06 UTC
Same behaviour is noticed when using Print Preview in Writer. And yes, it is very annoying.
Comment 3 bugquestcontri 2013-02-08 05:11:22 UTC
As I upgraded to 3.6.5.2 I tested writer, draw and impress and observe always the same behavior.

XP Prof / SP3
Comment 4 Timur 2017-07-26 10:46:35 UTC
1. request that clicking on the "+" should readjust a position in my view in not correct; simple clicking on the "+" should simply focus 
2. request is justified, but on zoom with holding Control
3. zoom with Control was the same when bug was reported, but later (around 5.0) does what's requested: focuses on selected object in Impress and Draw

So, I'll close as WFM. Please comment should you disagree.