Bug 83588 - Scrollwheel zoom centers page in Impress and Draw
Summary: Scrollwheel zoom centers page in Impress and Draw
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3 Daily
Hardware: Other All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: BSA target:4.4.0
Keywords: regression
: 83258 (view as bug list)
Depends on:
Blocks: Zoom-Issues
  Show dependency treegraph
 
Reported: 2014-09-07 15:55 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-07-26 15:54 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-09-07 15:55:56 UTC
When using the scrollwheel to zoom in and out in Impress and Draw, it also centers the document which makes it impossible to zoom into/out of a particular area easily.

Steps:
1) Open Impress
2) Draw a rectangle in the top left corner
3) Attempt to zoom into rectangle with a combination of ctrl+scrollwheel (zoom in/out), scrollwheel (pan up/down) and shift+scrollwheel (pan left/right)
4) Once you are able to zoom into the rectangle, zoom out ctrl+scrollwheel

Tested in 4.3.2 and master on Linux. It works correctly in 4.2.6.
Comment 1 Jacques Guilleron 2014-09-07 21:47:08 UTC
Hi Jay,

I reproduce this beha
Comment 2 Jacques Guilleron 2014-09-07 21:55:48 UTC
Again,

I reproduce this behaviour with Impress in LO 4.3.1.2 
Build ID: 958349dc3b25111dbca392fbc281a05559ef6848
and LO 4.4.0.0.alpha0+
Build ID: 37b9ea92ba81d74764a2345a9c75c65bfd272d2b
TinderBox: Win-x86@42, Branch:master, Time: 2014-08-26_09:37:01

I have the correct behaviour with LO 4.2.7.0.0+
Build ID: 92216be6ce13990b8ea6b6264c656d2bc1746401
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-07-14_16:21:42
under Windows 7 Home Premium

I set status to NEW.

regards,

Jacques
Comment 3 Jean-Baptiste Faure 2014-09-08 06:29:17 UTC
Not sure if this behavior is a bug or a feature. I am pretty sure I already saw a bug or a discussion asking for this behavior. Not able to search where at the moment.

Set status to NEEDINFO. 

Best regards. JBF
Comment 4 Maxim Monastirsky 2014-09-08 08:42:51 UTC
(In reply to comment #3)
> I am pretty sure I already
> saw a bug or a discussion asking for this behavior.
There is very similar Bug 53224, but it's an old bug while this one says it's a regression from 4.2 (which BTW I couldn't confirm).
Comment 5 Maxim Monastirsky 2014-09-08 09:22:26 UTC
OK, got the point. If at some point the slide is not centered, it will center it on each zoom in/out. This is indeed different in 4.3 from 4.2.
Comment 6 Maxim Monastirsky 2014-09-08 09:35:30 UTC
This change was made by Caolán in http://cgit.freedesktop.org/libreoffice/core/commit/?id=b179235f702e474b115ca479b603052f422346fd
Comment 7 Yousuf Philips (jay) (retired) 2014-09-08 11:26:43 UTC
Look forward to knowing why Caolán added it. The behaviour in writer and calc is for zooming not to center the document.
Comment 8 Caolán McNamara 2014-09-09 15:37:43 UTC
Yeah, its deliberate, and it also centers on changing slide as well, but we could tweak things a bit if necessary.

It centers of zooming because of complaints of...

"In "impress" when you are working on a main slide, it's very easy to cause the individual "slide" to move up or down, or not fit exactly when in "normal" mode."

So I investigated what powerpoint does (on the basis that's its the familiar app) and that's the behaviour there, and among other things, zooming centers there, so the problem of slide "slipping" around doesn't occur as easily.

In retrospect I think we could definitely exclude draw from that system, and maybe additionally not center if something is selected on the assumption that the desire is to zoom into the selected thing.
Comment 9 Yousuf Philips (jay) (retired) 2014-09-09 21:28:08 UTC
(In reply to comment #8)
> Yeah, its deliberate, and it also centers on changing slide as well, but we
> could tweak things a bit if necessary.

From my testing on master, it doesnt center on changing slides. It keeps it in the exact same position. Or am i misunderstanding you. :D

> It centers of zooming because of complaints of...
> 
> "In "impress" when you are working on a main slide, it's very easy to cause
> the individual "slide" to move up or down, or not fit exactly when in
> "normal" mode."
> 
> So I investigated what powerpoint does (on the basis that's its the familiar
> app) and that's the behaviour there, and among other things, zooming centers
> there, so the problem of slide "slipping" around doesn't occur as easily.

Well i'm new to impress so i'm not fully getting what you mean. Is 'main slide' a master slide?

> In retrospect I think we could definitely exclude draw from that system, and
> maybe additionally not center if something is selected on the assumption
> that the desire is to zoom into the selected thing.

Well i'm assuming at one point or another an object will be selected and then the people who asked for this behaviour change will be back saying it doesnt work correctly. :) For users who want to zoom into a particular object, the simplest means for them to achieve that would be the object zoom button.

I guess the easiest means to achieve the previous behaviour now is either by keyboard (using the arrow keys with the plus and minus keys) or mouse (the scrollbars and the zoom feature in the statusbar).
Comment 10 pafal 2014-09-27 22:26:36 UTC
I hope, you won't make this a feature for Draw. In such case, there is no quick-zoom-to-object-under-cursor feature. I hate looking for/clicking a button on the toolbar then selecting area to zoom in/out. Ctrl+wheel was quick, intuitive and practical. If you feel feature is needed, please make it selectable (user can choose which behavior he wants). Thanks.
Comment 11 Yousuf Philips (jay) (retired) 2014-09-27 23:31:59 UTC
Well now that a zoom mode button has been added by Maxim (bug 55903) and has been improved (bug 83572), the goals of this bug report can be achieved with that button rather than the scrollwheel, so i guess this bug can be closed.

(In reply to comment #10)
> I hope, you won't make this a feature for Draw. In such case, there is no
> quick-zoom-to-object-under-cursor feature. I hate looking for/clicking a
> button on the toolbar then selecting area to zoom in/out. Ctrl+wheel was
> quick, intuitive and practical. If you feel feature is needed, please make
> it selectable (user can choose which behavior he wants). Thanks.

pafal: I seems to be confused by your words as this feature is already implemented in draw and i was requesting it to be removed from draw. Encase you didnt already know this, there is a quick-zoom-to-object button in the zoom drop down menu called 'Object Zoom'.
Comment 12 Allan Macdonald 2014-10-01 13:39:08 UTC
(In reply to comment #11)
> Well now that a zoom mode button has been added by Maxim (bug 55903) and has
> been improved (bug 83572), the goals of this bug report can be achieved with
> that button rather than the scrollwheel, so i guess this bug can be closed.

Object Zoom does not solve the issue described in this bug report.  For one thing, when using Object Zoom, the selected object fills the entire screen so it is awkward to zoom to a particular region that might have several objects or a part of an object.  Either you have to select a group of objects or, if that is not desirable, you have to draw a rectangle around the region you are zooming to, highlight it and then execute Object Zoom.  That is somewhat awkward to say the least.

I vote for continuing to restore the correct zoom on scroll wheel functionality such that the zoom occurs at either the mouse pointer position, or at least the center of the current view.

Thanks to Jay for reporting this issue.
Comment 13 Yousuf Philips (jay) (retired) 2014-10-02 10:50:13 UTC
Hi Allan,

I was referring to the Zoom Mode button and not the Object Zoom button. If you have a daily build master, you can try it out to see how well it functions for zooming in, out and panning.

I agree with Caolan that in Draw this centering functionality should be removed, so its worth using this bug to fix that issue.
Comment 14 Alexandru Staetu 2014-10-05 11:56:09 UTC
It is intuitive to zoom an area using ctrl and mousewheel. To overwrite the default functionality, a checkbox can be added in the preferences panel, in order to center on the slide when zooming is performed.
Comment 15 Regina Henschel 2014-10-06 08:38:57 UTC
See issue 83258 for the same defect.
Read http://ask.libreoffice.org/en/question/40741/zoom-mouse-behavior-draw/ for another complain.

Other drawing applications like Inkscape or Corel Draw zoom to the mouse position. The old behavior of zooming to the middle of the current window was already unusual but still useful. The new behavior is useless in Draw, especially for users who work on page formats larger than DIN A4.
Comment 16 Jouni Järvinen 2014-10-14 15:39:38 UTC
What can I say ? Useless "feature" added by someone. Worth the delete, or at least adding a setting to toggle between zooming to center and to cursor.
Comment 18 Yousuf Philips (jay) (retired) 2014-10-21 18:33:49 UTC
*** Bug 83258 has been marked as a duplicate of this bug. ***
Comment 19 Yousuf Philips (jay) (retired) 2014-10-21 19:44:43 UTC
Thanks Caolan for porting it to 4.3 and 4.3.3, but i didnt see anything in master port in gerrit, or was that already done a while back?
Comment 20 Adolfo Jayme 2014-10-22 01:33:56 UTC
(In reply to Jouni Järvinen from comment #16)
> What can I say ? Useless "feature" added by someone.

What could you say? Perhaps being a tad less rude would help...
Comment 22 Yousuf Philips (jay) (retired) 2015-02-17 07:16:22 UTC
Something seems to be wrong as ctrl+scrolwheel no longer centers in impress. Tested this on 4.3.6 and master.
Comment 23 Caolán McNamara 2015-02-17 10:19:27 UTC
"When using the scrollwheel to zoom in and out in Impress and Draw, it also centers the document which makes it impossible to zoom into/out of a particular area easily."

...

"Something seems to be wrong as ctrl+scrolwheel no longer centers in impress. Tested this on 4.3.6 and master."

The original bug is that its a bug that it centers, the last comment is that its a bug because it no longer centers ?
Comment 24 Yousuf Philips (jay) (retired) 2015-02-17 12:34:40 UTC
Comment 8: "In retrospect I think we could definitely exclude draw from that system, and maybe additionally not center if something is selected on the assumption that the desire is to zoom into the selected thing."

Comment 13: "I agree with Caolan that in Draw this centering functionality should be removed, so its worth using this bug to fix that issue."

Maybe there was some misunderstandings in the discussions, but my understanding was that the functionality was reverted in Draw and left as is in Impress because others had previously asked for the functionality.
Comment 25 Caolán McNamara 2015-02-17 14:20:05 UTC
ah, the whole thing was a thankless quagmire so I reverted everything back to how it was initially. The new little "center everything ideally" button in the statusbar wasn't controversial so that'll have to do.
Comment 26 Jouni Järvinen 2015-02-17 15:06:56 UTC
Instead of having either forcibly centering on the page -or- zooming to the location of the cursor, allow both, with zooming to the location of the cursor being the default, but able to change from settings and toggle between the 2 modes by using some additional button, like Shift+CTRL+scroll to toggle to center-to-page when zoom-to-cursor activated in settings, and toggle to zoom-to-cursor when center-to-page is activated in settings.

Way better than having just either.
Comment 27 Yousuf Philips (jay) (retired) 2015-02-22 01:05:46 UTC
Caolan: Thanks for the explain and sorry for the wasted time.

Jouni: I'm closing this bug and opening another bug about zooming into the center of the mouse in bug 89547.