Bug 89547 - Mouse scrollwheel zoom-to centering options
Summary: Mouse scrollwheel zoom-to centering options
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 89347 (view as bug list)
Depends on:
Blocks: Zoom-Issues
  Show dependency treegraph
 
Reported: 2015-02-22 01:05 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-02-02 19:11 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-02-22 01:05:34 UTC
Currently holding down shift and moving the scrollwheel zooms to the center of window, while with other drawing programs, it zooms to the center of the mouse pointer, so it would be useful to have the same behaviour.

http://ask.libreoffice.org/en/question/40741/zoom-mouse-behavior-draw/
Comment 1 V Stuart Foote 2015-02-22 02:28:30 UTC

*** This bug has been marked as a duplicate of bug 53224 ***
Comment 2 Yousuf Philips (jay) (retired) 2015-02-22 07:20:17 UTC
Seems Caolan fixed the center to mouse position in bug 83588 and Jouni has suggested that we have both zoom to center and zoom to mouse in bug 83588 comment 26. Jouni suggested we set shift+ctrl+scroll to do the none default zoom behaviour, which now is zoom to center.
Comment 3 Jouni Järvinen 2015-02-22 14:27:24 UTC
(In reply to Jay Philips from comment #2)
> Jouni suggested we set shift+ctrl+scroll to do the none default
> zoom behaviour, which now is zoom to center.

I have no clue what the shortcuts are in LO, but Shift+CTRL+scroll is most likely not in use.
Comment 4 V Stuart Foote 2015-02-22 16:05:08 UTC
Ok, sure we can provide alternate use of the m.scrollwheel. <Ctrl>+<Shift> is available.

But it should not just be Draw/Impress. From UX perspective we should make use of m.scrollwheel consistent for graphic/image and page elements across all components... right now Writer, Calc and Math are a mess in their zooming.

A consistent behavior across all components might be:

1.) pan -- (this is correct and needs no changes)
    <Shift>+M.scrollwheel -- Pan Left/Right
    M.scrollwheel -- Pan Up/Down

2.) default Zoom centered on Mouse pointer with <Ctrl>+M.scrollwheel

3.) Zoom on center of
   a. selected object
   b. active frame/cell
   c. page/slide

   with <Ctrl>+<Shift>+M.scrollwheel (the non-default actions).


And, we also have the issue of needing to provide accelerators for doing the same as m.scrollwheel.

For that possibly: <Ctrl>+<minus> ZoomOut, <Shift>+<plus> ZoomIn centered on Mouse pointer. And same but modified with <Alt> to center on object/frame/page.

From a UX perspective consistency of function would be helpful--but a lot of churn, including changes to Help & Documentation to achieve it.

@Caolán, Kendy -- dev thoughts on if this extensive a rework would make sense?
Comment 5 Jouni Järvinen 2015-02-22 17:10:59 UTC
(In reply to V Stuart Foote from comment #4)
> But it should not just be Draw/Impress. From UX perspective we should make
> use of m.scrollwheel consistent for graphic/image and page elements across
> all components... right now Writer, Calc and Math are a mess in their
> zooming.

Totally agree.
Comment 6 Yousuf Philips (jay) (retired) 2015-02-22 22:36:55 UTC
Have to disagree with you Stuart that <Ctrl>+M.scrollwheel should zoom centered on mouse pointer for Writer and Calc, as this isnt the norm for document-type applications like word processor and web browsers.
Comment 7 V Stuart Foote 2015-02-23 04:04:14 UTC
@Jay,(In reply to Jay Philips from comment #6)
> Have to disagree with you Stuart that <Ctrl>+M.scrollwheel should zoom
> centered on mouse pointer for Writer and Calc, as this isnt the norm for
> document-type applications like word processor and web browsers.

Hmm, LibreOffice is an integrated suite of office applications--we have all the latitude needed to change paradigms to suit UX needs of the suite. We are not bound by what other programs have done. The various HIG are stressing simpler UI--normalizing <Ctrl>+m.scrollwheel to follow mouse pointer as default across the suite simplifies the UX (and I suspect would clean up the code).

Do you think it is correct now? Hardly... 
How do Calc or Writer, or Math for that matter zoom with m.scrollwheel at this point? What is the focus behavior? Any consistentcy? Nope... 

Examples--

1.) Calc:  open new document, select cell J20

<Ctrl>+m.scrollwheel zooms anchored upper left -- the cell with focus zooms right out of screen.  Expand the J20 cell and insert an image into the cell. Select the cell--can you zoom to it? Select the image--can you zoom to it? Where is zoom focus?

2.) Math: use the examples "f ( x ) = {1} over {%sigma sqrt{2%pi} }e^-{{(x-%mu)^2} over {2%sigma^2}}" and "f ( x ) = sum from { { i = 0 } } to { infinity } { {f^{(i)}(0)} over {i!} x^i}" in normal mode, or w/Experimental features enabled. Get a long and tall equation.

<Ctrl>+m.scrollwheel zooms formula left aligned, on a complex multisection formula, selection of a formula element can not be isolated and zoomed to.

3.) Writer: open new document, insert an image any flavor. Insert drawing graphics circle, square and a shape (the Sun is nice). Type a row of text and set it aligned right. 

Place cursor at start of line of text, <Ctrl>+m.scrollwheel follows the text cursor. Now select the image, <Ctrl>+m.scrollwheel zooms in an out centering on the image object.  Select one of the shapes, <Ctrl>+m.scrollwheel zooms where? It ignores the selected object and zooms the page.  Now insert a table 3x3. Position cursor into the R3C3 cell. <Ctrl>+m.scrollwheel zoom--it follows the active cursor.  So thats text objects, images and table cells that m.scrollwheel follows, but graphic objects do not.

Point is there is no reason in HIG for these widgets not to use consistent and simplified UI--we can do what makes sense.
Comment 8 peterpan 2015-03-14 21:13:43 UTC
*** Bug 89347 has been marked as a duplicate of this bug. ***
Comment 9 peterpan 2015-03-14 21:19:50 UTC
(In reply to peterpan from comment #8)
> *** Bug 89347 has been marked as a duplicate of this bug. ***

In the duplicate I was kind of suggesting that ctrl+mousewheel in writer should center on text area vertical axis. In current environment where widescreen monitors are kind of standart and when toolbars are moved from top/bottom position to left/right positions, centering on window causes to hide text under toolbars. thus it would be appropriate to center not within window, but within text area.
Comment 10 Owen Genat (retired) 2015-03-15 00:08:17 UTC
The proposals by Stuart seem very good to me. I miss this zoom-on-mouse-pointer ability in Inkscape and it would be good to have consistency in terms of the three actions across all components.
Comment 11 Robinson Tryon (qubit) 2016-08-25 04:45:00 UTC Comment hidden (no-value, obsolete)
Comment 12 Heiko Tietze 2018-01-30 10:59:32 UTC
System standard is to scroll vertically with the wheel, and horizontally with shift+wheel. Quasi standard is to zoom on ctrl+wheel. Don't see any special function like zoom at center for Inkscape. GIMP has alt+wheel for opacity, shift+ctrl+wheel changes the brush and shift+alt+wheel the pattern - nerdy functions.

I would resolve the ticket as WFM (zoom at cursor position) or WF (center zoom). Center-zoom is not a common function, hard to integrate (alt+wheel is left only), and has not much benefit (haven't seen any clear use case).

If there is an issue with Writer we better handle it in another ticket.
Comment 13 Yousuf Philips (jay) (retired) 2018-02-02 19:11:53 UTC
(In reply to Heiko Tietze from comment #12)
> System standard is to scroll vertically with the wheel, and horizontally
> with shift+wheel. Quasi standard is to zoom on ctrl+wheel. Don't see any
> special function like zoom at center for Inkscape.

Inkscape zooms at cursor pointer with ctrl+wheel, scrolls horizontally with shift+wheel and scrolls vertically with alt+wheel.

Calligra Flow zooms at center with ctrl+wheel, scrolls vertically with shift+wheel and scrolls horizontally with alt+wheel.

MS Publisher zooms at center with ctrl+wheel, while shift and alt modifiers dont change the behaviour of horizontal scrolling.

> GIMP has alt+wheel for
> opacity, shift+ctrl+wheel changes the brush and shift+alt+wheel the pattern
> - nerdy functions.

GIMP isnt a suitable example of how mouse wheel functionality should be configured as it doesnt show an entire page like how it is in Draw. Also alt+wheel for opacity only works when you a drawing tool selected.

> I would resolve the ticket as WFM (zoom at cursor position) or WF (center
> zoom). Center-zoom is not a common function, hard to integrate (alt+wheel is
> left only), and has not much benefit (haven't seen any clear use case).

Yep WFM.